summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2008-10-19 14:14:07 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2008-10-19 14:14:07 +0000
commitd890a7eb00a3c2af8b161917055e2e214ded8fce (patch)
treeb933e046b9c108bf16269d4d8ffb7aa54976cab6 /app-i18n/ibus-m17n
parentVersion bumped. (diff)
downloadgentoo-2-d890a7eb00a3c2af8b161917055e2e214ded8fce.tar.gz
gentoo-2-d890a7eb00a3c2af8b161917055e2e214ded8fce.tar.bz2
gentoo-2-d890a7eb00a3c2af8b161917055e2e214ded8fce.zip
Version bumped.
(Portage version: 2.2_rc12/cvs/Linux 2.6.27-gentoo x86_64)
Diffstat (limited to 'app-i18n/ibus-m17n')
-rw-r--r--app-i18n/ibus-m17n/ChangeLog8
-rw-r--r--app-i18n/ibus-m17n/ibus-m17n-0.1.1.20081013.ebuild56
2 files changed, 63 insertions, 1 deletions
diff --git a/app-i18n/ibus-m17n/ChangeLog b/app-i18n/ibus-m17n/ChangeLog
index 2fad22f1ced7..767103430f9b 100644
--- a/app-i18n/ibus-m17n/ChangeLog
+++ b/app-i18n/ibus-m17n/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-i18n/ibus-m17n
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-m17n/ChangeLog,v 1.2 2008/10/09 15:04:17 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-m17n/ChangeLog,v 1.3 2008/10/19 14:14:07 matsuu Exp $
+
+*ibus-m17n-0.1.1.20081013 (19 Oct 2008)
+
+ 19 Oct 2008; MATSUU Takuto <matsuu@gentoo.org>
+ +ibus-m17n-0.1.1.20081013.ebuild:
+ Version bumped.
*ibus-m17n-0.1.1.20081009 (09 Oct 2008)
diff --git a/app-i18n/ibus-m17n/ibus-m17n-0.1.1.20081013.ebuild b/app-i18n/ibus-m17n/ibus-m17n-0.1.1.20081013.ebuild
new file mode 100644
index 000000000000..9b10ad400f70
--- /dev/null
+++ b/app-i18n/ibus-m17n/ibus-m17n-0.1.1.20081013.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-m17n/ibus-m17n-0.1.1.20081013.ebuild,v 1.1 2008/10/19 14:14:07 matsuu Exp $
+
+inherit python
+
+DESCRIPTION="The M17N engine IMEngine for IBus Framework"
+HOMEPAGE="http://code.google.com/p/ibus/"
+SRC_URI="http://ibus.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND="app-i18n/ibus
+ dev-libs/m17n-lib
+ >=dev-lang/python-2.5
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ dev-lang/swig
+ dev-util/pkgconfig
+ dev-db/m17n-db
+ dev-db/m17n-contrib
+ >=sys-devel/gettext-0.16.1"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ mv py-compile py-compile.orig || die
+ ln -s "$(type -P true)" py-compile || die
+}
+
+src_compile() {
+ econf $(use_enable nls) || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog NEWS README
+}
+
+pkg_postinst() {
+ ewarn "This package is very experimental, please report your bugs to"
+ ewarn "http://ibus.googlecode.com/issues/list"
+ elog
+ elog "You should run ibus-setup and enable IM Engines you want to use!"
+ elog
+ python_mod_optimize /usr/share/${PN}/engine
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/${PN}/engine
+}