summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2009-01-02 16:25:59 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2009-01-02 16:25:59 +0000
commita80550725a8538eb2fc0ad76d778a394c01e8d6e (patch)
tree677a3dc03f3fd9fbb3a8617f7248cba58491b001 /app-i18n/ibus-table
parentAdding local use flags for app-i18n/ibus-table-{erbi,wubi,zhengma}. (diff)
downloadgentoo-2-a80550725a8538eb2fc0ad76d778a394c01e8d6e.tar.gz
gentoo-2-a80550725a8538eb2fc0ad76d778a394c01e8d6e.tar.bz2
gentoo-2-a80550725a8538eb2fc0ad76d778a394c01e8d6e.zip
Version bumped.
(Portage version: 2.1.6.4/cvs/Linux 2.6.28-gentoo x86_64)
Diffstat (limited to 'app-i18n/ibus-table')
-rw-r--r--app-i18n/ibus-table/ChangeLog10
-rw-r--r--app-i18n/ibus-table/ibus-table-0.1.2.20090101.ebuild60
2 files changed, 68 insertions, 2 deletions
diff --git a/app-i18n/ibus-table/ChangeLog b/app-i18n/ibus-table/ChangeLog
index 3f495fce1cb3..e9446b340906 100644
--- a/app-i18n/ibus-table/ChangeLog
+++ b/app-i18n/ibus-table/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-i18n/ibus-table
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-table/ChangeLog,v 1.3 2008/11/16 17:14:56 matsuu Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-table/ChangeLog,v 1.4 2009/01/02 16:25:59 matsuu Exp $
+
+*ibus-table-0.1.2.20090101 (02 Jan 2009)
+
+ 02 Jan 2009; MATSUU Takuto <matsuu@gentoo.org>
+ +ibus-table-0.1.2.20090101.ebuild:
+ Version bumped.
*ibus-table-0.1.1.20081115 (16 Nov 2008)
diff --git a/app-i18n/ibus-table/ibus-table-0.1.2.20090101.ebuild b/app-i18n/ibus-table/ibus-table-0.1.2.20090101.ebuild
new file mode 100644
index 000000000000..1f75a7726b52
--- /dev/null
+++ b/app-i18n/ibus-table/ibus-table-0.1.2.20090101.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-table/ibus-table-0.1.2.20090101.ebuild,v 1.1 2009/01/02 16:25:59 matsuu Exp $
+
+inherit eutils python
+
+DESCRIPTION="The Table Engine for IBus Framework"
+HOMEPAGE="http://code.google.com/p/ibus/"
+SRC_URI="http://ibus.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="minimal nls"
+
+RDEPEND="app-i18n/ibus
+ >=dev-lang/python-2.5
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( >=sys-devel/gettext-0.16.1 )"
+
+pkg_setup() {
+ if ! built_with_use '>=dev-lang/python-2.5' sqlite; then
+ ewarn "You need build dev-lang/python with \"sqlite\" USE flag!"
+ die "Please rebuild dev-lang/python with sqlite USE flag!"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ mv py-compile py-compile.orig || die
+ ln -s "$(type -P true)" py-compile || die
+}
+
+src_compile() {
+ econf \
+ $(use_enable !minimal additional) \
+ $(use_enable nls) || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog NEWS README
+}
+
+pkg_postinst() {
+ ewarn "This package is very experimental, please report your bugs to"
+ ewarn "http://ibus.googlecode.com/issues/list"
+ elog
+ elog "You should run ibus-setup and enable IM Engines you want to use!"
+ elog
+ python_mod_optimize /usr/share/${PN}/engine
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/${PN}/engine
+}