summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2005-12-04 03:15:37 +0000
committerMamoru Komachi <usata@gentoo.org>2005-12-04 03:15:37 +0000
commitc52cb9faae75267aaadb47ce72c114e8ff48fd2c (patch)
tree72f1ff43463da6eedfce1b75c604dca7579c1edd /app-i18n/imhangul/imhangul-0.9.13.ebuild
parentVersion bumped. Marked 4.1 stable on x86. Thanks to Jung Tae-young <master@my... (diff)
downloadgentoo-2-c52cb9faae75267aaadb47ce72c114e8ff48fd2c.tar.gz
gentoo-2-c52cb9faae75267aaadb47ce72c114e8ff48fd2c.tar.bz2
gentoo-2-c52cb9faae75267aaadb47ce72c114e8ff48fd2c.zip
Version bumped. Marked 0.9.12 stable on x86. Thanks to Jeongsu Kim <jeongsu@bmp.pe.kr>; bug #113444.
(Portage version: 2.0.52-r1)
Diffstat (limited to 'app-i18n/imhangul/imhangul-0.9.13.ebuild')
-rw-r--r--app-i18n/imhangul/imhangul-0.9.13.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/app-i18n/imhangul/imhangul-0.9.13.ebuild b/app-i18n/imhangul/imhangul-0.9.13.ebuild
new file mode 100644
index 000000000000..d35099a53c93
--- /dev/null
+++ b/app-i18n/imhangul/imhangul-0.9.13.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/imhangul/imhangul-0.9.13.ebuild,v 1.1 2005/12/04 03:15:37 usata Exp $
+
+IUSE=""
+
+DESCRIPTION="Gtk+-2.0 Hangul Input Modules"
+HOMEPAGE="http://imhangul.kldp.net/"
+SRC_URI="http://kldp.net/frs/download.php/2808/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+
+DEPEND=">=x11-libs/gtk+-2.2.0"
+
+get_gtk_confdir() {
+ if useq amd64 || ( [ "${CONF_LIBDIR}" == "lib32" ] && useq x86 ) ; then
+ echo "/etc/gtk-2.0/${CHOST}"
+ else
+ echo "/etc/gtk-2.0"
+ fi
+}
+
+src_compile() {
+ sed -i -e "/^moduledir/d" -e "/# moduledir/s/# //" Makefile.* || die
+ econf || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ dodoc AUTHORS ChangeLog INSTALL NEWS README TODO
+}
+
+pkg_postinst() {
+ gtk-query-immodules-2.0 > ${ROOT}$(get_gtk_confdir)/gtk.immodules
+
+ einfo ""
+ einfo "If you want to use one of the module as a default input method, "
+ einfo ""
+ einfo "export GTK_IM_MODULE=hangul2 // 2 input type"
+ einfo "export GTK_IM_MODULE=hangul3f // 3 input type"
+ einfo ""
+}
+
+
+pkg_postrm() {
+ gtk-query-immodules-2.0 > ${ROOT}$(get_gtk_confdir)/gtk.immodules
+}