summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNaohiro Aota <naota@gentoo.org>2013-01-15 09:20:59 +0000
committerNaohiro Aota <naota@gentoo.org>2013-01-15 09:20:59 +0000
commita38d0fdd3499cba59aa23c0badc5dc1e0982e513 (patch)
tree74e0bd974db4d446ab2cf7c59525a759d534b12b /app-i18n/scim-input-pad
parentx86 stable wrt #444764 (diff)
downloadgentoo-2-a38d0fdd3499cba59aa23c0badc5dc1e0982e513.tar.gz
gentoo-2-a38d0fdd3499cba59aa23c0badc5dc1e0982e513.tar.bz2
gentoo-2-a38d0fdd3499cba59aa23c0badc5dc1e0982e513.zip
bumped. #451904
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key F8551514)
Diffstat (limited to 'app-i18n/scim-input-pad')
-rw-r--r--app-i18n/scim-input-pad/ChangeLog9
-rw-r--r--app-i18n/scim-input-pad/scim-input-pad-0.1.3.1.ebuild56
2 files changed, 63 insertions, 2 deletions
diff --git a/app-i18n/scim-input-pad/ChangeLog b/app-i18n/scim-input-pad/ChangeLog
index 5b0067473b84..a8073a201fd8 100644
--- a/app-i18n/scim-input-pad/ChangeLog
+++ b/app-i18n/scim-input-pad/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-i18n/scim-input-pad
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-input-pad/ChangeLog,v 1.10 2012/08/09 14:34:59 naota Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-input-pad/ChangeLog,v 1.11 2013/01/15 09:20:59 naota Exp $
+
+*scim-input-pad-0.1.3.1 (15 Jan 2013)
+
+ 15 Jan 2013; Naohiro Aota <naota@gentoo.org> +scim-input-pad-0.1.3.1.ebuild:
+ bumped. #451904
09 Aug 2012; Naohiro Aota <naota@gentoo.org> scim-input-pad-0.1.3.ebuild:
Remove intltool.m4 to update it. #428540
diff --git a/app-i18n/scim-input-pad/scim-input-pad-0.1.3.1.ebuild b/app-i18n/scim-input-pad/scim-input-pad-0.1.3.1.ebuild
new file mode 100644
index 000000000000..2c310c106b13
--- /dev/null
+++ b/app-i18n/scim-input-pad/scim-input-pad-0.1.3.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-input-pad/scim-input-pad-0.1.3.1.ebuild,v 1.1 2013/01/15 09:20:59 naota Exp $
+
+EAPI="4"
+
+inherit autotools
+
+DESCRIPTION="Input pad for SCIM used to input symbols and special characters"
+HOMEPAGE="http://www.scim-im.org/"
+SRC_URI="mirror://sourceforge/scim/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND=">=app-i18n/scim-1.2.0
+ >=x11-libs/gtk+-2.6.0:2"
+
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.33
+ virtual/pkgconfig"
+
+src_prepare() {
+ rm "${S}"/m4/intltool.m4 || die
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable nls) || die "Error: econf failed!"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Error: install failed!"
+ dodoc ChangeLog README
+}
+
+pkg_postinst() {
+
+ elog
+ elog "The SCIM input pad should be startable from the SCIM (and Skim)"
+ elog "systray icon right click menu. You will have to restart SCIM"
+ elog "(or Skim) in order for the menu entry to appear (you may simply"
+ elog "restart your X server). If you want to use it immediately, just"
+ elog "start the SCIM input pad, using the 'scim-input-pad' command."
+ elog
+ elog "To use, select the text zone you wish to write in, and just"
+ elog "click on the wanted character in the right multilevel tabbed"
+ elog "table, from the SCIM Input Pad interface."
+ elog
+ elog "To add new characters to the tables, see the documentation"
+ elog "(README file in /usr/share/doc/${PF})."
+ elog
+
+}