summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2005-10-30 04:06:07 +0000
committerMamoru Komachi <usata@gentoo.org>2005-10-30 04:06:07 +0000
commita47e64fa2ef7e2f255ab4fc975d7499018571e27 (patch)
tree3ed6f0d00446da97820871fc51fee585566d12a3 /app-i18n/scim-prime/scim-prime-0.3.0.ebuild
parentVersion bumped. (diff)
downloadgentoo-2-a47e64fa2ef7e2f255ab4fc975d7499018571e27.tar.gz
gentoo-2-a47e64fa2ef7e2f255ab4fc975d7499018571e27.tar.bz2
gentoo-2-a47e64fa2ef7e2f255ab4fc975d7499018571e27.zip
Version bumped.
(Portage version: 2.0.52-r1)
Diffstat (limited to 'app-i18n/scim-prime/scim-prime-0.3.0.ebuild')
-rw-r--r--app-i18n/scim-prime/scim-prime-0.3.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-i18n/scim-prime/scim-prime-0.3.0.ebuild b/app-i18n/scim-prime/scim-prime-0.3.0.ebuild
new file mode 100644
index 000000000000..7b84e46b4f79
--- /dev/null
+++ b/app-i18n/scim-prime/scim-prime-0.3.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-prime/scim-prime-0.3.0.ebuild,v 1.1 2005/10/30 04:05:17 usata Exp $
+
+DESCRIPTION="Japanese input method PRIME IMEngine for SCIM"
+HOMEPAGE="http://scim-imengine.sourceforge.jp/index.cgi?cmd=view;name=SCIMPRIME"
+SRC_URI="mirror://sourceforge.jp/scim-imengine/17192/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="|| ( >=app-i18n/scim-1.0 >=app-i18n/scim-cvs-1.0 )
+ >=app-i18n/prime-1.0.0"
+
+src_install() {
+ make DESTDIR=${D} install || die "make install failed"
+
+ dodoc AUTHORS THANKS README
+}
+
+pkg_postinst() {
+ einfo
+ einfo "To use SCIM, you should use the following in your user startup scripts"
+ einfo "such as .gnomerc or .xinitrc:"
+ einfo
+ einfo "LANG='your_language' scim -d"
+ einfo "export XMODIFIERS=@im=SCIM"
+ einfo "export GTK_IM_MODULE=scim"
+ einfo "export QT_IM_MODULE=scim"
+ einfo
+}