summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2007-10-07 16:28:26 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2007-10-07 16:28:26 +0000
commit1aaaf8b3a9a9cb8750511681b4339ac5cf6cf5d4 (patch)
tree7ab2ffc34548596928425a7fbadce0a376212c0d /app-i18n/skktools/skktools-1.3.1-r1.ebuild
parentppc stable, bug #194236 (diff)
downloadgentoo-2-1aaaf8b3a9a9cb8750511681b4339ac5cf6cf5d4.tar.gz
gentoo-2-1aaaf8b3a9a9cb8750511681b4339ac5cf6cf5d4.tar.bz2
gentoo-2-1aaaf8b3a9a9cb8750511681b4339ac5cf6cf5d4.zip
Fixed emacs support submitted by Ulrich Mueller, bug #194768.
(Portage version: 2.1.3.9)
Diffstat (limited to 'app-i18n/skktools/skktools-1.3.1-r1.ebuild')
-rw-r--r--app-i18n/skktools/skktools-1.3.1-r1.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/app-i18n/skktools/skktools-1.3.1-r1.ebuild b/app-i18n/skktools/skktools-1.3.1-r1.ebuild
new file mode 100644
index 000000000000..3efb47f2dda7
--- /dev/null
+++ b/app-i18n/skktools/skktools-1.3.1-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/skktools/skktools-1.3.1-r1.ebuild,v 1.1 2007/10/07 16:28:25 matsuu Exp $
+
+inherit elisp-common eutils
+
+DESCRIPTION="SKK utilities to manage dictionaries"
+HOMEPAGE="http://openlab.jp/skk/"
+SRC_URI="http://openlab.ring.gr.jp/skk/tools/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="emacs gdbm"
+
+DEPEND="emacs? ( virtual/emacs )
+ gdbm? ( sys-libs/gdbm )
+ !gdbm? ( sys-libs/db )
+ >=dev-libs/glib-2"
+
+SITEFILE=50${PN}-gentoo.el
+
+src_compile() {
+ econf $(use_with gdbm) || die
+ emake || die
+ if use emacs; then
+ elisp-compile skk-xml.el || die
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dobin saihenkan.rb
+ if use emacs; then
+ elisp-install ${PN} skk-xml.{el,elc} || die
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+ fi
+
+ insinto /usr/share/skk
+ doins unannotation.awk
+
+ dodoc ChangeLog README READMEs/*
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrmt() {
+ use emacs && elisp-site-regen
+}