summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-03-29 10:45:43 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-03-29 10:45:43 +0000
commitbb8e069b501b10d5f9322b0765eb4726897da28e (patch)
tree27c4a4c1a76f908979fa4d2fd5a70181a479f5cb /app-i18n/uim/files
parentBackport x11-libs/libnotify >= 0.7 patch to current stable. (diff)
downloadgentoo-2-bb8e069b501b10d5f9322b0765eb4726897da28e.tar.gz
gentoo-2-bb8e069b501b10d5f9322b0765eb4726897da28e.tar.bz2
gentoo-2-bb8e069b501b10d5f9322b0765eb4726897da28e.zip
old
(Portage version: 2.2.0_alpha29/cvs/Linux x86_64)
Diffstat (limited to 'app-i18n/uim/files')
-rw-r--r--app-i18n/uim/files/uim-1.5.7-kde4-applet.patch12
-rw-r--r--app-i18n/uim/files/uim-1.5.7-kde4.patch198
-rw-r--r--app-i18n/uim/files/uim-1.5.7-qt4.7.patch14
-rw-r--r--app-i18n/uim/files/uim-1.6.0-gettext.patch16
-rw-r--r--app-i18n/uim/files/uim-1.6.0-sandbox-violation.patch240
-rw-r--r--app-i18n/uim/files/uim-1.6.0-xcompose.patch16
6 files changed, 0 insertions, 496 deletions
diff --git a/app-i18n/uim/files/uim-1.5.7-kde4-applet.patch b/app-i18n/uim/files/uim-1.5.7-kde4-applet.patch
deleted file mode 100644
index dde28e3c4b3f..000000000000
--- a/app-i18n/uim/files/uim-1.5.7-kde4-applet.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Naur uim-1.5.7.orig/configure.ac uim-1.5.7/configure.ac
---- uim-1.5.7.orig/configure.ac 2009-11-21 21:55:15.000000000 +0900
-+++ uim-1.5.7/configure.ac 2010-02-05 01:00:37.000000000 +0900
-@@ -1259,7 +1259,7 @@
- @<:@default=yes@:>@]),
- enable_kde4_applet=$enableval,
- enable_kde4_applet=yes)
--case "$enable_kde_applet" in
-+case "$enable_kde4_applet" in
- no)
- use_applet_kde4="no"
- ;;
diff --git a/app-i18n/uim/files/uim-1.5.7-kde4.patch b/app-i18n/uim/files/uim-1.5.7-kde4.patch
deleted file mode 100644
index ed289ca1e38c..000000000000
--- a/app-i18n/uim/files/uim-1.5.7-kde4.patch
+++ /dev/null
@@ -1,198 +0,0 @@
-Index: qt4/toolbar/common-uimstateindicator.cpp
-===================================================================
---- qt4/toolbar/common-uimstateindicator.cpp (revision 6120)
-+++ qt4/toolbar/common-uimstateindicator.cpp (working copy)
-@@ -40,6 +40,7 @@
- #include <QtCore/QTextCodec>
- #include <QtGui/QHBoxLayout>
- #include <QtGui/QImage>
-+#include <QtGui/QMouseEvent>
- #include <QtGui/QPixmap>
-
- #include <cstring>
-@@ -171,11 +172,17 @@
- button->setToolTip( fields[ 3 ] );
-
- // create popup
-+#ifdef PLASMA_APPLET_UIM
-+ popupMenu = new QHelperPopupMenu( 0 );
-+#else
- popupMenu = new QHelperPopupMenu( button );
-+#endif
- connect( popupMenu, SIGNAL( aboutToShow() ),
- this, SLOT( slotPopupMenuAboutToShow() ) );
- connect( popupMenu, SIGNAL( aboutToHide() ),
- this, SLOT( slotPopupMenuAboutToHide() ) );
-+ connect( button, SIGNAL( menuRequested( QMenu* ) ),
-+ this, SIGNAL( menuRequested( QMenu* ) ) );
- button->setMenu( popupMenu );
- button->setPopupMode( QToolButton::InstantPopup );
-
-@@ -264,7 +271,29 @@
- }
-
- /**/
-+QHelperToolbarButton::QHelperToolbarButton( QWidget *parent )
-+ : QToolButton( parent )
-+{
-+ setAutoRaise( true );
-+}
-
-+QSize QHelperToolbarButton::sizeHint() const
-+{
-+ return QSize( BUTTON_SIZE, BUTTON_SIZE );
-+}
-+
-+void QHelperToolbarButton::mousePressEvent( QMouseEvent *event )
-+{
-+#ifdef PLASMA_APPLET_UIM
-+ if ( event->button() == Qt::LeftButton )
-+ emit menuRequested( menu() );
-+#else
-+ QToolButton::mousePressEvent( event );
-+#endif
-+}
-+
-+/**/
-+
- QHelperPopupMenu::QHelperPopupMenu( QWidget *parent )
- : QMenu( parent )
- {
-Index: qt4/toolbar/applet-kde4.h
-===================================================================
---- qt4/toolbar/applet-kde4.h (revision 6120)
-+++ qt4/toolbar/applet-kde4.h (working copy)
-@@ -50,6 +50,7 @@
-
- private slots:
- void slotToolbarResized();
-+ void slotMenuRequested(QMenu *menu);
-
- private:
- void initPopup();
-Index: qt4/toolbar/common-uimstateindicator.h
-===================================================================
---- qt4/toolbar/common-uimstateindicator.h (revision 6120)
-+++ qt4/toolbar/common-uimstateindicator.h (working copy)
-@@ -70,6 +70,7 @@
-
- signals:
- void indicatorResized();
-+ void menuRequested( QMenu *menu );
-
- public slots:
- void slotStdinActivated( int socket );
-@@ -91,14 +92,17 @@
-
- class QHelperToolbarButton : public QToolButton
- {
-+ Q_OBJECT
- public:
-- explicit QHelperToolbarButton( QWidget *parent = 0 )
-- : QToolButton( parent ){ setAutoRaise( true ); }
-+ explicit QHelperToolbarButton( QWidget *parent = 0 );
-
-- QSize sizeHint() const
-- {
-- return QSize( BUTTON_SIZE, BUTTON_SIZE );
-- }
-+ QSize sizeHint() const;
-+
-+signals:
-+ void menuRequested( QMenu *menu );
-+
-+private:
-+ void mousePressEvent( QMouseEvent *event );
- };
-
- class QHelperPopupMenu : public QMenu
-Index: qt4/toolbar/common-quimhelpertoolbar.cpp
-===================================================================
---- qt4/toolbar/common-quimhelpertoolbar.cpp (revision 6120)
-+++ qt4/toolbar/common-quimhelpertoolbar.cpp (working copy)
-@@ -56,7 +56,10 @@
- m_indicator = new UimStateIndicator( this );
- m_layout->addWidget( m_indicator );
-
-- connect( m_indicator, SIGNAL( indicatorResized() ), this, SLOT( slotIndicatorResized() ) );
-+ connect( m_indicator, SIGNAL( indicatorResized() ),
-+ this, SLOT( slotIndicatorResized() ) );
-+ connect( m_indicator, SIGNAL( menuRequested( QMenu* ) ),
-+ this, SIGNAL( menuRequested( QMenu* ) ) );
-
- QPixmap swicon = QPixmap( ICONDIR + "/im_switcher.png" );
- QPixmap preficon = QPixmap( ACTION_ICONDIR + "/configure.png");
-@@ -87,7 +90,7 @@
- exiticon = QPixmap::fromImage( exitimage.scaled( ICON_SIZE, ICON_SIZE,
- Qt::IgnoreAspectRatio, Qt::SmoothTransformation ) );
-
-- m_contextMenu = new QMenu( this );
-+ m_contextMenu = new QMenu( isApplet ? 0 : this );
- m_contextMenu->addAction( m_swicon, _("Switch input method"),
- this, SLOT(slotExecImSwitcher()) );
- m_contextMenu->addAction( m_preficon, _("Preference"),
-@@ -129,8 +132,13 @@
- {
- if( m_contextMenu->isHidden() )
- {
-+#ifdef PLASMA_APPLET_UIM
-+ Q_UNUSED( e );
-+ emit menuRequested( m_contextMenu );
-+#else
- m_contextMenu->move( e->globalPos() );
- m_contextMenu->exec();
-+#endif
- }
- }
-
-Index: qt4/toolbar/common-quimhelpertoolbar.h
-===================================================================
---- qt4/toolbar/common-quimhelpertoolbar.h (revision 6120)
-+++ qt4/toolbar/common-quimhelpertoolbar.h (working copy)
-@@ -80,6 +80,7 @@
- signals:
- void quitToolbar();
- void toolbarResized();
-+ void menuRequested( QMenu *menu );
-
- protected:
- UimStateIndicator *m_indicator;
-Index: qt4/toolbar/applet-kde4.cpp
-===================================================================
---- qt4/toolbar/applet-kde4.cpp (revision 6120)
-+++ qt4/toolbar/applet-kde4.cpp (working copy)
-@@ -61,6 +61,8 @@
- m_toolbar->setAttribute(Qt::WA_NoSystemBackground);
- connect(m_toolbar, SIGNAL(toolbarResized()),
- this, SLOT(slotToolbarResized()));
-+ connect(m_toolbar, SIGNAL(menuRequested(QMenu*)),
-+ this, SLOT(slotMenuRequested(QMenu*)));
-
- m_proxy = new QGraphicsProxyWidget;
- m_proxy->setWidget(m_toolbar);
-@@ -115,6 +117,12 @@
- resize(m_toolbar->width() + lr, m_toolbar->height() + tb);
- }
-
-+void UimApplet::slotMenuRequested(QMenu *menu)
-+{
-+ menu->adjustSize();
-+ menu->exec(popupPosition(menu->size()));
-+}
-+
- QGraphicsWidget *UimApplet::graphicsWidget()
- {
- return m_widget;
-Index: qt4/toolbar/CMakeLists.txt
-===================================================================
---- qt4/toolbar/CMakeLists.txt (revision 6120)
-+++ qt4/toolbar/CMakeLists.txt (working copy)
-@@ -3,7 +3,7 @@
- find_package(KDE4 REQUIRED)
- include(KDE4Defaults)
-
--add_definitions(${QT_DEFINITIONS} ${KDE4_DEFINITIONS})
-+add_definitions(${QT_DEFINITIONS} ${KDE4_DEFINITIONS} -DPLASMA_APPLET_UIM)
- include_directories(${KDE4_INCLUDES}
- ${CMAKE_SOURCE_DIR}/../.. ${CMAKE_SOURCE_DIR}/../../uim
- ${CMAKE_SOURCE_DIR}/../../replace ${CMAKE_SOURCE_DIR}/..)
diff --git a/app-i18n/uim/files/uim-1.5.7-qt4.7.patch b/app-i18n/uim/files/uim-1.5.7-qt4.7.patch
deleted file mode 100644
index d1e4af25ebc5..000000000000
--- a/app-i18n/uim/files/uim-1.5.7-qt4.7.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-Index: qt4/pref/customwidgets.cpp
-===================================================================
---- qt4/pref/customwidgets.cpp (revision 6394)
-+++ qt4/pref/customwidgets.cpp (revision 6395)
-@@ -886,8 +886,7 @@
- : QDialog( parent ),
- pressed_keyval( 0 ),
- pressed_keystate( Qt::NoModifier ),
-- pressed_unichar ( 0 ),
-- m_keystr( 0 )
-+ pressed_unichar ( 0 )
- {
- QLabel *l = new QLabel( _("Press keys to grab (e.g. <Control>a)"), this );
-
diff --git a/app-i18n/uim/files/uim-1.6.0-gettext.patch b/app-i18n/uim/files/uim-1.6.0-gettext.patch
deleted file mode 100644
index aa3a056cec61..000000000000
--- a/app-i18n/uim/files/uim-1.6.0-gettext.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-Index: qt4/qtgettext.h
-===================================================================
---- qt4/qtgettext.h (revision 6847)
-+++ qt4/qtgettext.h (revision 6848)
-@@ -61,6 +61,11 @@
- #else /* ENABLE_NLS */
-
- #define mygettext(String) QString::fromLocal8Bit(String)
-+/* undef original _(String) macro to use QString */
-+#ifdef _
-+#undef _
-+#endif
-+#define _(String) mygettext(String)
- #define UIC_(String, dummy) (String)
- #endif /* ENABLE_NLS */
-
diff --git a/app-i18n/uim/files/uim-1.6.0-sandbox-violation.patch b/app-i18n/uim/files/uim-1.6.0-sandbox-violation.patch
deleted file mode 100644
index d0bb19ce5b07..000000000000
--- a/app-i18n/uim/files/uim-1.6.0-sandbox-violation.patch
+++ /dev/null
@@ -1,240 +0,0 @@
-diff --git a/scm/custom-rt.scm b/scm/custom-rt.scm
-index ea94593..967f3c7 100644
---- a/scm/custom-rt.scm
-+++ b/scm/custom-rt.scm
-@@ -63,7 +63,10 @@
- (define custom-file-path
- (lambda (gsym)
- (let* ((group-name (symbol->string gsym))
-- (path (string-append (get-config-path! #f)
-+ (config-path (get-config-path #f))
-+ (path (string-append (if config-path
-+ config-path
-+ "")
- "/customs/custom-"
- group-name
- ".scm")))
-diff --git a/scm/dynlib.scm b/scm/dynlib.scm
-index 991ed55..6b67a77 100644
---- a/scm/dynlib.scm
-+++ b/scm/dynlib.scm
-@@ -34,14 +34,15 @@
- (define uim-dynlib-load-path
- (if (setugid?)
- (list (string-append (sys-pkglibdir) "/plugin"))
-- (let ((home-dir (or (home-directory (user-name)) ""))
-- (ld-library-path (getenv "LD_LIBRARY_PATH")))
-+ (let* ((ld-library-path (getenv "LD_LIBRARY_PATH"))
-+ (config-path (get-config-path #f))
-+ (user-plugin-path (if config-path
-+ (string-append config-path "/plugin")
-+ '())))
- (filter string?
- (append (list (getenv "LIBUIM_PLUGIN_LIB_DIR")
-- (if home-dir
-- (string-append (get-config-path! #f) "/plugin")
-- '())
-- (string-append (sys-pkglibdir) "/plugin"))
-+ user-plugin-path
-+ (string-append (sys-pkglibdir) "/plugin"))
- ;; XXX
- (if ld-library-path
- (string-split ld-library-path ":")
-diff --git a/scm/plugin.scm b/scm/plugin.scm
-index 2d5d74a..d187429 100644
---- a/scm/plugin.scm
-+++ b/scm/plugin.scm
-@@ -39,12 +39,12 @@
- (define uim-plugin-scm-load-path
- (if (setugid?)
- (list (sys-pkgdatadir))
-- (let ((home-dir (or (home-directory (user-name)) ""))
-+ (let ((config-path (get-config-path #f))
- (scm-paths (string-split (load-path) ":")))
- (filter string?
- (append scm-paths
-- (if home-dir
-- (list (string-append (get-config-path! #f) "/plugin"))
-+ (if config-path
-+ (list (string-append config-path "/plugin"))
- '())
- (list (sys-pkgdatadir)))))))
-
-@@ -71,9 +71,9 @@
- ;; TODO: write test
- (define load-module-conf
- (lambda ()
-- (let* ((home-dir (or (home-directory (user-name)) ""))
-- (user-module-dir (if home-dir
-- (string-append (get-config-path! #f) "/plugin/")
-+ (let* ((config-path (get-config-path #f))
-+ (user-module-dir (if config-path
-+ (string-append config-path "/plugin/")
- #f))
- (conf-file "installed-modules.scm")
- (user-conf-file (if user-module-dir
-@@ -100,9 +100,9 @@
- ;; TODO: write test
- (define load-enabled-modules
- (lambda ()
-- (let* ((home-dir (or (home-directory (user-name)) ""))
-- (user-module-dir (if home-dir
-- (string-append (get-config-path! #f) "/plugin/")
-+ (let* ((config-path (get-config-path #f))
-+ (user-module-dir (if config-path
-+ (string-append config-path "/plugin/")
- #f))
- (file "loader.scm")
- (user-file (if user-module-dir
-diff --git a/uim/uim-helper.c b/uim/uim-helper.c
-index e4a558f..882aea6 100644
---- a/uim/uim-helper.c
-+++ b/uim/uim-helper.c
-@@ -207,7 +207,11 @@ uim_helper_get_pathname(char *helper_path, int len)
- return UIM_TRUE;
-
- path_error:
-- uim_fatal_error("uim_helper_get_pathname()");
-+#if USE_UIM_NOTIFY && !UIM_NON_LIBUIM_PROG
-+ uim_notify_fatal("uim_helper_get_pathname() failed");
-+#else
-+ fprintf(stderr, "uim_helper_get_pathname() failed\n");
-+#endif
- helper_path[0] = '\0';
-
- UIM_CATCH_ERROR_END();
-diff --git a/uim/uim-posix.c b/uim/uim-posix.c
-index 83691d8..de8a327 100644
---- a/uim/uim-posix.c
-+++ b/uim/uim-posix.c
-@@ -141,21 +141,33 @@ home_directory(uim_lisp user_)
- return MAKE_STR(home);
- }
-
--uim_bool
--uim_check_dir(const char *dir)
-+static uim_bool
-+uim_check_dir_internal(const char *dir, int need_prepare)
- {
- struct stat st;
-
- if (stat(dir, &st) < 0)
-- return (mkdir(dir, 0700) < 0) ? UIM_FALSE : UIM_TRUE;
-+ if (need_prepare)
-+ return (mkdir(dir, 0700) < 0) ? UIM_FALSE : UIM_TRUE;
-+ else
-+ return UIM_FALSE;
- else {
- mode_t mode = S_IFDIR | S_IRUSR | S_IWUSR | S_IXUSR;
- return ((st.st_mode & mode) == mode) ? UIM_TRUE : UIM_FALSE;
- }
- }
-
-+/* FIXME: use appropriate name for this API */
-+uim_bool
-+uim_check_dir(const char *dir)
-+{
-+ int need_prepare = UIM_TRUE;
-+
-+ return uim_check_dir_internal(dir, need_prepare);
-+}
-+
- static uim_lisp
--c_check_dir(uim_lisp dir_)
-+c_prepare_dir(uim_lisp dir_)
- {
- if (!uim_check_dir(REFER_C_STR(dir_))) {
- return uim_scm_f();
-@@ -163,8 +175,8 @@ c_check_dir(uim_lisp dir_)
- return uim_scm_t();
- }
-
--uim_bool
--uim_get_config_path(char *path, int len, int is_getenv)
-+static uim_bool
-+uim_get_config_path_internal(char *path, int len, int is_getenv, int need_prepare)
- {
- char home[MAXPATHLEN];
-
-@@ -174,34 +186,63 @@ uim_get_config_path(char *path, int len, int is_getenv)
- if (!uim_get_home_directory(home, sizeof(home), getuid()) && is_getenv) {
- char *home_env = getenv("HOME");
-
-- if (!home_env)
-+ if (!home_env) {
-+ path[0] = '\0';
- return UIM_FALSE;
-+ }
-
-- if (strlcpy(home, home_env, sizeof(home)) >= sizeof(home))
-+ if (strlcpy(home, home_env, sizeof(home)) >= sizeof(home)) {
-+ path[0] = '\0';
- return UIM_FALSE;
-+ }
- }
-
-- if (snprintf(path, len, "%s/.uim.d", home) == -1)
-+ if (snprintf(path, len, "%s/.uim.d", home) < 0) {
-+ path[0] = '\0';
- return UIM_FALSE;
-+ }
-
-- if (!uim_check_dir(path)) {
-+ if (!uim_check_dir_internal(path, need_prepare)) {
- return UIM_FALSE;
- }
-
- return UIM_TRUE;
- }
-
-+/* FIXME: use appropriate name for this API */
-+uim_bool
-+uim_get_config_path(char *path, int len, int is_getenv)
-+{
-+ int need_prepare = UIM_TRUE;
-+
-+ return uim_get_config_path_internal(path, len, is_getenv, need_prepare);
-+}
-+
- static uim_lisp
--c_get_config_path(uim_lisp is_getenv_)
-+c_prepare_config_path(uim_lisp is_getenv_)
- {
- char path[MAXPATHLEN];
-+ int need_prepare = UIM_TRUE;
-
-- if (!uim_get_config_path(path, sizeof(path), C_BOOL(is_getenv_)))
-+ if (!uim_get_config_path_internal(path, sizeof(path), C_BOOL(is_getenv_), need_prepare))
- return uim_scm_f();
- return MAKE_STR(path);
- }
-
- static uim_lisp
-+c_get_config_path(uim_lisp is_getenv_)
-+{
-+ char path[MAXPATHLEN];
-+ int need_prepare = UIM_FALSE;
-+ int exist;
-+
-+ /* No need to check the existence of path in this function */
-+ exist = uim_get_config_path_internal(path, sizeof(path), C_BOOL(is_getenv_), need_prepare);
-+
-+ return MAKE_STR(path);
-+}
-+
-+static uim_lisp
- file_stat_mode(uim_lisp filename, mode_t mode)
- {
- struct stat st;
-@@ -391,8 +432,9 @@ uim_init_posix_subrs(void)
- uim_scm_init_proc0("user-name", user_name);
- uim_scm_init_proc1("home-directory", home_directory);
-
-- uim_scm_init_proc1("create/check-directory!", c_check_dir);
-- uim_scm_init_proc1("get-config-path!", c_get_config_path);
-+ uim_scm_init_proc1("create/check-directory!", c_prepare_dir);
-+ uim_scm_init_proc1("get-config-path!", c_prepare_config_path);
-+ uim_scm_init_proc1("get-config-path", c_get_config_path);
-
- uim_scm_init_proc1("file-readable?", file_readablep);
- uim_scm_init_proc1("file-writable?", file_writablep);
diff --git a/app-i18n/uim/files/uim-1.6.0-xcompose.patch b/app-i18n/uim/files/uim-1.6.0-xcompose.patch
deleted file mode 100644
index 48a56c32921c..000000000000
--- a/app-i18n/uim/files/uim-1.6.0-xcompose.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-Index: gtk/compose.c
-===================================================================
---- gtk/compose.c (revision 6879)
-+++ gtk/compose.c (revision 6880)
-@@ -621,7 +621,10 @@
- {
- char *result;
- result = g_locale_to_utf8(rhs_string_mb, -1, NULL, NULL, NULL);
-- rhs_string_utf8 = strdup(result);
-+ if (!result)
-+ rhs_string_utf8 = strdup("");
-+ else
-+ rhs_string_utf8 = strdup(result);
- g_free(result);
- }
-