summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2009-12-24 14:28:26 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2009-12-24 14:28:26 +0000
commit0f25ff6d34e75c75d15b2492e8673dc1b8ed3473 (patch)
treed746af7c611850851248a142f1056a0c5e2488d7 /app-i18n
parentUse -j1 for build (bug #298208). (diff)
downloadgentoo-2-0f25ff6d34e75c75d15b2492e8673dc1b8ed3473.tar.gz
gentoo-2-0f25ff6d34e75c75d15b2492e8673dc1b8ed3473.tar.bz2
gentoo-2-0f25ff6d34e75c75d15b2492e8673dc1b8ed3473.zip
Version bumped.
(Portage version: 2.1.7.15/cvs/Linux x86_64)
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/ibus-skk/ChangeLog7
-rw-r--r--app-i18n/ibus-skk/ibus-skk-0.0.2.ebuild47
2 files changed, 53 insertions, 1 deletions
diff --git a/app-i18n/ibus-skk/ChangeLog b/app-i18n/ibus-skk/ChangeLog
index 49dc96c9da0e..7e27d774f8f6 100644
--- a/app-i18n/ibus-skk/ChangeLog
+++ b/app-i18n/ibus-skk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-i18n/ibus-skk
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-skk/ChangeLog,v 1.1 2009/12/07 12:44:32 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-skk/ChangeLog,v 1.2 2009/12/24 14:28:26 matsuu Exp $
+
+*ibus-skk-0.0.2 (24 Dec 2009)
+
+ 24 Dec 2009; MATSUU Takuto <matsuu@gentoo.org> +ibus-skk-0.0.2.ebuild:
+ Version bumped.
*ibus-skk-0.0.1 (07 Dec 2009)
diff --git a/app-i18n/ibus-skk/ibus-skk-0.0.2.ebuild b/app-i18n/ibus-skk/ibus-skk-0.0.2.ebuild
new file mode 100644
index 000000000000..2a0716e6c2c3
--- /dev/null
+++ b/app-i18n/ibus-skk/ibus-skk-0.0.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-skk/ibus-skk-0.0.2.ebuild,v 1.1 2009/12/24 14:28:26 matsuu Exp $
+
+EAPI="2"
+
+inherit python
+
+DESCRIPTION="Japanese input method Anthy IMEngine for IBus Framework"
+HOMEPAGE="http://github.com/ueno/ibus-skk"
+SRC_URI="http://cloud.github.com/downloads/ueno/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND="app-i18n/ibus
+ >=dev-lang/python-2.5
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( >=sys-devel/gettext-0.16.1 )"
+RDEPEND="${RDEPEND}
+ app-i18n/skk-jisyo"
+
+src_prepare() {
+ mv py-compile py-compile.orig || die
+ ln -s "$(type -P true)" py-compile || die
+}
+
+src_configure() {
+ econf $(use_enable nls) || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog NEWS README TODO || die
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/share/${PN}
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/${PN}
+}