summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-01-08 19:35:49 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-01-08 19:35:49 +0000
commit3233a85a88fcc05ce04b692f89f12d4f02fecb04 (patch)
tree23d06748021fa55f4793a617df4d20df1c66e72f /app-i18n
parentmirror fix (diff)
downloadgentoo-2-3233a85a88fcc05ce04b692f89f12d4f02fecb04.tar.gz
gentoo-2-3233a85a88fcc05ce04b692f89f12d4f02fecb04.tar.bz2
gentoo-2-3233a85a88fcc05ce04b692f89f12d4f02fecb04.zip
Fix deprecation warnings.
(Portage version: 2.2.0_alpha14/cvs/Linux x86_64)
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/nkf/ChangeLog8
-rw-r--r--app-i18n/nkf/nkf-2.0.7-r1.ebuild20
-rw-r--r--app-i18n/nkf/nkf-2.0.7.ebuild20
-rw-r--r--app-i18n/nkf/nkf-2.1.0.ebuild14
4 files changed, 43 insertions, 19 deletions
diff --git a/app-i18n/nkf/ChangeLog b/app-i18n/nkf/ChangeLog
index c914e6381af0..a5c5a920217b 100644
--- a/app-i18n/nkf/ChangeLog
+++ b/app-i18n/nkf/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-i18n/nkf
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/nkf/ChangeLog,v 1.45 2010/01/23 09:02:26 matsuu Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/nkf/ChangeLog,v 1.46 2011/01/08 19:35:49 arfrever Exp $
+
+ 08 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ nkf-2.0.7.ebuild, nkf-2.0.7-r1.ebuild, nkf-2.1.0.ebuild:
+ Fix deprecation warnings.
*nkf-2.1.0 (23 Jan 2010)
diff --git a/app-i18n/nkf/nkf-2.0.7-r1.ebuild b/app-i18n/nkf/nkf-2.0.7-r1.ebuild
index 70979474c4d7..1d87ce900578 100644
--- a/app-i18n/nkf/nkf-2.0.7-r1.ebuild
+++ b/app-i18n/nkf/nkf-2.0.7-r1.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/nkf/nkf-2.0.7-r1.ebuild,v 1.1 2008/12/08 14:58:29 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/nkf/nkf-2.0.7-r1.ebuild,v 1.2 2011/01/08 19:35:49 arfrever Exp $
+
+EAPI="3"
inherit toolchain-funcs eutils perl-module distutils
@@ -17,11 +19,7 @@ IUSE="perl python linguas_ja"
S="${WORKDIR}/${MY_P}"
-src_unpack() {
- unpack ${MY_P}.tar.gz
-
- cd "${S}"
-
+src_prepare() {
sed -i -e '/-o nkf/s:$(CFLAGS):$(CFLAGS) $(LDFLAGS):' Makefile || die
if use python; then
@@ -68,3 +66,11 @@ src_install() {
distutils_src_install
fi
}
+
+pkg_postinst() {
+ use python && distutils_pkg_postinst
+}
+
+pkg_postrm() {
+ use python && distutils_pkg_postrm
+}
diff --git a/app-i18n/nkf/nkf-2.0.7.ebuild b/app-i18n/nkf/nkf-2.0.7.ebuild
index 3b3ec87d9ee4..c185c4d0d73b 100644
--- a/app-i18n/nkf/nkf-2.0.7.ebuild
+++ b/app-i18n/nkf/nkf-2.0.7.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/nkf/nkf-2.0.7.ebuild,v 1.8 2007/08/25 13:46:17 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/nkf/nkf-2.0.7.ebuild,v 1.9 2011/01/08 19:35:49 arfrever Exp $
+
+EAPI="3"
inherit toolchain-funcs eutils perl-app distutils
@@ -17,11 +19,7 @@ IUSE="perl python linguas_ja"
S="${WORKDIR}/${MY_P}"
-src_unpack() {
- unpack ${MY_P}.tar.gz
-
- cd "${S}"
-
+src_prepare() {
sed -i -e '/-o nkf/s:$(CFLAGS):$(CFLAGS) $(LDFLAGS):' Makefile || die
if use python; then
@@ -59,3 +57,11 @@ src_install() {
distutils_src_install
fi
}
+
+pkg_postinst() {
+ use python && distutils_pkg_postinst
+}
+
+pkg_postrm() {
+ use python && distutils_pkg_postrm
+}
diff --git a/app-i18n/nkf/nkf-2.1.0.ebuild b/app-i18n/nkf/nkf-2.1.0.ebuild
index bcb7a732b560..f4ef5838d6ce 100644
--- a/app-i18n/nkf/nkf-2.1.0.ebuild
+++ b/app-i18n/nkf/nkf-2.1.0.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/nkf/nkf-2.1.0.ebuild,v 1.1 2010/01/23 09:02:26 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/nkf/nkf-2.1.0.ebuild,v 1.2 2011/01/08 19:35:49 arfrever Exp $
-EAPI="2"
+EAPI="3"
inherit eutils distutils perl-module toolchain-funcs
@@ -65,3 +65,11 @@ src_install() {
distutils_src_install
fi
}
+
+pkg_postinst() {
+ use python && distutils_pkg_postinst
+}
+
+pkg_postrm() {
+ use python && distutils_pkg_postrm
+}