summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2004-03-21 21:26:13 +0000
committerMamoru Komachi <usata@gentoo.org>2004-03-21 21:26:13 +0000
commit6079afd1b99684a4b1d68e065632b7ec189fabd9 (patch)
tree3fa2c6a569cd7c2e6fcc2b1c095aa6283f8285a4 /app-i18n
parentYou can control XMMS using your SBLive Drive's IR port. Ebuild by me. Close... (diff)
downloadgentoo-2-6079afd1b99684a4b1d68e065632b7ec189fabd9.tar.gz
gentoo-2-6079afd1b99684a4b1d68e065632b7ec189fabd9.tar.bz2
gentoo-2-6079afd1b99684a4b1d68e065632b7ec189fabd9.zip
Fixed compilation with gtk+-2.4.0. Closing bug #45246
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/im-ja/ChangeLog6
-rw-r--r--app-i18n/im-ja/files/im-ja-0.9-gtk24-gentoo.diff69
-rw-r--r--app-i18n/im-ja/im-ja-0.9-r1.ebuild10
3 files changed, 83 insertions, 2 deletions
diff --git a/app-i18n/im-ja/ChangeLog b/app-i18n/im-ja/ChangeLog
index e3259a0bcb9c..4053aeb00cf0 100644
--- a/app-i18n/im-ja/ChangeLog
+++ b/app-i18n/im-ja/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-i18n/im-ja
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/im-ja/ChangeLog,v 1.14 2004/03/04 19:21:50 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/im-ja/ChangeLog,v 1.15 2004/03/21 21:26:13 usata Exp $
+
+ 22 Mar 2004; Mamoru KOMACHI <usata@gentoo.org> im-ja-0.9-r1.ebuild,
+ files/im-ja-0.9-gtk24-gentoo.diff:
+ Fixed compilation with gtk+-2.4. Closing bug #45246
05 Mar 2004; Mamoru KOMACHI <usata@gentoo.org> im-ja-0.6.ebuild,
im-ja-0.7_p2.ebuild, im-ja-0.8.ebuild, im-ja-0.9-r1.ebuild, im-ja-0.9.ebuild:
diff --git a/app-i18n/im-ja/files/im-ja-0.9-gtk24-gentoo.diff b/app-i18n/im-ja/files/im-ja-0.9-gtk24-gentoo.diff
new file mode 100644
index 000000000000..dd54c6869e3a
--- /dev/null
+++ b/app-i18n/im-ja/files/im-ja-0.9-gtk24-gentoo.diff
@@ -0,0 +1,69 @@
+Index: preeditarea.c
+===================================================================
+RCS file: /cvsroot/im-ja/im-ja/src/preeditarea.c,v
+retrieving revision 1.3
+retrieving revision 1.7
+diff -u -r1.3 -r1.7
+--- preeditarea.c 7 Aug 2003 14:22:02 -0000 1.3
++++ preeditarea.c 12 Mar 2004 13:34:41 -0000 1.7
+@@ -20,6 +20,7 @@
+ * Based on gtklabel.c
+ */
+
++#include <config.h>
+ #include <gtk/gtk.h>
+ #include <math.h>
+
+@@ -296,7 +297,7 @@
+ PreeditArea *area;
+ gint width, height;
+ PangoRectangle logical_rect;
+- GtkWidgetAuxInfo *aux_info;
++ //GtkWidgetAuxInfo *aux_info;
+
+ //IM_JA_DEBUG("preedit_area_size_request\n");
+
+@@ -312,7 +313,7 @@
+
+ pango_layout_get_extents(area->layout, NULL, &logical_rect);
+
+- aux_info = _gtk_widget_get_aux_info(widget, FALSE);
++ //aux_info = _gtk_widget_get_aux_info(widget, FALSE);
+ width += PANGO_PIXELS(logical_rect.width);
+
+ height += PANGO_PIXELS(logical_rect.height);
+@@ -403,25 +404,29 @@
+
+ PangoRectangle cursor_pos;
+ GdkRectangle cursor_location;
++#ifdef GTK_2_2
+ GdkGC *gc;
++#endif
+ PangoLayout *layout = preedit_area_get_layout(PREEDIT_AREA(area));
+
+ preedit_area_ensure_layout(area);
+
+ pango_layout_get_cursor_pos(layout, area->cursor_pos, &cursor_pos, NULL);
+
+-
+ cursor_location.x = xoffset + PANGO_PIXELS(cursor_pos.x);
+ cursor_location.y = yoffset + PANGO_PIXELS(cursor_pos.y);
+ cursor_location.width = 0;
+ cursor_location.height = PANGO_PIXELS(cursor_pos.height);
+
++#ifdef GTK_2_2
+ gc = _gtk_get_insertion_cursor_gc(widget, TRUE);
+-
+- _gtk_draw_insertion_cursor(widget, widget->window, gc,
+- &cursor_location, GTK_TEXT_DIR_LTR,
+- FALSE);
++ _gtk_draw_insertion_cursor(widget, widget->window, gc, &cursor_location,
++ GTK_TEXT_DIR_LTR, FALSE);
+ g_object_unref(gc);
++#else
++ gtk_draw_insertion_cursor(widget, widget->window, NULL, &cursor_location,
++ TRUE, GTK_TEXT_DIR_LTR, FALSE);
++#endif
+
+ }
+
diff --git a/app-i18n/im-ja/im-ja-0.9-r1.ebuild b/app-i18n/im-ja/im-ja-0.9-r1.ebuild
index 8b6ca6c1824b..e44f29c26992 100644
--- a/app-i18n/im-ja/im-ja-0.9-r1.ebuild
+++ b/app-i18n/im-ja/im-ja-0.9-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/im-ja/im-ja-0.9-r1.ebuild,v 1.3 2004/03/04 19:21:50 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/im-ja/im-ja-0.9-r1.ebuild,v 1.4 2004/03/21 21:26:13 usata Exp $
inherit gnome2
@@ -39,10 +39,18 @@ src_unpack() {
unpack ${A}
cd ${S}
epatch ${FILESDIR}/${P}-canna-3.7-gentoo.diff
+ # fix for the bug #45246
+ if has_version '>=x11-libs/gtk+-2.4' ; then
+ use debug || find . -name 'Makefile*' \
+ -exec sed -i -e "/DEPRECATED/d" {} \;
+ cd src
+ epatch ${FILESDIR}/${P}-gtk24-gentoo.diff
+ fi
}
src_compile() {
local myconf
+ export WANT_AUTOMAKE=1.8
use gnome || myconf="$myconf --disable-gnome"
use canna || myconf="$myconf --disable-canna"
use freewnn || myconf="$myconf --disable-wnn"