summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2014-08-01 07:33:54 +0000
committerYixun Lan <dlan@gentoo.org>2014-08-01 07:33:54 +0000
commit62498a31d2107205a269232b00479685fee7abbe (patch)
tree9d2374fe9bdcb08cab503d9787b0e95edeb3a3d3 /app-i18n
parentversion bump (diff)
downloadgentoo-2-62498a31d2107205a269232b00479685fee7abbe.tar.gz
gentoo-2-62498a31d2107205a269232b00479685fee7abbe.tar.bz2
gentoo-2-62498a31d2107205a269232b00479685fee7abbe.zip
version bump, switch SRC_URI to github
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xAABEFD55)
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/ibus-qt/ChangeLog7
-rw-r--r--app-i18n/ibus-qt/ibus-qt-1.3.3.ebuild47
2 files changed, 53 insertions, 1 deletions
diff --git a/app-i18n/ibus-qt/ChangeLog b/app-i18n/ibus-qt/ChangeLog
index 390ef2113a07..afc44fe70dc7 100644
--- a/app-i18n/ibus-qt/ChangeLog
+++ b/app-i18n/ibus-qt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-i18n/ibus-qt
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-qt/ChangeLog,v 1.21 2014/01/06 04:40:43 naota Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-qt/ChangeLog,v 1.22 2014/08/01 07:33:54 dlan Exp $
+
+*ibus-qt-1.3.3 (01 Aug 2014)
+
+ 01 Aug 2014; Yixun Lan <dlan@gentoo.org> +ibus-qt-1.3.3.ebuild:
+ version bump, switch SRC_URI to github
*ibus-qt-1.3.2 (06 Jan 2014)
diff --git a/app-i18n/ibus-qt/ibus-qt-1.3.3.ebuild b/app-i18n/ibus-qt/ibus-qt-1.3.3.ebuild
new file mode 100644
index 000000000000..5b4bb7ea6243
--- /dev/null
+++ b/app-i18n/ibus-qt/ibus-qt-1.3.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-qt/ibus-qt-1.3.3.ebuild,v 1.1 2014/08/01 07:33:54 dlan Exp $
+
+EAPI="5"
+inherit cmake-utils eutils multilib
+
+DESCRIPTION="Qt IBus library and Qt input method plugin"
+HOMEPAGE="http://code.google.com/p/ibus/"
+SRC_URI="https://github.com/ibus/ibus-qt/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+RDEPEND=">=app-i18n/ibus-1.3.7
+ >=sys-apps/dbus-1.2
+ x11-libs/libX11
+ >=dev-qt/qtcore-4.5:4
+ >=dev-qt/qtdbus-4.5:4"
+DEPEND="${RDEPEND}
+ >=dev-libs/icu-4:=
+ dev-util/cmake
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+DOCS="AUTHORS README TODO"
+
+mycmakeargs="-DLIBDIR=$(get_libdir) all"
+
+src_compile() {
+ cmake-utils_src_compile
+
+ if use doc ; then
+ cd "${CMAKE_BUILD_DIR}"
+ emake docs || die
+ fi
+}
+
+src_install() {
+ if use doc ; then
+ HTML_DOCS="${CMAKE_BUILD_DIR}/docs/html/*"
+ fi
+
+ cmake-utils_src_install
+}