summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2004-04-26 08:26:08 +0000
committerAlastair Tse <liquidx@gentoo.org>2004-04-26 08:26:08 +0000
commit99fef93474af161fad33e7e704e72a088ff74167 (patch)
tree8b335e97ef39958991421b7a87d4f33ed1b186dd /app-i18n
parentremoved sparc from keywords (Manifest recommit) (diff)
downloadgentoo-2-99fef93474af161fad33e7e704e72a088ff74167.tar.gz
gentoo-2-99fef93474af161fad33e7e704e72a088ff74167.tar.bz2
gentoo-2-99fef93474af161fad33e7e704e72a088ff74167.zip
version bump (#48869). thanks to Ming Zhao <zhaoming@tsinghua.org.cn>.
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/scim/ChangeLog7
-rw-r--r--app-i18n/scim/files/digest-scim-0.9.61
-rw-r--r--app-i18n/scim/scim-0.9.6.ebuild62
3 files changed, 69 insertions, 1 deletions
diff --git a/app-i18n/scim/ChangeLog b/app-i18n/scim/ChangeLog
index 3f4210d9b2a1..e65d419984a1 100644
--- a/app-i18n/scim/ChangeLog
+++ b/app-i18n/scim/ChangeLog
@@ -1,11 +1,16 @@
# ChangeLog for app-i18n/scim
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim/ChangeLog,v 1.10 2004/04/25 20:31:23 squinky86 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim/ChangeLog,v 1.11 2004/04/26 08:26:08 liquidx Exp $
25 Apr 2004; Jon Hood <squinky86@gentoo.org> scim-0.6.1.ebuild,
scim-0.8.2.ebuild,scim-0.9.0.ebuild, scim-0.9.2.ebuild, scim-0.9.3.ebuild:
added "die"
+*scim-0.9.6 (26 Apr 2004)
+
+ 26 Apr 2004; Alastair Tse <liquidx@gentoo.org> +scim-0.9.6.ebuild:
+ version bump (#48869). thanks to Ming Zhao <zhaoming@tsinghua.org.cn>.
+
*scim-0.9.3 (29 Mar 2004)
29 Mar 2004; Alastair Tse <liquidx@gentoo.org> scim-0.9.3.ebuild,
diff --git a/app-i18n/scim/files/digest-scim-0.9.6 b/app-i18n/scim/files/digest-scim-0.9.6
new file mode 100644
index 000000000000..d460204ea50a
--- /dev/null
+++ b/app-i18n/scim/files/digest-scim-0.9.6
@@ -0,0 +1 @@
+MD5 a90de6d140bbe4160a5a7b98d9d36a98 scim-0.9.6.tar.gz 1337731
diff --git a/app-i18n/scim/scim-0.9.6.ebuild b/app-i18n/scim/scim-0.9.6.ebuild
new file mode 100644
index 000000000000..e9b61b25dd4e
--- /dev/null
+++ b/app-i18n/scim/scim-0.9.6.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim/scim-0.9.6.ebuild,v 1.1 2004/04/26 08:26:08 liquidx Exp $
+
+inherit gnome2 eutils
+
+DESCRIPTION="Smart Common Input Method (SCIM) is a Input Method (IM) development platform"
+HOMEPAGE="http://freedesktop.org/~suzhe/"
+SRC_URI="http://freedesktop.org/~suzhe/sources/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE="gnome"
+
+RDEPEND="virtual/x11
+ gnome? ( >=gnome-base/gconf-1.2
+ >=dev-libs/libxml2-2.5
+ >=gnome-base/ORBit2-2.8 )
+ >=x11-libs/gtk+-2
+ >=dev-libs/atk-1
+ >=x11-libs/pango-1
+ >=dev-libs/glib-2"
+DEPEND="${RDEPEND}
+ dev-lang/perl"
+PDEPEND=">=app-i18n/scim-tables-0.3.5"
+
+ELTCONF="--reverse-deps"
+SCROLLKEEPER_UPDATE="0"
+
+src_unpack() {
+ unpack ${A}
+ # use scim gtk2 IM module only for chinese/japanese/korean
+ EPATCH_OPTS="-d ${S}" epatch ${FILESDIR}/${PN}-0.6.1-gtk2immodule.patch
+ # workaround for problematic makefile
+ sed -i -e "s:^\(scim_LDFLAGS.*\):\1 -ldl:" ${S}/src/Makefile.in
+ sed -i -e "s:^\(scim_config_agent_LDFLAGS = .*\):\1 -ldl:" ${S}/src/Makefile.in
+ sed -i -e "s:^\(scim_make_table_LDFLAGS.*\):\1 -ldl:" ${S}/modules/Server/Makefile.in
+ sed -i -e "s:^LDFLAGS = :LDFLAGS = -ldl :" ${S}/tests/Makefile.in
+ sed -i -e "s:GTK_VERSION=2.3.5:GTK_VERSION=2.4.0:" ${S}/configure
+}
+
+src_compile() {
+ use gnome || G2CONF="${G2CONF} --disable-config-gconf"
+ gnome2_src_compile
+}
+
+src_install() {
+ gnome2_src_install || die "install failed"
+ dodoc README AUTHORS ChangeLog docs/developers docs/scim.cfg
+ dohtml -r docs/html/*
+}
+
+pkg_postinst() {
+ einfo "To use SCIM with both GTK2 and XIM, you should use the following"
+ einfo "in your user startup scripts such as .gnomerc or .xinitrc:"
+ einfo " "
+ einfo "LANG='your_language' scim -f socket -ns socket -d"
+ einfo "LANG='your_language' scim -f x11 -s socket -c socket -d"
+ einfo " "
+ einfo "where 'your_language' can either be zh_CN or zh_TW"
+}