summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2006-06-27 09:51:45 +0000
committerRoy Marples <uberlord@gentoo.org>2006-06-27 09:51:45 +0000
commit02ce49edc32eb4f2ab4d56e08acda40bbde3aee8 (patch)
tree9714ef64c9c479f4546d0570116becaed1bc3b3b /app-laptop/hdapsd/hdapsd-20060409.ebuild
parentFix cachecheck to make it work with autoconf-2.60, thanks to flameeyes, bug 1... (diff)
downloadgentoo-2-02ce49edc32eb4f2ab4d56e08acda40bbde3aee8.tar.gz
gentoo-2-02ce49edc32eb4f2ab4d56e08acda40bbde3aee8.tar.bz2
gentoo-2-02ce49edc32eb4f2ab4d56e08acda40bbde3aee8.zip
Added a kernel patch so --config can enable hdaps on my Z60m
(Portage version: 2.1.1_pre1-r3)
Diffstat (limited to 'app-laptop/hdapsd/hdapsd-20060409.ebuild')
-rw-r--r--app-laptop/hdapsd/hdapsd-20060409.ebuild13
1 files changed, 11 insertions, 2 deletions
diff --git a/app-laptop/hdapsd/hdapsd-20060409.ebuild b/app-laptop/hdapsd/hdapsd-20060409.ebuild
index 588aeaf51877..67896d6a803b 100644
--- a/app-laptop/hdapsd/hdapsd-20060409.ebuild
+++ b/app-laptop/hdapsd/hdapsd-20060409.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/hdapsd/hdapsd-20060409.ebuild,v 1.1 2006/06/26 20:07:24 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/hdapsd/hdapsd-20060409.ebuild,v 1.2 2006/06/27 09:51:45 uberlord Exp $
inherit eutils linux-info
@@ -34,7 +34,7 @@ src_install() {
newinitd "${FILESDIR}"/hdapsd.init hdapsd
# Install our kernel patches
- dodoc *.patch
+ dodoc *.patch "${FILESDIR}"/hdaps-Z60m.patch
}
kernel_patched() {
@@ -62,6 +62,15 @@ pkg_config() {
cd "${KERNEL_DIR}"
epatch "${docdir}/${p}"
+
+ # This is just a nice to have for me as I use a Z60m myself
+ if ! grep "Z60m" "${KERNEL_DIR}"/drivers/hwmon/hdaps.c ; then
+ epatch "${docdir}"/hdaps-Z60m.patch.gz
+ fi
+
+ echo
+ einfo "Now you should rebuild your kernel, its modules"
+ einfo "and then install them."
}
pkg_postinst(){