summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-05-01 13:42:40 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-05-01 13:42:40 +0000
commit5d9a1d7b53e2ed61eaebb90425242aea7a0fb736 (patch)
tree721329d9d74c74db821893e058f85d73cf842cc4 /app-laptop/hdapsd
parentFix problem with locale variants, bug 365365 (diff)
downloadgentoo-2-5d9a1d7b53e2ed61eaebb90425242aea7a0fb736.tar.gz
gentoo-2-5d9a1d7b53e2ed61eaebb90425242aea7a0fb736.tar.bz2
gentoo-2-5d9a1d7b53e2ed61eaebb90425242aea7a0fb736.zip
Convert from built_with_use to has_version and clean up
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'app-laptop/hdapsd')
-rw-r--r--app-laptop/hdapsd/hdapsd-20090401.ebuild21
1 files changed, 9 insertions, 12 deletions
diff --git a/app-laptop/hdapsd/hdapsd-20090401.ebuild b/app-laptop/hdapsd/hdapsd-20090401.ebuild
index 4eb86558969c..476694c445fa 100644
--- a/app-laptop/hdapsd/hdapsd-20090401.ebuild
+++ b/app-laptop/hdapsd/hdapsd-20090401.ebuild
@@ -1,9 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/hdapsd/hdapsd-20090401.ebuild,v 1.2 2009/10/15 02:30:08 mr_bones_ Exp $
-
-EAPI="2"
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/hdapsd/hdapsd-20090401.ebuild,v 1.3 2011/05/01 13:42:40 ssuominen Exp $
+EAPI=2
inherit eutils linux-info toolchain-funcs
DESCRIPTION="IBM ThinkPad Harddrive Active Protection disk head parking daemon"
@@ -12,15 +11,13 @@ SRC_URI="mirror://sourceforge/hdaps/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~amd64"
-
+KEYWORDS="~amd64 ~x86"
IUSE=""
-RDEPEND=""
pkg_setup() {
# We require the hdaps module which can either come from kernel sources or
# from the tp_smapi package.
- if ! has_version app-laptop/tp_smapi || ! built_with_use app-laptop/tp_smapi hdaps; then
+ if ! has_version app-laptop/tp_smapi[hdaps]; then
CONFIG_CHECK="~SENSORS_HDAPS"
ERROR_SENSORS_HDAPS="${P} requires app-laptop/tp_smapi (with hdaps USE enabled) or support for CONFIG_SENSORS_HDAPS enabled"
linux-info_pkg_setup
@@ -28,7 +25,7 @@ pkg_setup() {
}
src_install() {
- emake DESTDIR="${D}" install || die "Install failed"
+ emake DESTDIR="${D}" install || die
rm -rf "${D}"/usr/share/doc/hdapsd
dodoc ChangeLog README AUTHORS
newconfd "${FILESDIR}"/hdapsd.conf hdapsd
@@ -36,11 +33,11 @@ src_install() {
}
pkg_postinst(){
- [[ -z $(ls "${ROOT}"/sys/block/*/queue/protect 2>/dev/null) ]] && \
- [[ -z $(ls "${ROOT}"/sys/block/*/device/unload_heads 2>/dev/null) ]] && \
+ [[ -z $(ls ${ROOT}/sys/block/*/queue/protect 2>/dev/null) ]] && \
+ [[ -z $(ls ${ROOT}/sys/block/*/device/unload_heads 2>/dev/null) ]] && \
ewarn "Your kernel does NOT support shock protection. Kernel 2.6.28 and above is recommended!"
- if ! has_version app-laptop/tp_smapi; then
+ if ! has_version app-laptop/tp_smapi[hdaps]; then
ewarn "Using the hdaps module provided by app-laptop/tp_smapi instead"
ewarn "of the in-kernel driver is strongly recommended!"
fi