summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph Jezak <josejx@gentoo.org>2006-01-30 02:44:35 +0000
committerJoseph Jezak <josejx@gentoo.org>2006-01-30 02:44:35 +0000
commit656a02eb5938ced4d5fff5ad27a28574273d9266 (patch)
treeb2594ef5769388cf5b141095a3c4ea38ac3934e9 /app-laptop/pbbuttonsd
parentold (diff)
downloadgentoo-2-656a02eb5938ced4d5fff5ad27a28574273d9266.tar.gz
gentoo-2-656a02eb5938ced4d5fff5ad27a28574273d9266.tar.bz2
gentoo-2-656a02eb5938ced4d5fff5ad27a28574273d9266.zip
Removed kernel checks.
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'app-laptop/pbbuttonsd')
-rw-r--r--app-laptop/pbbuttonsd/ChangeLog6
-rw-r--r--app-laptop/pbbuttonsd/pbbuttonsd-0.7.2.ebuild20
-rw-r--r--app-laptop/pbbuttonsd/pbbuttonsd-0.7.4.ebuild18
3 files changed, 17 insertions, 27 deletions
diff --git a/app-laptop/pbbuttonsd/ChangeLog b/app-laptop/pbbuttonsd/ChangeLog
index d45d13c57364..1486f5ca4579 100644
--- a/app-laptop/pbbuttonsd/ChangeLog
+++ b/app-laptop/pbbuttonsd/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-laptop/pbbuttonsd
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/pbbuttonsd/ChangeLog,v 1.41 2006/01/28 15:30:43 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/pbbuttonsd/ChangeLog,v 1.42 2006/01/30 02:44:35 josejx Exp $
+
+ 30 Jan 2006; Joseph Jezak <josejx@gentoo.org> pbbuttonsd-0.7.2.ebuild,
+ pbbuttonsd-0.7.4.ebuild:
+ Removed kernel checks.
*pbbuttonsd-0.7.4 (28 Jan 2006)
diff --git a/app-laptop/pbbuttonsd/pbbuttonsd-0.7.2.ebuild b/app-laptop/pbbuttonsd/pbbuttonsd-0.7.2.ebuild
index eb58eae4849f..5f174a6b7999 100644
--- a/app-laptop/pbbuttonsd/pbbuttonsd-0.7.2.ebuild
+++ b/app-laptop/pbbuttonsd/pbbuttonsd-0.7.2.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/pbbuttonsd/pbbuttonsd-0.7.2.ebuild,v 1.3 2005/11/19 20:37:53 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/pbbuttonsd/pbbuttonsd-0.7.2.ebuild,v 1.4 2006/01/30 02:44:35 josejx Exp $
-inherit eutils linux-info flag-o-matic
+inherit eutils flag-o-matic
DESCRIPTION="program to map special Powerbook/iBook keys"
HOMEPAGE="http://pbbuttons.sf.net"
@@ -20,12 +20,6 @@ src_compile() {
# Fix crash bug on some systems
replace-flags -O? -O1
- if ! linux_chkconfig_present INPUT_EVDEV ; then
- eerror "Please enable CONFIG_INPUT_EVDEV in your kernel"
- eerror "pbbuttonsd will not work without it."
- die "Kernel not compiled with CONFIG_INPUT_EVDEV support"
- fi
-
if use x86; then
if use acpi; then
laptop=acpi
@@ -53,10 +47,9 @@ src_install() {
}
pkg_postinst() {
- if linux_chkconfig_module INPUT_EVDEV ; then
- ewarn "Ensure that the evdev kernel module is loaded otherwise"
- ewarn "pbbuttonsd won't work."
- fi
+ ewarn "Ensure that the evdev kernel module is loaded or built in"
+ ewarn "pbbuttonsd won't work without it."
+ einfo
if use ppc; then
einfo
@@ -65,6 +58,7 @@ pkg_postinst() {
einfo "replace_pmud=no in /etc/pbbuttonsd.conf. Otherwise you can"
einfo "try setting replace_pmud=yes in /etc/pbbuttonsd.conf and"
einfo "disabling PMUD"
+ einfo
ewarn "Warning: the NoTapTyping option is unstable, see bug #86768."
fi
}
diff --git a/app-laptop/pbbuttonsd/pbbuttonsd-0.7.4.ebuild b/app-laptop/pbbuttonsd/pbbuttonsd-0.7.4.ebuild
index 69ae4ada90cb..27c8d0448959 100644
--- a/app-laptop/pbbuttonsd/pbbuttonsd-0.7.4.ebuild
+++ b/app-laptop/pbbuttonsd/pbbuttonsd-0.7.4.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/pbbuttonsd/pbbuttonsd-0.7.4.ebuild,v 1.1 2006/01/28 15:30:43 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/pbbuttonsd/pbbuttonsd-0.7.4.ebuild,v 1.2 2006/01/30 02:44:35 josejx Exp $
-inherit eutils linux-info flag-o-matic
+inherit eutils flag-o-matic
DESCRIPTION="Handles power management and special keys on laptops."
HOMEPAGE="http://pbbuttons.sf.net"
@@ -22,12 +22,6 @@ src_compile() {
# Fix crash bug on some systems
replace-flags -O? -O1
- if ! linux_chkconfig_present INPUT_EVDEV ; then
- eerror "Please enable CONFIG_INPUT_EVDEV in your kernel"
- eerror "pbbuttonsd will not work without it."
- die "Kernel not compiled with CONFIG_INPUT_EVDEV support"
- fi
-
if use x86; then
if use acpi; then
laptop=acpi
@@ -56,11 +50,9 @@ src_install() {
}
pkg_postinst() {
- if linux_chkconfig_module INPUT_EVDEV ; then
- ewarn "Ensure that the evdev kernel module is loaded otherwise"
- ewarn "pbbuttonsd won't work."
- einfo
- fi
+ ewarn "Ensure that the evdev kernel module is loaded otherwise"
+ ewarn "pbbuttonsd won't work."
+ einfo
if use ppc ; then
einfo "It's recommended that you let pbbuttonsd act as the low level"