summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2008-09-22 21:08:19 +0000
committerHanno Böck <hanno@gentoo.org>2008-09-22 21:08:19 +0000
commit1b7716b41989768f3ada51fc24e0313958105f07 (patch)
treeaf77e5ac49513990e6c5e9373b1ee26d26563744 /app-laptop
parentbump patchset to include a patch to fix build with latest ffmpeg (diff)
downloadgentoo-2-1b7716b41989768f3ada51fc24e0313958105f07.tar.gz
gentoo-2-1b7716b41989768f3ada51fc24e0313958105f07.tar.bz2
gentoo-2-1b7716b41989768f3ada51fc24e0313958105f07.zip
hdaps-gl initial commit
(Portage version: 2.2_rc9/cvs/Linux 2.6.27-rc7 x86_64)
Diffstat (limited to 'app-laptop')
-rw-r--r--app-laptop/hdaps-gl/ChangeLog11
-rw-r--r--app-laptop/hdaps-gl/Manifest5
-rw-r--r--app-laptop/hdaps-gl/files/hdaps-gl-0.0.5-as-needed.diff11
-rw-r--r--app-laptop/hdaps-gl/hdaps-gl-0.0.5.ebuild30
-rw-r--r--app-laptop/hdaps-gl/metadata.xml6
5 files changed, 63 insertions, 0 deletions
diff --git a/app-laptop/hdaps-gl/ChangeLog b/app-laptop/hdaps-gl/ChangeLog
new file mode 100644
index 000000000000..644875d396f7
--- /dev/null
+++ b/app-laptop/hdaps-gl/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-laptop/hdaps-gl
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/hdaps-gl/ChangeLog,v 1.1 2008/09/22 21:08:18 hanno Exp $
+
+*hdaps-gl-0.0.5 (22 Sep 2008)
+
+ 22 Sep 2008; Hanno Boeck <hanno@gentoo.org>
+ +files/hdaps-gl-0.0.5-as-needed.diff, +metadata.xml,
+ +hdaps-gl-0.0.5.ebuild:
+ Initial commit of hdaps-gl, tool for thinkpad hdaps enabled laptops.
+
diff --git a/app-laptop/hdaps-gl/Manifest b/app-laptop/hdaps-gl/Manifest
new file mode 100644
index 000000000000..42cf68b6e54b
--- /dev/null
+++ b/app-laptop/hdaps-gl/Manifest
@@ -0,0 +1,5 @@
+AUX hdaps-gl-0.0.5-as-needed.diff 346 RMD160 c1f951e559ce3141642dcdb5ffcbd71003860013 SHA1 d6ef925dd0ede23906be29e63399006705ad65f6 SHA256 daa97477fa732fc326b9b497b36eddd953e90aaabbad9721df0a1538f2a4c21a
+DIST hdaps-gl-0.0.5.tar.gz 2495 RMD160 a681193a187273f1d48db978a9bd1f86d624a877 SHA1 4472a8d4c6222c9d7f5b2ffd01baf2af2d4ed68b SHA256 d7696a42be66b09d492345c3a05b7c3b45f5e8e33464d3a74844b78182c73c64
+EBUILD hdaps-gl-0.0.5.ebuild 555 RMD160 cad39860b048d1a265d56e7880a255c135e29009 SHA1 cfd5843b20a048993d515c34cb5e1597cd2b2181 SHA256 2ece90c0aa3786b7408573885a95aca346838cfb942bbc341b3cf7bfcb1832bc
+MISC ChangeLog 350 RMD160 fec33d4218650f027ab53e1ea0b65eaa2921a118 SHA1 b89c26acd8fa3c172b8e4ba5167f09b491f400f8 SHA256 d3a0947b2285c67eb45f88e6adc80a7147cb31f9aca81c1acf7854719ee68177
+MISC metadata.xml 217 RMD160 3b01d5dab901ee93217f72b711954d3cccbb1717 SHA1 e304788b60dd2cf214d360a21d267e8635474d98 SHA256 2f5dfc1eb79d2d9ee02663da6e1449f499c3a37b7f4cc2391e18d7789a314669
diff --git a/app-laptop/hdaps-gl/files/hdaps-gl-0.0.5-as-needed.diff b/app-laptop/hdaps-gl/files/hdaps-gl-0.0.5-as-needed.diff
new file mode 100644
index 000000000000..0d0214033252
--- /dev/null
+++ b/app-laptop/hdaps-gl/files/hdaps-gl-0.0.5-as-needed.diff
@@ -0,0 +1,11 @@
+--- hdaps-gl-0.0.5/Makefile 2005-08-30 20:06:53.000000000 +0200
++++ hdaps-gl-0.0.5-1/Makefile 2008-09-22 22:55:57.000000000 +0200
+@@ -10,7 +10,7 @@
+ all: hdaps-gl
+
+ hdaps-gl: hdaps-gl.c
+- $(CC) $(CFLAGS) $(LIBDIR) $(LIBRARIES) -o hdaps-gl hdaps-gl.c
++ $(CC) $(CFLAGS) $(LIBDIR) -o hdaps-gl hdaps-gl.c $(LIBRARIES)
+
+ clean:
+ rm -f hdaps-gl *.o
diff --git a/app-laptop/hdaps-gl/hdaps-gl-0.0.5.ebuild b/app-laptop/hdaps-gl/hdaps-gl-0.0.5.ebuild
new file mode 100644
index 000000000000..0e2186ed081b
--- /dev/null
+++ b/app-laptop/hdaps-gl/hdaps-gl-0.0.5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/hdaps-gl/hdaps-gl-0.0.5.ebuild,v 1.1 2008/09/22 21:08:18 hanno Exp $
+
+inherit eutils
+
+DESCRIPTION="OpenGL visualization for HDAPS data"
+HOMEPAGE="http://hdaps.sourceforge.net"
+SRC_URI="mirror://sourceforge/hdaps/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="virtual/glu"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-as-needed.diff" || die
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS} ${LDFLAGS}" || die "make failed"
+}
+
+src_install() {
+ dobin ${PN}
+}
diff --git a/app-laptop/hdaps-gl/metadata.xml b/app-laptop/hdaps-gl/metadata.xml
new file mode 100644
index 000000000000..efa54454de71
--- /dev/null
+++ b/app-laptop/hdaps-gl/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer><email>hanno@gentoo.org</email></maintainer>
+</pkgmetadata>