summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-01-15 19:14:09 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-01-15 19:14:09 +0000
commit2b909d59f18db9fd4509c0cfc55efeb02e0f485f (patch)
treee9b3931dbf2cdb6a0307a5174e460f8b38193168 /app-laptop
parentppc64 stable wrt #333947 (diff)
downloadgentoo-2-2b909d59f18db9fd4509c0cfc55efeb02e0f485f.tar.gz
gentoo-2-2b909d59f18db9fd4509c0cfc55efeb02e0f485f.tar.bz2
gentoo-2-2b909d59f18db9fd4509c0cfc55efeb02e0f485f.zip
Version bump
(Portage version: 2.1.9.31/cvs/Linux x86_64)
Diffstat (limited to 'app-laptop')
-rw-r--r--app-laptop/batti/ChangeLog9
-rw-r--r--app-laptop/batti/batti-0.3.8.ebuild42
2 files changed, 49 insertions, 2 deletions
diff --git a/app-laptop/batti/ChangeLog b/app-laptop/batti/ChangeLog
index bca542c40aa3..1c6ceeea0339 100644
--- a/app-laptop/batti/ChangeLog
+++ b/app-laptop/batti/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-laptop/batti
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/batti/ChangeLog,v 1.10 2010/09/28 04:53:40 ssuominen Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/batti/ChangeLog,v 1.11 2011/01/15 19:14:09 hwoarang Exp $
+
+*batti-0.3.8 (15 Jan 2011)
+
+ 15 Jan 2011; Markos Chandras <hwoarang@gentoo.org> +batti-0.3.8.ebuild:
+ Version bump
28 Sep 2010; Samuli Suominen <ssuominen@gentoo.org> batti-0.3.7.ebuild:
Remove sys-apps/devicekit-power from dependencies. Use sys-power/upower.
diff --git a/app-laptop/batti/batti-0.3.8.ebuild b/app-laptop/batti/batti-0.3.8.ebuild
new file mode 100644
index 000000000000..2ede4c5c5ead
--- /dev/null
+++ b/app-laptop/batti/batti-0.3.8.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/batti/batti-0.3.8.ebuild,v 1.1 2011/01/15 19:14:09 hwoarang Exp $
+
+EAPI=3
+
+SUPPORT_PYTHON_ABIS="1"
+PYTHON_DEPEND="2"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit python distutils gnome2-utils
+
+DESCRIPTION="A upower based battery monitor for the system tray, similar to batterymon"
+HOMEPAGE="http://code.google.com/p/batti-gtk/"
+SRC_URI="http://batti-gtk.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libnotify"
+
+RDEPEND="dev-python/pygtk
+ dev-python/dbus-python
+ sys-power/upower
+ libnotify? ( x11-libs/libnotify )"
+DEPEND=""
+
+DOCS="AUTHORS"
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ distutils_pkg_postinst
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ distutils_pkg_postrm
+}