summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJurek Bartuszek <jurek@gentoo.org>2008-06-01 00:27:22 +0000
committerJurek Bartuszek <jurek@gentoo.org>2008-06-01 00:27:22 +0000
commit4349a32169847a9652e7fe24b303355681ae606f (patch)
treef3b16410a43d28375864e589be2c2475dbf02611 /app-laptop
parentdev-util/codeblocks: version bump (bug #211865) (diff)
downloadgentoo-2-4349a32169847a9652e7fe24b303355681ae606f.tar.gz
gentoo-2-4349a32169847a9652e7fe24b303355681ae606f.tar.bz2
gentoo-2-4349a32169847a9652e7fe24b303355681ae606f.zip
app-laptop/acer_acpi: Version bump (bug #214632)
(Portage version: 2.1.4.4)
Diffstat (limited to 'app-laptop')
-rw-r--r--app-laptop/acer_acpi/ChangeLog7
-rw-r--r--app-laptop/acer_acpi/acer_acpi-0.11.2.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/app-laptop/acer_acpi/ChangeLog b/app-laptop/acer_acpi/ChangeLog
index a90584bf629f..bf97ba8d0f81 100644
--- a/app-laptop/acer_acpi/ChangeLog
+++ b/app-laptop/acer_acpi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-laptop/acer_acpi
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/acer_acpi/ChangeLog,v 1.15 2008/01/30 23:44:16 jurek Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/acer_acpi/ChangeLog,v 1.16 2008/06/01 00:27:22 jurek Exp $
+
+*acer_acpi-0.11.2 (01 Jun 2008)
+
+ 01 Jun 2008; Jurek Bartuszek <jurek@gentoo.org> +acer_acpi-0.11.2.ebuild:
+ Version bump (bug #214632)
30 Jan 2008; Jurek Bartuszek <jurek@gentoo.org> acer_acpi-0.10.ebuild:
Appended BACKLIGHT_LCD_SUPPORT to CONFIG_CHECK (bug #195803)
diff --git a/app-laptop/acer_acpi/acer_acpi-0.11.2.ebuild b/app-laptop/acer_acpi/acer_acpi-0.11.2.ebuild
new file mode 100644
index 000000000000..0e325c2122fb
--- /dev/null
+++ b/app-laptop/acer_acpi/acer_acpi-0.11.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/acer_acpi/acer_acpi-0.11.2.ebuild,v 1.1 2008/06/01 00:27:22 jurek Exp $
+
+inherit linux-mod
+
+DESCRIPTION="A kernel module to allow hardware control on newer Acer laptops"
+HOMEPAGE="http://code.google.com/p/aceracpi"
+SRC_URI="http://aceracpi.googlecode.com/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+MODULE_NAMES="wmi-acer(extra:) acer_acpi(extra:)"
+BUILD_TARGETS="all"
+
+CONFIG_CHECK="LEDS_CLASS BACKLIGHT_LCD_SUPPORT"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+ BUILD_PARAMS="KERNELSRC=${KV_DIR} KERNELVERSION=${KV_FULL}"
+}
+
+src_install() {
+ linux-mod_src_install
+ dodoc README NEWS AUTHORS
+}
+
+pkg_postinst() {
+ linux-mod_pkg_postinst
+
+ elog "You can load the module:"
+ elog "% modprobe acer_acpi"
+ elog
+ ewarn "From Version 0.3 on it is sufficient to load acer_acpi ONCE in your"
+ ewarn "/etc/modules.autoload.d/kernel-2.${KV_MINOR} file!"
+ ewarn "If you upgraded from version 0.1 or 0.2, than please delete on of the lines from that file!"
+ elog
+ elog "If you need more info about this driver you can read the README file"
+ elog "% zmore /usr/share/doc/${PF}/README.bz2"
+}