summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2013-05-02 15:26:04 +0000
committerSergey Popov <pinkbyte@gentoo.org>2013-05-02 15:26:04 +0000
commitcf03c3be259e2b473a8676e9a0433484dfa821aa (patch)
tree7443abc28e9652e8c93bb8c2d8957ae2aeddc9df /app-leechcraft
parentBump LeechCraft to 0.5.95, thanks to 0xd34df00d (diff)
downloadgentoo-2-cf03c3be259e2b473a8676e9a0433484dfa821aa.tar.gz
gentoo-2-cf03c3be259e2b473a8676e9a0433484dfa821aa.tar.bz2
gentoo-2-cf03c3be259e2b473a8676e9a0433484dfa821aa.zip
Bump LeechCraft to 0.5.95, thanks to 0xd34df00d
(Portage version: 2.2.0_alpha173/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'app-leechcraft')
-rw-r--r--app-leechcraft/lc-aggregator/ChangeLog7
-rw-r--r--app-leechcraft/lc-aggregator/lc-aggregator-0.5.95.ebuild32
2 files changed, 38 insertions, 1 deletions
diff --git a/app-leechcraft/lc-aggregator/ChangeLog b/app-leechcraft/lc-aggregator/ChangeLog
index 29332f7cf10e..0a31848bb434 100644
--- a/app-leechcraft/lc-aggregator/ChangeLog
+++ b/app-leechcraft/lc-aggregator/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-leechcraft/lc-aggregator
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-aggregator/ChangeLog,v 1.1 2013/03/08 21:54:30 maksbotan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-aggregator/ChangeLog,v 1.2 2013/05/02 15:26:04 pinkbyte Exp $
+
+*lc-aggregator-0.5.95 (02 May 2013)
+
+ 02 May 2013; Sergey Popov <pinkbyte@gentoo.org> +lc-aggregator-0.5.95.ebuild:
+ Bump app-leechcraft/lc-aggregator to 0.5.95, thanks to 0xd34df00d
*lc-aggregator-9999 (08 Mar 2013)
*lc-aggregator-0.5.90 (08 Mar 2013)
diff --git a/app-leechcraft/lc-aggregator/lc-aggregator-0.5.95.ebuild b/app-leechcraft/lc-aggregator/lc-aggregator-0.5.95.ebuild
new file mode 100644
index 000000000000..1b701d3214db
--- /dev/null
+++ b/app-leechcraft/lc-aggregator/lc-aggregator-0.5.95.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-aggregator/lc-aggregator-0.5.95.ebuild,v 1.1 2013/05/02 15:26:04 pinkbyte Exp $
+
+EAPI="4"
+
+inherit leechcraft
+
+DESCRIPTION="Full-featured RSS/Atom feed reader for LeechCraft"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug mysql +sqlite postgres"
+
+DEPEND="~app-leechcraft/lc-core-${PV}[postgres?,sqlite?]
+ dev-qt/qtwebkit:4"
+RDEPEND="${DEPEND}
+ virtual/leechcraft-downloader-http"
+
+REQUIRED_USE="|| ( mysql sqlite postgres )"
+
+pkg_setup(){
+ if use mysql; then
+ ewarn "Support for MySQL databases is experimental and is more likely"
+ ewarn "to contain bugs or mishandle your data than other storage"
+ ewarn "backends. If you do not plan testing the MySQL storage backend"
+ ewarn "itself, consider using other backends."
+ ewarn "Anyway, it is perfectly safe to enable the mysql use flag as"
+ ewarn "long as at least one other storage is enabled since you will"
+ ewarn "be able to choose another storage backend at run time."
+ fi
+}