summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2014-07-10 15:44:13 +0000
committerMichael Weber <xmw@gentoo.org>2014-07-10 15:44:13 +0000
commit72fe688e031d1397877658e6127a5f2f16e729e0 (patch)
tree665c79f75184e862119b513e20e828b7132f323b /app-misc/abduco
parentFix bug #515680 - Bump eid-mw, also commit live ebuild. Thanks to Vincent Hardy (diff)
downloadgentoo-2-72fe688e031d1397877658e6127a5f2f16e729e0.tar.gz
gentoo-2-72fe688e031d1397877658e6127a5f2f16e729e0.tar.bz2
gentoo-2-72fe688e031d1397877658e6127a5f2f16e729e0.zip
Initial import, ebuild by lorem_ipsum, respect CC, fail on test-error.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 62EEF090)
Diffstat (limited to 'app-misc/abduco')
-rw-r--r--app-misc/abduco/ChangeLog8
-rw-r--r--app-misc/abduco/Manifest3
-rw-r--r--app-misc/abduco/abduco-0.1.ebuild50
-rw-r--r--app-misc/abduco/metadata.xml16
4 files changed, 77 insertions, 0 deletions
diff --git a/app-misc/abduco/ChangeLog b/app-misc/abduco/ChangeLog
new file mode 100644
index 000000000000..3252551778a6
--- /dev/null
+++ b/app-misc/abduco/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for app-misc/abduco
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/abduco/ChangeLog,v 1.1 2014/07/10 15:44:13 xmw Exp $
+
+*abduco-0.1 (10 Jul 2014)
+
+ 10 Jul 2014; Michael Weber <xmw@gentoo.org> +abduco-0.1.ebuild, +metadata.xml:
+ Initial import, ebuild by lorem_ipsum, respect CC, fail on test-error.
diff --git a/app-misc/abduco/Manifest b/app-misc/abduco/Manifest
new file mode 100644
index 000000000000..a6b02568e274
--- /dev/null
+++ b/app-misc/abduco/Manifest
@@ -0,0 +1,3 @@
+DIST abduco-0.1.tar.gz 10911 SHA256 b4ef297cb7cc81170dc7edf75385cb1c55e024a52f90c1dd0bc0e9862e6f39b5 SHA512 42fbe02bf2a69bbfc91be36830a70daae5ed934877f1fc36808fe13bce52010d8094254a13292f97e1c6b196e8fca6e0835799c4d626865e21ad7ac6716340d6 WHIRLPOOL 283f7788bf00c5bf58f2f52a943aee85b6117603206d1a7540d5b1b7d8eb8d913b48ac7ac14a166380a3a9518daedcc3084955f3951db9dd2ed640d70bfd6321
+EBUILD abduco-0.1.ebuild 851 SHA256 b5cb0589124b2b8aec6ddf0763a7448261fabc9d6d3c1610a98af6f0785df242 SHA512 e458bae5555876d836341b94b4de24ea4fac2d346a23082db692ded7018ae2f186c595c614189a014f240519bdfa9a53a61559fe02c9cee65bee7974dc1f95e9 WHIRLPOOL 532c9c2f97f985f574340c3bc91ea6bb25f5498e2b928e6949ef33c06a7199773d8dd80c705e7313513ababb4ca4b2493a66b588aca8557810247e2457d81ca0
+MISC metadata.xml 698 SHA256 4cf95773b1e5b3a3bc1ebf4b7b13d664ef03e249d3b6007a20c40426bfa82072 SHA512 2ea4cac5177729e615833c07214949dc89b51e63c2dc3c6bb3d120b929069c14f22e6dec0e43f9ea157595fdc93c6f2d19e81b4f118be1f8f28835505f0dc98e WHIRLPOOL cfc6d0eb023a3927646e042d622557176d2794fd7df22ee6dca63ecc30b0b6b13afcdf4670a3d79b7eb8216bb8f4aac77c705b487ad58c386225d4004f6f82df
diff --git a/app-misc/abduco/abduco-0.1.ebuild b/app-misc/abduco/abduco-0.1.ebuild
new file mode 100644
index 000000000000..93a171ae47d2
--- /dev/null
+++ b/app-misc/abduco/abduco-0.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/abduco/abduco-0.1.ebuild,v 1.1 2014/07/10 15:44:13 xmw Exp $
+
+EAPI=5
+
+inherit eutils savedconfig toolchain-funcs
+
+DESCRIPTION="lightweight session manager with {de,at}tach support."
+HOMEPAGE="http://www.brain-dump.org/projects/abduco/"
+SRC_URI="http://www.brain-dump.org/projects/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_prepare() {
+ sed -e 's:^PREFIX.*:PREFIX = /usr:' \
+ -e 's/-Os//' \
+ -e '/^CC/d' \
+ -i config.mk || die
+
+ sed -e "s/VERSION/${PV}/g" \
+ -i ${PN}.1 || die
+
+ sed -e '/@echo CC/d' \
+ -e 's|@${CC}|$(CC)|g' \
+ -i Makefile || die
+
+ restore_config config.def.h
+ epatch_user
+
+ tc-export CC
+}
+
+src_test() {
+ ./testsuite.sh || die
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc README
+ doman ${PN}.1
+
+ save_config config.def.h
+}
diff --git a/app-misc/abduco/metadata.xml b/app-misc/abduco/metadata.xml
new file mode 100644
index 000000000000..e062d001b116
--- /dev/null
+++ b/app-misc/abduco/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>proxy-maintainers</herd>
+<maintainer>
+ <email>hendrik@consetetur.de</email>
+ <name>Hendrik v. Raven (lorem_ipsum)</name>
+</maintainer>
+<maintainer>
+ <email>xmw@gentoo.org</email>
+ <name>Michael Weber</name>
+</maintainer>
+<longdescription lang="en">
+ abduco provides session management i.e. it allows programs to be run independently from its controlling terminal. That is programs can be detached - run in the background - and then later reattached. Together with dvtm it provides a simpler and cleaner alternative to tmux or screen.
+</longdescription>
+</pkgmetadata>