summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Kohl <citizen428@gentoo.org>2005-08-25 10:47:37 +0000
committerMichael Kohl <citizen428@gentoo.org>2005-08-25 10:47:37 +0000
commitb832799cb4ef1752a8fc08a4b2be3ef40a26553c (patch)
tree4ddf30266af21270b9559c42dc5543e222a6c73e /app-misc/alexandria
parentKDevelop 3.3 prerelease. (diff)
downloadgentoo-2-b832799cb4ef1752a8fc08a4b2be3ef40a26553c.tar.gz
gentoo-2-b832799cb4ef1752a8fc08a4b2be3ef40a26553c.tar.bz2
gentoo-2-b832799cb4ef1752a8fc08a4b2be3ef40a26553c.zip
Version bump. Removed ~amd64 keyword because of new dependency (dev-ruby/ruby-zoom) that has no amd64 keyword.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'app-misc/alexandria')
-rw-r--r--app-misc/alexandria/ChangeLog9
-rw-r--r--app-misc/alexandria/Manifest12
-rw-r--r--app-misc/alexandria/alexandria-0.6.0.ebuild50
-rw-r--r--app-misc/alexandria/files/digest-alexandria-0.6.01
4 files changed, 61 insertions, 11 deletions
diff --git a/app-misc/alexandria/ChangeLog b/app-misc/alexandria/ChangeLog
index 7ad9afbbdca6..a746aaf3d588 100644
--- a/app-misc/alexandria/ChangeLog
+++ b/app-misc/alexandria/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-misc/alexandria
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/alexandria/ChangeLog,v 1.12 2005/08/25 10:42:00 citizen428 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/alexandria/ChangeLog,v 1.13 2005/08/25 10:47:37 citizen428 Exp $
+
+*alexandria-0.6.0 (25 Aug 2005)
+
+ 25 Aug 2005; Michael Kohl <citizen428@gentoo.org>
+ +alexandria-0.6.0.ebuild:
+ Version bump. Removed ~amd64 keyword because of new dependency
+ (dev-ruby/ruby-zoom) that has no amd64 keyword.
25 Aug 2005; Michael Kohl <citizen428@gentoo.org>
-alexandria-0.4.0.ebuild, -alexandria-0.5.0.ebuild:
diff --git a/app-misc/alexandria/Manifest b/app-misc/alexandria/Manifest
index ab2c7d0d5756..2c889e9b406e 100644
--- a/app-misc/alexandria/Manifest
+++ b/app-misc/alexandria/Manifest
@@ -1,14 +1,6 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
+MD5 a1176ca53f40af3353a695bd3ab6697d alexandria-0.6.0.ebuild 1210
MD5 c7d823d8165ec6bec907c32cd2f71ec6 alexandria-0.5.1.ebuild 1567
MD5 1b794f3de9bef46baf35eebf8811b120 ChangeLog 1522
MD5 8efa6365a12e903001e60e3f38150264 metadata.xml 274
MD5 5632496040c8d420260b7233beae6bc3 files/digest-alexandria-0.5.1 68
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.2.4 (GNU/Linux)
-
-iD8DBQFDDaCRehlBotwFZuQRAhc6AKCMUeKnP3HkEp0O30vIAPKgXnnCtwCgkh36
-YRSZ6znlvvTszs/3NbtORrU=
-=xuDX
------END PGP SIGNATURE-----
+MD5 27d2a57dfc7eb1dd11da138847fff0b1 files/digest-alexandria-0.6.0 68
diff --git a/app-misc/alexandria/alexandria-0.6.0.ebuild b/app-misc/alexandria/alexandria-0.6.0.ebuild
new file mode 100644
index 000000000000..1cc948057a3f
--- /dev/null
+++ b/app-misc/alexandria/alexandria-0.6.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/alexandria/alexandria-0.6.0.ebuild,v 1.1 2005/08/25 10:47:37 citizen428 Exp $
+
+inherit ruby gnome2 eutils
+
+IUSE=""
+
+DESCRIPTION="A GNOME application to help you manage your book collection"
+HOMEPAGE="http://alexandria.rubyforge.org/"
+SRC_URI="http://rubyforge.org/frs/download.php/5712/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+USE_RUBY="ruby18"
+
+DOCS="AUTHORS COPYING ChangeLog HACKING NEWS README TODO"
+
+RDEPEND=">=dev-lang/ruby-1.8.0
+ >=dev-ruby/ruby-gettext-0.6.1
+ >=dev-ruby/ruby-gnome2-0.12.0
+ >=dev-ruby/ruby-libglade2-0.12.0
+ >=dev-ruby/ruby-gconf2-0.12.0
+ >=dev-ruby/ruby-gdkpixbuf2-0.12.0
+ >=dev-ruby/ruby-amazon-0.8.3
+ >=dev-ruby/ruby-zoom-0.2.0"
+
+src_compile() {
+ ruby install.rb config || die
+ ruby install.rb setup || die
+}
+
+src_install() {
+ export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL="1"
+ ruby install.rb config --prefix=${D}/usr || die
+ ruby install.rb install || die
+
+ make_desktop_entry alexandria "Alexandria" "/usr/share/${PN}/icons/alexandria_small.png" "Utility"
+}
+
+pkg_postinst() {
+ unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
+
+ gnome2_gconf_install
+
+ # For the next line see bug #76726
+ ${ROOT}/usr/bin/gconftool-2 --shutdown
+}
diff --git a/app-misc/alexandria/files/digest-alexandria-0.6.0 b/app-misc/alexandria/files/digest-alexandria-0.6.0
new file mode 100644
index 000000000000..79e4a252fc81
--- /dev/null
+++ b/app-misc/alexandria/files/digest-alexandria-0.6.0
@@ -0,0 +1 @@
+MD5 02634c264594cd6f6bfd35c880119a25 alexandria-0.6.0.tar.gz 929188