summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuis Medinas <metalgod@gentoo.org>2007-02-02 22:48:38 +0000
committerLuis Medinas <metalgod@gentoo.org>2007-02-02 22:48:38 +0000
commit07550511ef43a137b0f5948c4cc39e96100b82f3 (patch)
tree7818734a2df1f2ae4ceadddf8ecb6cd13cc84d94 /app-misc/beagle
parentabiword 2.4.4 is no longer in portage (diff)
downloadgentoo-2-07550511ef43a137b0f5948c4cc39e96100b82f3.tar.gz
gentoo-2-07550511ef43a137b0f5948c4cc39e96100b82f3.tar.bz2
gentoo-2-07550511ef43a137b0f5948c4cc39e96100b82f3.zip
Version Bump. This release closes bgo #155732 #163958 #164039 #163081 #159454 and #158446.
(Portage version: 2.1.2-r6)
Diffstat (limited to 'app-misc/beagle')
-rw-r--r--app-misc/beagle/ChangeLog10
-rw-r--r--app-misc/beagle/beagle-0.2.15.1.ebuild140
-rw-r--r--app-misc/beagle/files/beagle-0.2.15.1-crawllocation.patch107
-rw-r--r--app-misc/beagle/files/beagle-log-level-warn.patch45
-rw-r--r--app-misc/beagle/files/digest-beagle-0.2.15.13
5 files changed, 304 insertions, 1 deletions
diff --git a/app-misc/beagle/ChangeLog b/app-misc/beagle/ChangeLog
index 7d216158227f..66dbb6c1e491 100644
--- a/app-misc/beagle/ChangeLog
+++ b/app-misc/beagle/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-misc/beagle
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/beagle/ChangeLog,v 1.44 2007/01/28 04:55:05 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/beagle/ChangeLog,v 1.45 2007/02/02 22:48:38 metalgod Exp $
+
+*beagle-0.2.15.1 (02 Feb 2007)
+
+ 02 Feb 2007; Luis Medinas <metalgod@gentoo.org>
+ +files/beagle-0.2.15.1-crawllocation.patch,
+ +files/beagle-log-level-warn.patch, +beagle-0.2.15.1.ebuild:
+ Version Bump. This release closes bgo #155732 #163958 #164039 #163081
+ #159454 and #158446.
28 Jan 2007; Marius Mauch <genone@gentoo.org> beagle-0.2.7.ebuild,
beagle-0.2.13.ebuild, beagle-0.2.14.ebuild:
diff --git a/app-misc/beagle/beagle-0.2.15.1.ebuild b/app-misc/beagle/beagle-0.2.15.1.ebuild
new file mode 100644
index 000000000000..6a4c2af5c2d2
--- /dev/null
+++ b/app-misc/beagle/beagle-0.2.15.1.ebuild
@@ -0,0 +1,140 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/beagle/beagle-0.2.15.1.ebuild,v 1.1 2007/02/02 22:48:38 metalgod Exp $
+
+inherit gnome.org eutils autotools mono
+
+DESCRIPTION="search tool that ransacks your personal information space to find whatever you're looking for"
+HOMEPAGE="http://www.beagle-project.org/"
+
+LICENSE="MIT Apache-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="chm doc evo galago gtk ole pdf python thunderbird"
+
+RDEPEND="
+ >=dev-lang/mono-1.1.16.1
+ app-shells/bash
+ app-arch/zip
+ sys-devel/gettext
+ >=x11-libs/gtk+-2.6.0
+ >=dev-libs/atk-1.2.4
+ >=dev-libs/gmime-2.2.1
+ >=dev-dotnet/gtk-sharp-2.8
+ >=gnome-base/librsvg-2.0
+ >=media-libs/libexif-0.6.0
+ >=dev-libs/libxml2-2.6.19
+
+ || ( >=dev-db/sqlite-3.3.1
+ =dev-db/sqlite-2* )
+
+ || ( ( x11-libs/libX11
+ x11-libs/libXScrnSaver
+ x11-libs/libXt )
+ virtual/x11 )
+
+ gtk? ( >=dev-dotnet/gconf-sharp-2.8
+ >=dev-dotnet/glade-sharp-2.8
+ >=dev-dotnet/gnome-sharp-2.8 )
+
+ python? ( >=dev-lang/python-2.3
+ >=dev-python/pygtk-2.6 )
+
+ evo? ( >=dev-dotnet/evolution-sharp-0.10.2
+ >=dev-dotnet/gconf-sharp-2.3 )
+
+ ole? ( >=app-text/wv-1.2.0
+ >=dev-dotnet/gsf-sharp-0.6
+ >=app-office/gnumeric-1.4.3-r3 )
+ pdf? ( >=app-text/poppler-0.5.1 )
+ chm? ( app-doc/chmlib )
+ galago? ( >=dev-dotnet/galago-sharp-0.5.0 )
+ doc? ( dev-util/gtk-doc )
+ thunderbird? ( >=mail-client/mozilla-thunderbird-1.5 )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ || ( ( x11-proto/xproto
+ x11-proto/scrnsaverproto )
+ virtual/x11 )"
+
+pkg_setup() {
+ if built_with_use dev-libs/gmime mono
+ then
+ einfo "Mono support enabled in dev-libs/gmime, I will continue..."
+ else
+ eerror "Please rebuild dev-libs/gmime, with mono support enabled!"
+ eerror "Try USE=\"mono\" emerge dev-libs/gmime,"
+ eerror "or add \"mono\" to your USE string in /etc/make.conf and"
+ eerror "emerge dev-libs/gmime."
+ die "Mono USE flag must be enabled in dev-libs/gmime"
+ fi
+
+ enewgroup beagleindex
+ enewuser beagleindex -1 -1 /var/lib/cache/beagle beagleindex
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # To prevent excessive revdep-rebuild, gentoo's libexif is sticking to
+ # soversion 10 for now.
+ sed -i -e 's/EXIF_SOVERSION=12/EXIF_SOVERSION=10/' configure.in
+
+ # Multilib fix
+ sed -i -e 's:prefix mono`/lib:libdir mono`:' \
+ ${S}/configure.in || die "sed failed"
+
+ epatch ${FILESDIR}/${PN}-0.2.7-crawltweek.patch
+ epatch ${FILESDIR}/${PN}-log-level-warn.patch
+ epatch ${FILESDIR}/${P}-crawllocation.patch
+
+ eautoreconf
+}
+
+src_compile() {
+ econf \
+ $(use_enable doc gtk-doc) \
+ $(use_enable thunderbird) \
+ $(use_enable evo evolution) \
+ $(use_enable gtk gui) \
+ $(use_enable python ) \
+ $(use_enable ole gsf-sharp ) \
+ --enable-libbeagle \
+ || die "configure failed"
+ emake || die "Make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "Install failed!"
+
+ dodir /usr/share/beagle
+ insinto /usr/share/beagle
+ doins mozilla-extension/beagle.xpi
+
+ dodoc AUTHORS INSTALL NEWS README
+
+ sed -i 's/CRAWL_ENABLED="yes"/CRAWL_ENABLED="no"/' ${D}/etc/beagle/crawl-*
+
+ insinto /etc/beagle
+ doins ${FILESDIR}/crawl-portage
+
+ keepdir /usr/$(get_libdir)/beagle/Backends
+ diropts -o beagleindex -g beagleindex
+ keepdir /var/lib/cache/beagle/indexes
+}
+
+pkg_postinst() {
+ elog "If available, Beagle greatly benefits from using certain operating"
+ elog "system features such as Extended Attributes and inotify."
+ echo
+ elog "If you want static queryables such as the portage tree and system"
+ elog "documentation you will need to edit the /etc/beagle/crawl-* files"
+ elog "and change CRAWL_ENABLE from 'no' to 'yes'."
+ echo
+ elog "For more info on how to create the optimal beagle environment, and"
+ elog "basic usage info, see the Gentoo page of the Beagle website:"
+ elog " http://www.beagle-project.org/Gentoo_Installation"
+}
+
diff --git a/app-misc/beagle/files/beagle-0.2.15.1-crawllocation.patch b/app-misc/beagle/files/beagle-0.2.15.1-crawllocation.patch
new file mode 100644
index 000000000000..d2b15a3e4070
--- /dev/null
+++ b/app-misc/beagle/files/beagle-0.2.15.1-crawllocation.patch
@@ -0,0 +1,107 @@
+--- trunk/beagle/tools/Makefile.am 2007/01/20 00:18:26 3290
++++ trunk/beagle/tools/Makefile.am 2007/01/31 23:44:13 3357
+@@ -29,18 +29,17 @@
+ CRAWL_WRAPPER = beagle-crawl-system
+ CRAWL_WRAPPER_IN = $(CRAWL_WRAPPER).in
+
+-$(CRAWL_WRAPPER) : $(CRAWL_WRAPPER_IN)
++$(CRAWL_WRAPPER): $(CRAWL_WRAPPER_IN)
+ $(WRAPPER_SED) < $(srcdir)/$(CRAWL_WRAPPER_IN) > $@
+ chmod +x $(CRAWL_WRAPPER)
+
++crondir = $(sysconfdir)/cron.daily
++
+ CRAWL_RULES = \
+ $(srcdir)/crawl-rules/crawl-windows \
+ $(srcdir)/crawl-rules/crawl-applications \
+ $(srcdir)/crawl-rules/crawl-documentation
+
+-crondir = $(sysconfdir)/cron.daily
+-cron_SCRIPTS = $(CRAWL_WRAPPER)
+-
+ # FIXME: Per-distribution specific crawl rules
+ configdir = $(sysconfdir)/beagle
+ config_DATA = $(CRAWL_RULES)
+@@ -142,7 +141,7 @@
+
+ TARGETS_MDB = $(TARGETS:%=%.mdb)
+
+-WRAPPERS = \
++BUILT_WRAPPERS = \
+ $(INFO_WRAPPER) \
+ $(SHUTDOWN_WRAPPER) \
+ $(QUERY_WRAPPER) \
+@@ -150,11 +149,11 @@
+ $(CONFIG_WRAPPER)
+
+ if ENABLE_GUI
+-WRAPPERS += $(SETTINGS_WRAPPER)
++BUILT_WRAPPERS += $(SETTINGS_WRAPPER)
+ endif
+
+ if ENABLE_WV1
+-WRAPPERS += $(DOC_EXTRACTOR_WRAPPER)
++BUILT_WRAPPERS += $(DOC_EXTRACTOR_WRAPPER)
+ endif
+
+ PREBUILT_WRAPPERS = \
+@@ -162,9 +161,11 @@
+ beagle-ping \
+ beagle-status
+
+-BIN_WRAPPERS = \
+- $(WRAPPERS) \
+- $(PREBUILT_WRAPPERS)
++BIN_WRAPPERS = $(BUILT_WRAPPERS) $(PREBUILT_WRAPPERS)
++
++WRAPPERS = \
++ $(BIN_WRAPPERS) \
++ $(CRAWL_WRAPPER)
+
+ man_MANS = \
+ beagle-query.1 \
+@@ -184,12 +185,13 @@
+
+ all: $(TARGETS) $(WRAPPERS)
+
+-install-data-local: $(TARGETS)
+- $(mkinstalldirs) $(DESTDIR)$(bindir)
++install-data-local: $(TARGETS) $(WRAPPERS)
+ $(mkinstalldirs) $(DESTDIR)$(pkglibdir)
+ $(INSTALL_DATA) $(TARGETS) $(TARGETS_MDB) $(DESTDIR)$(pkglibdir)
+
+- @for i in $(WRAPPERS); do \
++ $(mkinstalldirs) $(DESTDIR)$(bindir)
++
++ @for i in $(BUILT_WRAPPERS); do \
+ sed -e "s|\#installed=1|installed=1|" < $$i > $$i.tmp; \
+ echo "$(INSTALL_SCRIPT) $$i.tmp $(DESTDIR)$(bindir)/$$i"; \
+ $(INSTALL_SCRIPT) $$i.tmp $(DESTDIR)$(bindir)/$$i || exit 1; \
+@@ -203,6 +205,9 @@
+ rm -f $$i.tmp; \
+ done
+
++ $(mkinstalldirs) $(DESTDIR)$(crondir)
++ $(INSTALL_SCRIPT) $(CRAWL_WRAPPER) $(DESTDIR)$(crondir)
++
+ uninstall-local:
+ cd $(DESTDIR)$(pkglibdir) && rm -f $(TARGETS) && rm -f $(TARGETS_MDB)
+
+@@ -211,6 +216,8 @@
+ rm -f $(DESTDIR)$(bindir)/$$i || exit 1; \
+ done
+
++ cd $(DESTDIR)$(crondir) && rm -f $(CRAWL_WRAPPER)
++
+ EXTRA_DIST = \
+ $(WRAPPER_IN) \
+ $(CRAWL_WRAPPER_IN) \
+@@ -236,7 +243,7 @@
+ CLEANFILES = \
+ $(TARGETS) \
+ $(TARGETS_MDB) \
+- $(WRAPPERS) \
++ $(BUILT_WRAPPERS) \
+ $(CRAWL_WRAPPER) \
+ $(desktop_DATA) \
+ $(desktop_h_files) \
diff --git a/app-misc/beagle/files/beagle-log-level-warn.patch b/app-misc/beagle/files/beagle-log-level-warn.patch
new file mode 100644
index 000000000000..cbd9d1e52eed
--- /dev/null
+++ b/app-misc/beagle/files/beagle-log-level-warn.patch
@@ -0,0 +1,45 @@
+Index: beagled/BeagleDaemon.cs
+===================================================================
+RCS file: /cvs/gnome/beagle/beagled/BeagleDaemon.cs,v
+retrieving revision 1.109
+diff -u -p -u -r1.109 BeagleDaemon.cs
+--- beagled/BeagleDaemon.cs 8 Mar 2006 21:01:50 -0000 1.109
++++ beagled/BeagleDaemon.cs 17 Mar 2006 18:27:58 -0000
+@@ -371,10 +371,7 @@ namespace Beagle.Daemon {
+
+ Log.Initialize (PathFinder.LogDir,
+ "Beagle",
+- // FIXME: We always turn on full debugging output! We are still
+- // debugging this code, after all...
+- //arg_debug ? LogLevel.Debug : LogLevel.Warn,
+- LogLevel.Debug,
++ arg_debug ? LogLevel.Debug : LogLevel.Warn,
+ arg_fg);
+
+ Logger.Log.Info ("Starting Beagle Daemon (version {0})", ExternalStringsHack.Version);
+Index: beagled/IndexHelper/IndexHelper.cs
+===================================================================
+RCS file: /cvs/gnome/beagle/beagled/IndexHelper/IndexHelper.cs,v
+retrieving revision 1.24
+diff -u -p -u -r1.24 IndexHelper.cs
+--- beagled/IndexHelper/IndexHelper.cs 8 Feb 2006 18:19:49 -0000 1.24
++++ beagled/IndexHelper/IndexHelper.cs 4 Apr 2006 20:08:28 -0000
+@@ -61,16 +61,13 @@ namespace Beagle.IndexHelper {
+ bool run_by_hand = (Environment.GetEnvironmentVariable ("BEAGLE_RUN_HELPER_BY_HAND") != null);
+ bool log_in_fg = (Environment.GetEnvironmentVariable ("BEAGLE_LOG_IN_THE_FOREGROUND_PLEASE") != null);
+
+- // FIXME: We always turn on full debugging output! We are still
+- // debugging this code, after all...
+- //bool debug = (Environment.GetEnvironmentVariable ("BEAGLE_DEBUG_FLAG_IS_SET") != null);
++ bool debug = (Environment.GetEnvironmentVariable ("BEAGLE_DEBUG_FLAG_IS_SET") != null);
+
+ last_activity = DateTime.Now;
+
+ Log.Initialize (PathFinder.LogDir,
+ "IndexHelper",
+- //debug ? LogLevel.Debug : LogLevel.Warn,
+- LogLevel.Debug,
++ debug ? LogLevel.Debug : LogLevel.Warn,
+ run_by_hand || log_in_fg);
+
+ Application.InitCheck ("IndexHelper", ref args);
diff --git a/app-misc/beagle/files/digest-beagle-0.2.15.1 b/app-misc/beagle/files/digest-beagle-0.2.15.1
new file mode 100644
index 000000000000..f493265731b5
--- /dev/null
+++ b/app-misc/beagle/files/digest-beagle-0.2.15.1
@@ -0,0 +1,3 @@
+MD5 91fb5a499467b3ef468a5f003830c9fa beagle-0.2.15.1.tar.bz2 1531263
+RMD160 1c0f316ade2b15eeb96c7d4d6f0e3c2c69901cb8 beagle-0.2.15.1.tar.bz2 1531263
+SHA256 0291b5d76bc011f7ac7989bb5d575780535363fd07bad7abc8f916b96fecf4f3 beagle-0.2.15.1.tar.bz2 1531263