summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-11-05 07:32:17 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-11-05 07:32:17 +0000
commitfa73018e84ab6fbcaa824d73453be1b4e50b9c0b (patch)
tree8e214e88fdac72d198b3a8a3eee1361e7f42190e /app-misc/beanstalkd
parentVersion bump. (diff)
downloadgentoo-2-fa73018e84ab6fbcaa824d73453be1b4e50b9c0b.tar.gz
gentoo-2-fa73018e84ab6fbcaa824d73453be1b4e50b9c0b.tar.bz2
gentoo-2-fa73018e84ab6fbcaa824d73453be1b4e50b9c0b.zip
Bump
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'app-misc/beanstalkd')
-rw-r--r--app-misc/beanstalkd/ChangeLog8
-rw-r--r--app-misc/beanstalkd/beanstalkd-1.8.ebuild46
-rw-r--r--app-misc/beanstalkd/files/init-1.826
3 files changed, 79 insertions, 1 deletions
diff --git a/app-misc/beanstalkd/ChangeLog b/app-misc/beanstalkd/ChangeLog
index 9a0b6ad79efa..975008085da1 100644
--- a/app-misc/beanstalkd/ChangeLog
+++ b/app-misc/beanstalkd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/beanstalkd
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/beanstalkd/ChangeLog,v 1.29 2012/10/01 03:07:18 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/beanstalkd/ChangeLog,v 1.30 2012/11/05 07:32:17 patrick Exp $
+
+*beanstalkd-1.8 (05 Nov 2012)
+
+ 05 Nov 2012; Patrick Lauer <patrick@gentoo.org> +beanstalkd-1.8.ebuild,
+ +files/init-1.8, beanstalkd-1.7.ebuild:
+ Bump
*beanstalkd-1.7 (01 Oct 2012)
diff --git a/app-misc/beanstalkd/beanstalkd-1.8.ebuild b/app-misc/beanstalkd/beanstalkd-1.8.ebuild
new file mode 100644
index 000000000000..486b7adf05cf
--- /dev/null
+++ b/app-misc/beanstalkd/beanstalkd-1.8.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/beanstalkd/beanstalkd-1.8.ebuild,v 1.1 2012/11/05 07:32:17 patrick Exp $
+
+EAPI="4"
+
+PYTHON_DEPEND="test? 2"
+
+inherit eutils python user
+
+DESCRIPTION="A fast, distributed, in-memory workqueue service"
+HOMEPAGE="http://xph.us/software/beanstalkd/"
+SRC_URI="mirror://github/kr/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~x86 ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x64-macos ~x86-macos"
+
+RDEPEND=""
+DEPEND=""
+
+IUSE="test"
+
+pkg_setup() {
+ enewuser beanstalk -1 -1 /var/lib/beanstalkd daemon
+ python_set_active_version 2
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" || die "compile failed"
+}
+
+src_install() {
+ dobin beanstalkd
+
+ DATADIR=/var/lib/${PN}
+ dodir ${DATADIR}
+ fowners beanstalk:daemon ${DATADIR}
+
+ doman doc/"${PN}".1
+
+ dodoc README NEWS.md doc/*.txt
+
+ newconfd "${FILESDIR}/conf-1.4.2" beanstalkd
+ newinitd "${FILESDIR}/init-${PV}" beanstalkd
+}
diff --git a/app-misc/beanstalkd/files/init-1.8 b/app-misc/beanstalkd/files/init-1.8
new file mode 100644
index 000000000000..73358b712f5d
--- /dev/null
+++ b/app-misc/beanstalkd/files/init-1.8
@@ -0,0 +1,26 @@
+#!/sbin/runscript
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of MIT
+# $Header: /var/cvsroot/gentoo-x86/app-misc/beanstalkd/files/init-1.8,v 1.1 2012/11/05 07:32:17 patrick Exp $
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting beanstalkd"
+ /sbin/start-stop-daemon --start \
+ --background \
+ --pidfile ${PIDFILE} --make-pidfile \
+ --exec ${BEANSTALKD_BINARY} \
+ -- -b ${DATADIR} -p ${PORT} -l ${ADDR} -u ${USER}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping beanstalkd"
+ start-stop-daemon --stop --quiet \
+ --pidfile ${PIDFILE} \
+ --exec ${BEANSTALKD_BINARY}
+ eend $?
+} \ No newline at end of file