summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2007-02-04 02:17:49 +0000
committerRyan Hill <dirtyepic@gentoo.org>2007-02-04 02:17:49 +0000
commit46dc1aee999f796d056fb17cf29f2646824c1a75 (patch)
tree8257de8f8932e987103bd7f56d4a55ca7add3d55 /app-misc/countrycodes/countrycodes-1.0.5.ebuild
parentRemove old versions. (diff)
downloadgentoo-2-46dc1aee999f796d056fb17cf29f2646824c1a75.tar.gz
gentoo-2-46dc1aee999f796d056fb17cf29f2646824c1a75.tar.bz2
gentoo-2-46dc1aee999f796d056fb17cf29f2646824c1a75.zip
Fix pre-stripped files and get CC through tc-getCC. Bug #152253.
(Portage version: 2.1.2-r7)
Diffstat (limited to 'app-misc/countrycodes/countrycodes-1.0.5.ebuild')
-rw-r--r--app-misc/countrycodes/countrycodes-1.0.5.ebuild15
1 files changed, 13 insertions, 2 deletions
diff --git a/app-misc/countrycodes/countrycodes-1.0.5.ebuild b/app-misc/countrycodes/countrycodes-1.0.5.ebuild
index afcf57249c87..d5fa31f49e7b 100644
--- a/app-misc/countrycodes/countrycodes-1.0.5.ebuild
+++ b/app-misc/countrycodes/countrycodes-1.0.5.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/countrycodes/countrycodes-1.0.5.ebuild,v 1.17 2006/12/04 20:45:35 eroyf Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/countrycodes/countrycodes-1.0.5.ebuild,v 1.18 2007/02/04 02:17:49 dirtyepic Exp $
+
+inherit eutils toolchain-funcs
DESCRIPTION="An ISO 3166 country code finder"
HOMEPAGE="http://www.grigna.com/diego/linux/countrycodes/"
@@ -15,6 +17,15 @@ RDEPEND="virtual/libc"
DEPEND="${RDEPEND}
sys-apps/sed"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-Makefile.patch
+
+ sed -i -e "s:gcc:$(tc-getCC):" src/Makefile || die "sed failed"
+}
+
src_compile() {
emake -C src CCOPTS="${CFLAGS}" || die "emake failed"
}