summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2011-08-22 22:33:54 +0000
committerUlrich Müller <ulm@gentoo.org>2011-08-22 22:33:54 +0000
commita170b4e8a142b138f68cacc3d29e398c0760a8df (patch)
tree69a0b2bdd7e3225020c64f19886c300f421f0bcf /app-misc/editor-wrapper/editor-wrapper-4.ebuild
parentMake khotkeys also DEPEND, bug 379869 (diff)
downloadgentoo-2-a170b4e8a142b138f68cacc3d29e398c0760a8df.tar.gz
gentoo-2-a170b4e8a142b138f68cacc3d29e398c0760a8df.tar.bz2
gentoo-2-a170b4e8a142b138f68cacc3d29e398c0760a8df.zip
Version bump, fixes bug 380285.
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'app-misc/editor-wrapper/editor-wrapper-4.ebuild')
-rw-r--r--app-misc/editor-wrapper/editor-wrapper-4.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-misc/editor-wrapper/editor-wrapper-4.ebuild b/app-misc/editor-wrapper/editor-wrapper-4.ebuild
new file mode 100644
index 000000000000..10f6689a64b8
--- /dev/null
+++ b/app-misc/editor-wrapper/editor-wrapper-4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/editor-wrapper/editor-wrapper-4.ebuild,v 1.1 2011/08/22 22:33:54 ulm Exp $
+
+EAPI=4
+
+DESCRIPTION="Wrapper scripts that will execute EDITOR or PAGER"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI=""
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE=""
+
+S="${WORKDIR}"
+
+src_prepare() {
+ sed -e 's/@VAR@/EDITOR/g' "${FILESDIR}/${P}.sh" >editor || die
+ sed -e 's/@VAR@/PAGER/g' "${FILESDIR}/${P}.sh" >pager || die
+}
+
+src_install() {
+ exeinto /usr/libexec
+ doexe editor pager
+ # backwards compatibility
+ dosym editor /usr/libexec/gentoo-editor
+}