summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2013-03-01 23:16:50 +0000
committerLars Wendler <polynomial-c@gentoo.org>2013-03-01 23:16:50 +0000
commitc0f676e408f00577025594e4126af90408e1dba6 (patch)
treebd1948598942f95a9db4684e08445bc62534e2ef /app-misc/g15daemon
parentPAM support merged upstream. (diff)
downloadgentoo-2-c0f676e408f00577025594e4126af90408e1dba6.tar.gz
gentoo-2-c0f676e408f00577025594e4126af90408e1dba6.tar.bz2
gentoo-2-c0f676e408f00577025594e4126af90408e1dba6.zip
Added rewritten init script to fix bug #451966
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 0x981CA6FC)
Diffstat (limited to 'app-misc/g15daemon')
-rw-r--r--app-misc/g15daemon/ChangeLog12
-rw-r--r--app-misc/g15daemon/files/g15daemon-1.9.5.3.initd41
-rw-r--r--app-misc/g15daemon/g15daemon-1.9.5.3-r6.ebuild12
-rw-r--r--app-misc/g15daemon/g15daemon-1.9.5.3-r7.ebuild179
-rw-r--r--app-misc/g15daemon/g15daemon-9999.ebuild6
5 files changed, 238 insertions, 12 deletions
diff --git a/app-misc/g15daemon/ChangeLog b/app-misc/g15daemon/ChangeLog
index 4dec2d581937..d69a18e8686f 100644
--- a/app-misc/g15daemon/ChangeLog
+++ b/app-misc/g15daemon/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-misc/g15daemon
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/g15daemon/ChangeLog,v 1.42 2012/10/12 20:22:20 robbat2 Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/g15daemon/ChangeLog,v 1.43 2013/03/01 23:16:49 polynomial-c Exp $
+
+*g15daemon-1.9.5.3-r7 (01 Mar 2013)
+
+ 01 Mar 2013; Lars Wendler <polynomial-c@gentoo.org>
+ g15daemon-1.9.5.3-r6.ebuild, +g15daemon-1.9.5.3-r7.ebuild,
+ +files/g15daemon-1.9.5.3.initd, g15daemon-9999.ebuild:
+ Non-maintainer commit. Added rewritten init script to fix bug #451966. Thanks
+ to Manuel Rüger for reporting this. Moved ebuild with g510 support to -r7.
*g15daemon-1.9.5.3-r6 (12 Oct 2012)
*g15daemon-9999 (12 Oct 2012)
diff --git a/app-misc/g15daemon/files/g15daemon-1.9.5.3.initd b/app-misc/g15daemon/files/g15daemon-1.9.5.3.initd
new file mode 100644
index 000000000000..d2775643f2c1
--- /dev/null
+++ b/app-misc/g15daemon/files/g15daemon-1.9.5.3.initd
@@ -0,0 +1,41 @@
+#!/sbin/runscript
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/g15daemon/files/g15daemon-1.9.5.3.initd,v 1.1 2013/03/01 23:16:50 polynomial-c Exp $
+
+# Init script for g15daemon
+
+pidfile="/var/run/g15daemon.pid"
+command="/usr/sbin/g15daemon"
+command_args=""
+start_stop_daemon_args="--background --pidfile ${pidfile}"
+
+depend() {
+ after hotplug
+ after usb
+ after modules
+}
+
+start_pre() {
+ # Does the input device already exist?
+ if [ -e "/proc/modules" ] ; then
+ if [ ! -e "/dev/input/uinput" ] || [ ! -e "/dev/uinput" ] ; then
+ # We can load modules, but uinput device does not exist
+ einfo "Loading uinput module"
+ /sbin/modprobe uinput > /dev/null 2> /dev/null
+ fi
+ fi
+
+ local SWITCHKEY=""
+ [ "${CLIENT_SWITCH_L1}" = "yes" ] && command_args="--switch"
+}
+
+stop() {
+ ebegin "Stopping g15daemon"
+ local KILLOPT="-k"
+ if [ $BACKLIGHT_OFF = "yes" ]; then
+ KILLOPT="-K"
+ fi
+ start-stop-daemon -R 5 --exec ${command} -- ${KILLOPT}
+ eend $?
+}
diff --git a/app-misc/g15daemon/g15daemon-1.9.5.3-r6.ebuild b/app-misc/g15daemon/g15daemon-1.9.5.3-r6.ebuild
index 40e3ade073b0..f0e21d1feab5 100644
--- a/app-misc/g15daemon/g15daemon-1.9.5.3-r6.ebuild
+++ b/app-misc/g15daemon/g15daemon-1.9.5.3-r6.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/g15daemon/g15daemon-1.9.5.3-r6.ebuild,v 1.1 2012/10/12 20:22:20 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/g15daemon/g15daemon-1.9.5.3-r6.ebuild,v 1.2 2013/03/01 23:16:49 polynomial-c Exp $
EAPI=4
GENTOO_DEPEND_ON_PERL="no"
@@ -15,11 +15,11 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS=""
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
IUSE="perl python static-libs"
DEPEND="virtual/libusb:0
- >=dev-libs/libg15-9999
+ >=dev-libs/libg15-1.2.4
>=dev-libs/libg15render-1.2
perl? (
dev-lang/perl
@@ -31,9 +31,7 @@ RDEPEND="${DEPEND}"
PATCHES=(
"${FILESDIR}/${P}-forgotten-open-mode.patch"
"${FILESDIR}/${P}-overflow-fix.patch"
- "${FILESDIR}/${P}-g510-keys.patch"
)
-
uinput_check() {
ebegin "Checking for uinput support"
local rc=1
@@ -117,7 +115,7 @@ src_install() {
fi
newconfd "${FILESDIR}/${PN}-1.2.7.confd" ${PN}
- newinitd "${FILESDIR}/${PN}-1.2.7-r2.initd" ${PN}
+ newinitd "${FILESDIR}/${PN}-1.9.5.3.initd" ${PN}
dobin "${FILESDIR}/g15daemon-hotplug"
insinto /lib/udev/rules.d
doins "${FILESDIR}/99-g15daemon.rules"
diff --git a/app-misc/g15daemon/g15daemon-1.9.5.3-r7.ebuild b/app-misc/g15daemon/g15daemon-1.9.5.3-r7.ebuild
new file mode 100644
index 000000000000..322ab802c99f
--- /dev/null
+++ b/app-misc/g15daemon/g15daemon-1.9.5.3-r7.ebuild
@@ -0,0 +1,179 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/g15daemon/g15daemon-1.9.5.3-r7.ebuild,v 1.1 2013/03/01 23:16:49 polynomial-c Exp $
+
+EAPI=4
+GENTOO_DEPEND_ON_PERL="no"
+PYTHON_DEPEND="python? *"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit eutils linux-info perl-module python base
+
+DESCRIPTION="G15daemon takes control of the G15 keyboard, through the linux kernel uinput device driver"
+HOMEPAGE="http://g15daemon.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="perl python static-libs"
+
+DEPEND="virtual/libusb:0
+ >=dev-libs/libg15-9999
+ >=dev-libs/libg15render-1.2
+ perl? (
+ dev-lang/perl
+ dev-perl/GDGraph
+ >=dev-perl/Inline-0.4
+ )"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-forgotten-open-mode.patch"
+ "${FILESDIR}/${P}-overflow-fix.patch"
+ "${FILESDIR}/${P}-g510-keys.patch"
+)
+
+uinput_check() {
+ ebegin "Checking for uinput support"
+ local rc=1
+ linux_config_exists && linux_chkconfig_present INPUT_UINPUT
+ rc=$?
+
+ if [[ $rc -ne 0 ]] ; then
+ eerror "To use g15daemon, you need to compile your kernel with uinput support."
+ eerror "Please enable uinput support in your kernel config, found at:"
+ eerror
+ eerror "Device Drivers -> Input Device ... -> Miscellaneous devices -> User level driver support."
+ eerror
+ eerror "Once enabled, you should have the /dev/input/uinput device."
+ eerror "g15daemon will not work without the uinput device."
+ fi
+}
+
+pkg_setup() {
+ linux-info_pkg_setup
+ uinput_check
+ if use python; then
+ python_pkg_setup
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ if use perl; then
+ unpack "./${P}/lang-bindings/perl-G15Daemon-0.2.tar.gz"
+ fi
+ if use python; then
+ unpack "./${P}/lang-bindings/pyg15daemon-0.0.tar.bz2"
+ fi
+}
+
+src_prepare() {
+ if use perl; then
+ perl-module_src_prepare
+ sed -i \
+ -e '1i#!/usr/bin/perl' \
+ "${S}"/contrib/testbindings.pl
+ else
+ # perl-module_src_prepare always calls base_src_prepare
+ base_src_prepare
+ fi
+}
+
+src_configure() {
+ econf \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ $(use_enable static-libs static)
+
+ if use perl; then
+ cd "${WORKDIR}/G15Daemon-0.2"
+ perl-module_src_configure
+ fi
+}
+
+src_compile() {
+ default
+
+ if use perl; then
+ cd "${WORKDIR}/G15Daemon-0.2"
+ perl-module_src_compile
+ fi
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -exec rm -f {} +
+
+ # remove odd docs installed my make
+ rm "${ED}/usr/share/doc/${PF}/"{LICENSE,README.usage}
+
+ insinto /usr/share/${PN}/contrib
+ doins contrib/xmodmaprc
+ doins contrib/xmodmap.sh
+ if use perl; then
+ doins contrib/testbindings.pl
+ fi
+
+ newconfd "${FILESDIR}/${PN}-1.2.7.confd" ${PN}
+ newinitd "${FILESDIR}/${PN}-1.9.5.3.initd" ${PN}
+ dobin "${FILESDIR}/g15daemon-hotplug"
+ insinto /lib/udev/rules.d
+ doins "${FILESDIR}/99-g15daemon.rules"
+
+ insinto /etc
+ doins "${FILESDIR}"/g15daemon.conf
+
+ # Gentoo bug #301340, debian bug #611649
+ exeinto /usr/lib/pm-utils/sleep.d
+ doexe "${FILESDIR}"/20g15daemon
+
+ if use perl; then
+ ebegin "Installing Perl Bindings (G15Daemon.pm)"
+ cd "${WORKDIR}/G15Daemon-0.2"
+ docinto perl
+ perl-module_src_install
+ fi
+
+ if use python; then
+ ebegin "Installing Python Bindings (g15daemon.py)"
+ cd "${WORKDIR}/pyg15daemon"
+
+ installation() {
+ insinto $(python_get_sitedir)
+ doins g15daemon.py
+ }
+ python_execute_function installation
+
+ docinto python
+ dodoc AUTHORS
+ fi
+}
+
+pkg_postinst() {
+ if use python; then
+ python_mod_optimize g15daemon.py
+ echo ""
+ fi
+
+ elog "To use g15daemon, you need to add g15daemon to the default runlevel."
+ elog "This can be done with:"
+ elog "# /sbin/rc-update add g15daemon default"
+ elog "You can edit some g15daemon options at /etc/conf.d/g15daemon"
+ elog ""
+ elog "To have all new keys working in X11, you'll need create a "
+ elog "specific xmodmap in your home directory or edit the existent one."
+ elog ""
+ elog "Create the xmodmap:"
+ elog "cp /usr/share/g15daemon/contrib/xmodmaprc ~/.Xmodmap"
+ elog ""
+ elog "Adding keycodes to an existing xmodmap:"
+ elog "cat /usr/share/g15daemon/contrib/xmodmaprc >> ~/.Xmodmap"
+}
+
+pkg_postrm() {
+ if use python; then
+ python_mod_cleanup g15daemon.py
+ fi
+}
diff --git a/app-misc/g15daemon/g15daemon-9999.ebuild b/app-misc/g15daemon/g15daemon-9999.ebuild
index 0bb8fafc6a9b..3169fcfe8d82 100644
--- a/app-misc/g15daemon/g15daemon-9999.ebuild
+++ b/app-misc/g15daemon/g15daemon-9999.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/g15daemon/g15daemon-9999.ebuild,v 1.1 2012/10/12 20:22:20 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/g15daemon/g15daemon-9999.ebuild,v 1.2 2013/03/01 23:16:49 polynomial-c Exp $
EAPI=4
GENTOO_DEPEND_ON_PERL="no"
@@ -129,7 +129,7 @@ src_install() {
fi
newconfd "${FILESDIR}/${PN}-1.2.7.confd" ${PN}
- newinitd "${FILESDIR}/${PN}-1.2.7-r2.initd" ${PN}
+ newinitd "${FILESDIR}/${PN}-1.9.5.3.initd" ${PN}
dobin "${FILESDIR}/g15daemon-hotplug"
insinto /lib/udev/rules.d
doins "${FILESDIR}/99-g15daemon.rules"