summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-11-30 20:50:28 +0000
committerMike Frysinger <vapier@gentoo.org>2002-11-30 20:50:28 +0000
commit87331061bd776e67544583f88d5b8f44c0ea1b24 (patch)
tree298b68361c1f82adec2b1142a766b3bbc71fc4a5 /app-misc/gtypist
parentChanged src_install () to src_install() (diff)
downloadgentoo-2-87331061bd776e67544583f88d5b8f44c0ea1b24.tar.gz
gentoo-2-87331061bd776e67544583f88d5b8f44c0ea1b24.tar.bz2
gentoo-2-87331061bd776e67544583f88d5b8f44c0ea1b24.zip
Changed econf||die to econf
Diffstat (limited to 'app-misc/gtypist')
-rw-r--r--app-misc/gtypist/gtypist-2.5.ebuild13
-rw-r--r--app-misc/gtypist/gtypist-2.6.2.ebuild13
2 files changed, 14 insertions, 12 deletions
diff --git a/app-misc/gtypist/gtypist-2.5.ebuild b/app-misc/gtypist/gtypist-2.5.ebuild
index 995ad8d006d5..3d283e494b14 100644
--- a/app-misc/gtypist/gtypist-2.5.ebuild
+++ b/app-misc/gtypist/gtypist-2.5.ebuild
@@ -1,15 +1,15 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/gtypist/gtypist-2.5.ebuild,v 1.8 2002/10/20 18:40:22 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/gtypist/gtypist-2.5.ebuild,v 1.9 2002/11/30 20:48:19 vapier Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="GNU Typist (also called gtypist) is a universal typing tutor."
SRC_URI="ftp://ftp.gnu.org/gnu/gtypist/${P}.tar.gz"
HOMEPAGE="http://www.gnu.org/software/gtypist/gtypist.html"
-IUSE="nls"
+
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86"
+IUSE="nls"
DEPEND=">=sys-libs/ncurses-5.2"
@@ -17,14 +17,15 @@ src_compile() {
local myconf
# gtypist uses a built in gettext
- use nls && myconf="--enable-nls" || \
- myconf="--disable-nls"
+ use nls \
+ && myconf="--enable-nls" \
+ || myconf="--disable-nls"
# gtypist also produces some Emacs/XEmacs editing modes if
# emacs/xemacs is present. if emacs/xemacs is not present then
# these emacs modes are not compiled or installed.
- econf ${myconf} || die "./configure failed"
+ econf ${myconf}
emake || die
}
diff --git a/app-misc/gtypist/gtypist-2.6.2.ebuild b/app-misc/gtypist/gtypist-2.6.2.ebuild
index f9a7bf72e900..691fbe3740ca 100644
--- a/app-misc/gtypist/gtypist-2.6.2.ebuild
+++ b/app-misc/gtypist/gtypist-2.6.2.ebuild
@@ -1,15 +1,15 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/gtypist/gtypist-2.6.2.ebuild,v 1.1 2002/11/05 19:29:05 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/gtypist/gtypist-2.6.2.ebuild,v 1.2 2002/11/30 20:49:05 vapier Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="GNU Typist (also called gtypist) is a universal typing tutor."
SRC_URI="mirror://gnu/gtypist/${P}.tar.gz"
HOMEPAGE="http://www.gnu.org/software/gtypist/gtypist.html"
-IUSE="nls"
+
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="~x86"
+IUSE="nls"
DEPEND=">=sys-libs/ncurses-5.2"
@@ -17,14 +17,15 @@ src_compile() {
local myconf
# gtypist uses a built in gettext
- use nls && myconf="--enable-nls" || \
- myconf="--disable-nls"
+ use nls \
+ && myconf="--enable-nls" \
+ || myconf="--disable-nls"
# gtypist also produces some Emacs/XEmacs editing modes if
# emacs/xemacs is present. if emacs/xemacs is not present then
# these emacs modes are not compiled or installed.
- econf ${myconf} || die "./configure failed"
+ econf ${myconf}
emake || die
}