summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-12-21 14:13:13 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-12-21 14:13:13 +0000
commitebe52b9ccdaf123eefef54de4f45e43a1141cabb (patch)
treef1e534514594e298260286b7c555eff5ca2dae89 /app-misc/iguanaIR
parentRecord upstream bug URL and number for parallel make fixes. (diff)
downloadgentoo-2-ebe52b9ccdaf123eefef54de4f45e43a1141cabb.tar.gz
gentoo-2-ebe52b9ccdaf123eefef54de4f45e43a1141cabb.tar.bz2
gentoo-2-ebe52b9ccdaf123eefef54de4f45e43a1141cabb.zip
Fix building with -Wl,--as-needed wrt #294358 by Kacper Kowalik.
(Portage version: 2.2_rc59/cvs/Linux x86_64)
Diffstat (limited to 'app-misc/iguanaIR')
-rw-r--r--app-misc/iguanaIR/ChangeLog8
-rw-r--r--app-misc/iguanaIR/files/iguanaIR-0.93-asneeded.patch29
-rw-r--r--app-misc/iguanaIR/iguanaIR-0.93.ebuild17
3 files changed, 43 insertions, 11 deletions
diff --git a/app-misc/iguanaIR/ChangeLog b/app-misc/iguanaIR/ChangeLog
index cfffd2a3bbfd..61205869531b 100644
--- a/app-misc/iguanaIR/ChangeLog
+++ b/app-misc/iguanaIR/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-misc/iguanaIR
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/iguanaIR/ChangeLog,v 1.1 2008/03/26 17:04:17 hd_brummy Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/iguanaIR/ChangeLog,v 1.2 2009/12/21 14:13:13 ssuominen Exp $
+
+ 21 Dec 2009; Samuli Suominen <ssuominen@gentoo.org> iguanaIR-0.93.ebuild,
+ +files/iguanaIR-0.93-asneeded.patch:
+ Fix building with -Wl,--as-needed wrt #294358 by Kacper Kowalik.
*iguanaIR-0.93 (26 Mar 2008)
diff --git a/app-misc/iguanaIR/files/iguanaIR-0.93-asneeded.patch b/app-misc/iguanaIR/files/iguanaIR-0.93-asneeded.patch
new file mode 100644
index 000000000000..099b1a4ee4f0
--- /dev/null
+++ b/app-misc/iguanaIR/files/iguanaIR-0.93-asneeded.patch
@@ -0,0 +1,29 @@
+--- iguanaIR-0.93.orig/Makefile.in 2009-12-13 15:27:50.942734390 +0100
++++ iguanaIR-0.93/Makefile.in 2009-12-13 15:29:58.580486676 +0100
+@@ -48,14 +48,14 @@
+ igclient igdaemon: libiguanaIR.so
+
+ libiguanaIR.so: iguanaIR.o support.o dataPackets.o pipes.o base.o
+- $(CC) -shared $(CPPFLAGS) $^ -lpopt -lrt -o $@
++ $(CC) -shared $(CPPFLAGS) $^ -o $@ -lpopt -lrt
+
+ igdaemon: daemon.o client-interface.o device-interface.o usbclient.o \
+ list.o compatibility.o
+- $(CC) $(CPPFLAGS) $(CFLAGS) $^ $(LIBS) -lusb -L. -liguanaIR -o $@
++ $(CC) $(CPPFLAGS) $(CFLAGS) $^ -o $@ -L. -liguanaIR -lusb -lpopt
+
+ igclient: client.o list.o
+- $(CC) $(CPPFLAGS) $^ -lpopt -L. -liguanaIR -o $@
++ $(CC) $(CPPFLAGS) $^ -o $@ -L. -liguanaIR -lpopt
+
+ %.o: %.c Makefile iguanaIR.h
+ $(CC) -c $(CPPFLAGS) $(CFLAGS) $< -o $@
+@@ -71,7 +71,7 @@
+ swig $(CPPFLAGS) -python $<
+
+ _iguanaIR.so: iguanaIR_wrap.c
+- $(CC) $(CPPFLAGS) -shared $(CFLAGS) -Wno-strict-aliasing -Wno-unused -Wno-implicit-function-declaration -Wno-long-long @PYTHON_CPPFLAGS@ $^ -L. -liguanaIR -o $@
++ $(CC) $(CPPFLAGS) -shared $(CFLAGS) -Wno-strict-aliasing -Wno-unused -Wno-implicit-function-declaration -Wno-long-long @PYTHON_CPPFLAGS@ $^ -o $@ -L. -liguanaIR
+ endif
+
+ .PHONY: install
diff --git a/app-misc/iguanaIR/iguanaIR-0.93.ebuild b/app-misc/iguanaIR/iguanaIR-0.93.ebuild
index 89036766a3da..1e4ca47934e1 100644
--- a/app-misc/iguanaIR/iguanaIR-0.93.ebuild
+++ b/app-misc/iguanaIR/iguanaIR-0.93.ebuild
@@ -1,16 +1,16 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/iguanaIR/iguanaIR-0.93.ebuild,v 1.1 2008/03/26 17:04:17 hd_brummy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/iguanaIR/iguanaIR-0.93.ebuild,v 1.2 2009/12/21 14:13:13 ssuominen Exp $
inherit eutils flag-o-matic
DESCRIPTION="library for Irman control of Unix software"
-SRC_URI="http://iguanaworks.net/downloads/${P}.tar.bz2"
HOMEPAGE="http://iguanaworks.net/index.php"
+SRC_URI="http://iguanaworks.net/downloads/${P}.tar.bz2"
-SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="~x86 ~amd64"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
IUSE=""
pkg_setup() {
@@ -18,18 +18,17 @@ pkg_setup() {
}
src_unpack() {
-
unpack ${A}
cd "${S}"
sed -e "s:CFLAGS =:CFLAGS ?=:" -i Makefile.in
- epatch "${FILESDIR}/${P}-gentoo.diff"
+ epatch "${FILESDIR}"/${P}-gentoo.diff \
+ "${FILESDIR}"/${P}-asneeded.patch
}
src_install() {
-
- emake install DESTDIR="${D}" || die "emake failed"
+ emake DESTDIR="${D}" install || die
insinto /etc/udev/rules.d/
doins "${FILESDIR}"/40-iguanaIR.rules