summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2005-05-01 20:31:36 +0000
committerMichael Januszewski <spock@gentoo.org>2005-05-01 20:31:36 +0000
commit0a9df362463e9d6db57c920e6ce2853ede215414 (patch)
tree62e7e837f89c2a009e1eada6dcbadc3ce546fc5f /app-misc/linux-logo
parentFixes #85795 Rose and SCSI tape vulnerability (Security fix) (diff)
downloadgentoo-2-0a9df362463e9d6db57c920e6ce2853ede215414.tar.gz
gentoo-2-0a9df362463e9d6db57c920e6ce2853ede215414.tar.bz2
gentoo-2-0a9df362463e9d6db57c920e6ce2853ede215414.zip
Version bump.
(Portage version: 2.0.51.20-r5)
Diffstat (limited to 'app-misc/linux-logo')
-rw-r--r--app-misc/linux-logo/ChangeLog8
-rw-r--r--app-misc/linux-logo/files/digest-linux-logo-4.121
-rw-r--r--app-misc/linux-logo/linux-logo-4.10.ebuild4
-rw-r--r--app-misc/linux-logo/linux-logo-4.12.ebuild71
4 files changed, 81 insertions, 3 deletions
diff --git a/app-misc/linux-logo/ChangeLog b/app-misc/linux-logo/ChangeLog
index fc95d46d14ba..110538a4fd68 100644
--- a/app-misc/linux-logo/ChangeLog
+++ b/app-misc/linux-logo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/linux-logo
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/linux-logo/ChangeLog,v 1.18 2005/04/05 17:42:25 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/linux-logo/ChangeLog,v 1.19 2005/05/01 20:31:36 spock Exp $
+
+*linux-logo-4.12 (01 May 2005)
+
+ 01 May 2005; Michał Januszewski <spock@gentoo.org>
+ linux-logo-4.10.ebuild, +linux-logo-4.12.ebuild:
+ Version bump. Merked 4.10 stable on x86.
05 Apr 2005; Michał Januszewski <spock@gentoo.org>
linux-logo-4.10.ebuild:
diff --git a/app-misc/linux-logo/files/digest-linux-logo-4.12 b/app-misc/linux-logo/files/digest-linux-logo-4.12
new file mode 100644
index 000000000000..30dfbc55abf4
--- /dev/null
+++ b/app-misc/linux-logo/files/digest-linux-logo-4.12
@@ -0,0 +1 @@
+MD5 727a92801656309e6ab703f8b2658fe2 linux_logo-4.12.tar.gz 90209
diff --git a/app-misc/linux-logo/linux-logo-4.10.ebuild b/app-misc/linux-logo/linux-logo-4.10.ebuild
index 1144ea20227b..819af46f9264 100644
--- a/app-misc/linux-logo/linux-logo-4.10.ebuild
+++ b/app-misc/linux-logo/linux-logo-4.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/linux-logo/linux-logo-4.10.ebuild,v 1.2 2005/04/05 17:42:25 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/linux-logo/linux-logo-4.10.ebuild,v 1.3 2005/05/01 20:31:36 spock Exp $
inherit eutils
@@ -12,7 +12,7 @@ SRC_URI="http://www.deater.net/weave/vmwprod/linux_logo/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~sparc ~mips ~hppa ~amd64 ~ppc"
+KEYWORDS="x86 ~sparc ~mips ~hppa ~amd64 ~ppc"
IUSE="nls"
DEPEND="virtual/libc
diff --git a/app-misc/linux-logo/linux-logo-4.12.ebuild b/app-misc/linux-logo/linux-logo-4.12.ebuild
new file mode 100644
index 000000000000..1160248f5e21
--- /dev/null
+++ b/app-misc/linux-logo/linux-logo-4.12.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/linux-logo/linux-logo-4.12.ebuild,v 1.1 2005/05/01 20:31:36 spock Exp $
+
+inherit eutils
+
+MY_P=${PN/-/_}-${PV}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="A utility that displays an ANSI/ASCII logo and some system information"
+HOMEPAGE="http://www.deater.net/weave/vmwprod/linux_logo/"
+SRC_URI="http://www.deater.net/weave/vmwprod/linux_logo/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~mips ~hppa ~amd64 ~ppc"
+IUSE="nls"
+
+DEPEND="virtual/libc
+ >=sys-apps/sed-4"
+RDEPEND="nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ echo "./logos/gentoo.logo" >> logo_config
+ cp ${FILESDIR}/gentoo.logo ${S}/logos/.
+
+ epatch ${FILESDIR}/${PN}-4.07-gentoo-logo.patch
+ sed -i -e 's:.*Trying to open .*::' linux_logo.c
+
+ if ! use nls ; then
+ sed -i 's:cd po && $(MAKE)::' Makefile
+ fi
+}
+
+src_compile() {
+ make || die
+}
+
+src_install() {
+ dobin linux_logo || die
+ doman linux_logo.1.gz
+
+ dodoc BUGS CHANGES README README.CUSTOM_LOGOS TODO USAGE LINUX_LOGO.FAQ
+
+ if use nls ; then
+ dodir /usr/share/locale
+ make INSTALLDIR=${D}/usr/share/locale -C po install || die
+ fi
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/${PN}.initscript ${PN}
+
+ insinto /etc/conf.d
+ newins ${FILESDIR}/${PN}.conf ${PN}
+}
+
+pkg_postinst() {
+ echo
+ einfo "Linux_logo ebuild for Gentoo comes with two Gentoo logos."
+ einfo ""
+ einfo "To display the first Gentoo logo type: linux_logo -L 3"
+ einfo "To display the second Gentoo logo type: linux_logo -L 4"
+ einfo "To display all the logos available type: linux_logo -L list."
+ einfo ""
+ einfo "To start linux_logo on boot, please type:"
+ einfo " rc-update add linux-logo default"
+ einfo "which uses the settings found in"
+ einfo " /etc/conf.d/linux-logo"
+ echo
+}