summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2002-07-14 14:34:10 +0000
committerBrandon Low <lostlogic@gentoo.org>2002-07-14 14:34:10 +0000
commit6f9e906764aa3b3526755e8241d8a05232abd716 (patch)
tree92a333f26392a5a308c45e660c0ca58d273cfc41 /app-misc/lirc
parentUnmasked util-linux-2.11r-r1 (diff)
downloadgentoo-2-6f9e906764aa3b3526755e8241d8a05232abd716.tar.gz
gentoo-2-6f9e906764aa3b3526755e8241d8a05232abd716.tar.bz2
gentoo-2-6f9e906764aa3b3526755e8241d8a05232abd716.zip
Initial ebuild, somewhat overdue, great work by George Sauthoff
Diffstat (limited to 'app-misc/lirc')
-rw-r--r--app-misc/lirc/ChangeLog8
-rw-r--r--app-misc/lirc/files/digest-lirc-0.6.51
-rw-r--r--app-misc/lirc/files/lirc-0.6.5-gentoo.diff293
-rw-r--r--app-misc/lirc/files/lircd22
-rw-r--r--app-misc/lirc/lirc-0.6.5.ebuild123
5 files changed, 447 insertions, 0 deletions
diff --git a/app-misc/lirc/ChangeLog b/app-misc/lirc/ChangeLog
new file mode 100644
index 000000000000..69939b19a539
--- /dev/null
+++ b/app-misc/lirc/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for app-misc/lirc
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/lirc/ChangeLog,v 1.1 2002/07/14 14:34:10 lostlogic Exp $
+
+*lirc-0.6.5 (11 Jul 2002)
+
+ 09 JuL 2002; Georg Sauthoff <g_sauthoff@web.de> lirc-0.6.5.ebuild, files/lircd,
+ files/lirc-0.6.5-gentoo.diff: Initial ebuild.
diff --git a/app-misc/lirc/files/digest-lirc-0.6.5 b/app-misc/lirc/files/digest-lirc-0.6.5
new file mode 100644
index 000000000000..9d62ad96de88
--- /dev/null
+++ b/app-misc/lirc/files/digest-lirc-0.6.5
@@ -0,0 +1 @@
+MD5 35f4ae0b38e96f92db36eb415855f220 lirc-0.6.5.tar.bz2 318552
diff --git a/app-misc/lirc/files/lirc-0.6.5-gentoo.diff b/app-misc/lirc/files/lirc-0.6.5-gentoo.diff
new file mode 100644
index 000000000000..5025aa880d9a
--- /dev/null
+++ b/app-misc/lirc/files/lirc-0.6.5-gentoo.diff
@@ -0,0 +1,293 @@
+diff -ur lirc-0.6.5.orig/daemons/Makefile.am lirc-0.6.5/daemons/Makefile.am
+--- lirc-0.6.5.orig/daemons/Makefile.am Fri Nov 9 22:41:47 2001
++++ lirc-0.6.5/daemons/Makefile.am Sun Jun 2 14:08:26 2002
+@@ -79,8 +79,8 @@
+ test "$(lircmd_conf)" = "" || test -e $(DESTDIR)$(sysconfdir)/lircmd.conf || ($(mkinstalldirs) $(DESTDIR)$(sysconfdir) && $(INSTALL_DATA) $(top_srcdir)/remotes/$(lircmd_conf) $(DESTDIR)$(sysconfdir)/lircmd.conf)
+
+ mkdev:
+- test -e $(DESTDIR)$(devdir)/lircd || ($(mkinstalldirs) $(DESTDIR)$(devdir) && @mknod@ $(DESTDIR)$(devdir)/lircd p)
+- test -e $(DESTDIR)$(devdir)/lircm || ($(mkinstalldirs) $(DESTDIR)$(devdir) && @mknod@ $(DESTDIR)$(devdir)/lircm p)
++ echo "have devfs - no need to mknod"
++ echo "have devfs - no need to mknod"
+
+ rmdev:
+ -$(RM) $(DESTDIR)$(devdir)/lircd
+diff -ur lirc-0.6.5.orig/daemons/Makefile.in lirc-0.6.5/daemons/Makefile.in
+--- lirc-0.6.5.orig/daemons/Makefile.in Sat Jan 26 17:55:14 2002
++++ lirc-0.6.5/daemons/Makefile.in Sun Jun 2 14:08:26 2002
+@@ -496,8 +496,8 @@
+ test "$(lircmd_conf)" = "" || test -e $(DESTDIR)$(sysconfdir)/lircmd.conf || ($(mkinstalldirs) $(DESTDIR)$(sysconfdir) && $(INSTALL_DATA) $(top_srcdir)/remotes/$(lircmd_conf) $(DESTDIR)$(sysconfdir)/lircmd.conf)
+
+ mkdev:
+- test -e $(DESTDIR)$(devdir)/lircd || ($(mkinstalldirs) $(DESTDIR)$(devdir) && @mknod@ $(DESTDIR)$(devdir)/lircd p)
+- test -e $(DESTDIR)$(devdir)/lircm || ($(mkinstalldirs) $(DESTDIR)$(devdir) && @mknod@ $(DESTDIR)$(devdir)/lircm p)
++ echo "have devfs - no need to mknod"
++ echo "have devfs - no need to mknod"
+
+ rmdev:
+ -$(RM) $(DESTDIR)$(devdir)/lircd
+diff -ur lirc-0.6.5.orig/daemons/receive.c lirc-0.6.5/daemons/receive.c
+--- lirc-0.6.5.orig/daemons/receive.c Sun Nov 18 15:14:24 2001
++++ lirc-0.6.5/daemons/receive.c Sun Jun 2 14:07:50 2002
+@@ -17,6 +17,7 @@
+ #include "hardware.h"
+ #include "lircd.h"
+ #include "receive.h"
++#include <limits.h>
+
+ extern struct hardware hw;
+ extern struct ir_remote *last_remote;
+diff -ur lirc-0.6.5.orig/drivers/Makefile.am lirc-0.6.5/drivers/Makefile.am
+--- lirc-0.6.5.orig/drivers/Makefile.am Wed Dec 12 23:40:43 2001
++++ lirc-0.6.5/drivers/Makefile.am Sun Jun 2 14:08:26 2002
+@@ -23,7 +23,7 @@
+ -test "@irtty@" = "" || $(RM) $(DESTDIR)$(devdir)/lirc
+
+ mkdev:
+- test "@driver@" != "mediafocusI" || test -c $(DESTDIR)$(devdir)/lirc || ($(mkinstalldirs) $(DESTDIR)$(devdir) && @mknod@ $(DESTDIR)$(devdir)/lirc c @lirc_major@ 0)
++ test "@driver@" != "mediafocusI" || echo "have devfs - no need to mknod"
+
+ rmdev:
+ -test "@driver@" != "mediafocusI" || test -c $(DESTDIR)$(devdir)/lirc || $(RM) $(DESTDIR)$(devdir)/lirc
+diff -ur lirc-0.6.5.orig/drivers/Makefile.in lirc-0.6.5/drivers/Makefile.in
+--- lirc-0.6.5.orig/drivers/Makefile.in Sat Jan 26 17:54:26 2002
++++ lirc-0.6.5/drivers/Makefile.in Sun Jun 2 14:08:26 2002
+@@ -317,7 +317,7 @@
+ -test "@irtty@" = "" || $(RM) $(DESTDIR)$(devdir)/lirc
+
+ mkdev:
+- test "@driver@" != "mediafocusI" || test -c $(DESTDIR)$(devdir)/lirc || ($(mkinstalldirs) $(DESTDIR)$(devdir) && @mknod@ $(DESTDIR)$(devdir)/lirc c @lirc_major@ 0)
++ test "@driver@" != "mediafocusI" || echo "have devfs - no need to mknod"
+
+ rmdev:
+ -test "@driver@" != "mediafocusI" || test -c $(DESTDIR)$(devdir)/lirc || $(RM) $(DESTDIR)$(devdir)/lirc
+diff -ur lirc-0.6.5.orig/drivers/lirc.h lirc-0.6.5/drivers/lirc.h
+--- lirc-0.6.5.orig/drivers/lirc.h Sat Dec 8 16:07:03 2001
++++ lirc-0.6.5/drivers/lirc.h Sun Jun 2 14:07:50 2002
+@@ -3,7 +3,7 @@
+ #ifndef _LINUX_LIRC_H
+ #define _LINUX_LIRC_H
+
+-#include <limits.h>
++/* #include <limits.h> */
+
+ #include <linux/ioctl.h>
+ #include <asm/types.h>
+@@ -11,11 +11,11 @@
+ #define PULSE_BIT 0x01000000
+ #define PULSE_MASK 0x00FFFFFF
+
+-#if INT_MAX>=PULSE_BIT
++/*#if INT_MAX>=PULSE_BIT*/
+ typedef int lirc_t;
+-#else
++/*#else
+ #error "No appropriate type for lirc data available."
+-#endif
++#endif*/
+
+
+ /*
+diff -ur lirc-0.6.5.orig/drivers/lirc_dev/Makefile.am lirc-0.6.5/drivers/lirc_dev/Makefile.am
+--- lirc-0.6.5.orig/drivers/lirc_dev/Makefile.am Tue Nov 27 19:34:58 2001
++++ lirc-0.6.5/drivers/lirc_dev/Makefile.am Sun Jun 2 14:08:26 2002
+@@ -31,13 +31,13 @@
+ uninstall-local: rmdev
+
+ mkdev:
+- test -c $(DESTDIR)$(devdir)/lirc || ($(mkinstalldirs) $(DESTDIR)$(devdir) && @mknod@ $(DESTDIR)$(devdir)/lirc c @lirc_major@ 0)
++ echo "have devfs - no need to mknod"
+
+ rmdev:
+ -test -c $(DESTDIR)$(devdir)/lirc && $(RM) $(DESTDIR)$(devdir)/lirc
+
+ install-data-local:
+- -@depmod@ -a
++ echo "will do depmod -a later"
+
+ CLEANFILES = $(module_DATA) .$(module_DATA).flags *~
+
+diff -ur lirc-0.6.5.orig/drivers/lirc_dev/Makefile.in lirc-0.6.5/drivers/lirc_dev/Makefile.in
+--- lirc-0.6.5.orig/drivers/lirc_dev/Makefile.in Sat Jan 26 17:54:52 2002
++++ lirc-0.6.5/drivers/lirc_dev/Makefile.in Sun Jun 2 14:08:26 2002
+@@ -343,13 +343,13 @@
+ uninstall-local: rmdev
+
+ mkdev:
+- test -c $(DESTDIR)$(devdir)/lirc || ($(mkinstalldirs) $(DESTDIR)$(devdir) && @mknod@ $(DESTDIR)$(devdir)/lirc c @lirc_major@ 0)
++ echo "have devfs - no need to mknod"
+
+ rmdev:
+ -test -c $(DESTDIR)$(devdir)/lirc && $(RM) $(DESTDIR)$(devdir)/lirc
+
+ install-data-local:
+- -@depmod@ -a
++ echo "will do depmod -a later"
+
+ include $(KERNEL_LOCATION)/Rules.make
+
+diff -ur lirc-0.6.5.orig/drivers/lirc_i2c/lirc_i2c.c lirc-0.6.5/drivers/lirc_i2c/lirc_i2c.c
+--- lirc-0.6.5.orig/drivers/lirc_i2c/lirc_i2c.c Wed Dec 12 23:27:39 2001
++++ lirc-0.6.5/drivers/lirc_i2c/lirc_i2c.c Sun Jun 2 14:07:50 2002
+@@ -45,7 +45,8 @@
+ #include <linux/timer.h>
+ #include <linux/delay.h>
+ #include <linux/errno.h>
+-#include <linux/malloc.h>
++/*#include <linux/malloc.h>*/
++#include <linux/slab.h>
+ #include <linux/i2c.h>
+
+ #ifndef I2C_CLIENT_END
+diff -ur lirc-0.6.5.orig/drivers/lirc_it87/Makefile.am lirc-0.6.5/drivers/lirc_it87/Makefile.am
+--- lirc-0.6.5.orig/drivers/lirc_it87/Makefile.am Wed Dec 12 23:40:43 2001
++++ lirc-0.6.5/drivers/lirc_it87/Makefile.am Sun Jun 2 14:08:26 2002
+@@ -31,13 +31,13 @@
+ uninstall-local: rmdev
+
+ mkdev:
+- test -c $(DESTDIR)$(devdir)/lirc || ($(mkinstalldirs) $(DESTDIR)$(devdir) && @mknod@ $(DESTDIR)$(devdir)/lirc c @lirc_major@ 0)
++ echo "have devfs - no need to mknod"
+
+ rmdev:
+ -test -c $(DESTDIR)$(devdir)/lirc && $(RM) $(DESTDIR)$(devdir)/lirc
+
+ install-data-local:
+- -@depmod@ -a
++ echo "will do depmod -a later"
+
+ CLEANFILES = $(module_DATA) .$(module_DATA).flags *~
+
+diff -ur lirc-0.6.5.orig/drivers/lirc_it87/Makefile.in lirc-0.6.5/drivers/lirc_it87/Makefile.in
+--- lirc-0.6.5.orig/drivers/lirc_it87/Makefile.in Sat Jan 26 17:55:05 2002
++++ lirc-0.6.5/drivers/lirc_it87/Makefile.in Sun Jun 2 14:08:26 2002
+@@ -343,13 +343,13 @@
+ uninstall-local: rmdev
+
+ mkdev:
+- test -c $(DESTDIR)$(devdir)/lirc || ($(mkinstalldirs) $(DESTDIR)$(devdir) && @mknod@ $(DESTDIR)$(devdir)/lirc c @lirc_major@ 0)
++ echo "have devfs - no need to mknod"
+
+ rmdev:
+ -test -c $(DESTDIR)$(devdir)/lirc && $(RM) $(DESTDIR)$(devdir)/lirc
+
+ install-data-local:
+- -@depmod@ -a
++ echo "will do depmod -a later"
+
+ include $(KERNEL_LOCATION)/Rules.make
+
+diff -ur lirc-0.6.5.orig/drivers/lirc_parallel/Makefile.am lirc-0.6.5/drivers/lirc_parallel/Makefile.am
+--- lirc-0.6.5.orig/drivers/lirc_parallel/Makefile.am Tue Nov 27 19:34:59 2001
++++ lirc-0.6.5/drivers/lirc_parallel/Makefile.am Sun Jun 2 14:08:26 2002
+@@ -30,13 +30,13 @@
+ uninstall-local: rmdev
+
+ mkdev:
+- test -c $(DESTDIR)$(devdir)/lirc || ($(mkinstalldirs) $(DESTDIR)$(devdir) && @mknod@ $(DESTDIR)$(devdir)/lirc c @lirc_major@ 0)
++ echo "have devfs - no need to mknod"
+
+ rmdev:
+ -test -c $(DESTDIR)$(devdir)/lirc && $(RM) $(DESTDIR)$(devdir)/lirc
+
+ install-data-local:
+- -@depmod@ -a
++ echo "will do depmod -a later"
+
+ CLEANFILES = $(module_DATA) .$(module_DATA).flags *~
+
+diff -ur lirc-0.6.5.orig/drivers/lirc_parallel/Makefile.in lirc-0.6.5/drivers/lirc_parallel/Makefile.in
+--- lirc-0.6.5.orig/drivers/lirc_parallel/Makefile.in Sat Jan 26 17:54:36 2002
++++ lirc-0.6.5/drivers/lirc_parallel/Makefile.in Sun Jun 2 14:08:26 2002
+@@ -342,13 +342,13 @@
+ uninstall-local: rmdev
+
+ mkdev:
+- test -c $(DESTDIR)$(devdir)/lirc || ($(mkinstalldirs) $(DESTDIR)$(devdir) && @mknod@ $(DESTDIR)$(devdir)/lirc c @lirc_major@ 0)
++ echo "have devfs - no need to mknod"
+
+ rmdev:
+ -test -c $(DESTDIR)$(devdir)/lirc && $(RM) $(DESTDIR)$(devdir)/lirc
+
+ install-data-local:
+- -@depmod@ -a
++ echo "will do depmod -a later"
+
+ include $(KERNEL_LOCATION)/Rules.make
+
+diff -ur lirc-0.6.5.orig/drivers/lirc_serial/Makefile.am lirc-0.6.5/drivers/lirc_serial/Makefile.am
+--- lirc-0.6.5.orig/drivers/lirc_serial/Makefile.am Tue Nov 27 19:34:59 2001
++++ lirc-0.6.5/drivers/lirc_serial/Makefile.am Sun Jun 2 14:08:26 2002
+@@ -30,13 +30,13 @@
+ uninstall-local: rmdev
+
+ mkdev:
+- test -c $(DESTDIR)$(devdir)/lirc || ($(mkinstalldirs) $(DESTDIR)$(devdir) && @mknod@ $(DESTDIR)$(devdir)/lirc c @lirc_major@ 0)
++ echo "have devfs - no need to mknod"
+
+ rmdev:
+ -test -c $(DESTDIR)$(devdir)/lirc && $(RM) $(DESTDIR)$(devdir)/lirc
+
+ install-data-local:
+- -@depmod@ -a
++ echo "will do depmod -a later"
+
+ CLEANFILES = $(module_DATA) .$(module_DATA).flags *~
+
+diff -ur lirc-0.6.5.orig/drivers/lirc_serial/Makefile.in lirc-0.6.5/drivers/lirc_serial/Makefile.in
+--- lirc-0.6.5.orig/drivers/lirc_serial/Makefile.in Sat Jan 26 17:54:31 2002
++++ lirc-0.6.5/drivers/lirc_serial/Makefile.in Sun Jun 2 14:08:26 2002
+@@ -342,13 +342,13 @@
+ uninstall-local: rmdev
+
+ mkdev:
+- test -c $(DESTDIR)$(devdir)/lirc || ($(mkinstalldirs) $(DESTDIR)$(devdir) && @mknod@ $(DESTDIR)$(devdir)/lirc c @lirc_major@ 0)
++ echo "have devfs - no need to mknod"
+
+ rmdev:
+ -test -c $(DESTDIR)$(devdir)/lirc && $(RM) $(DESTDIR)$(devdir)/lirc
+
+ install-data-local:
+- -@depmod@ -a
++ echo "will do depmod -a later"
+
+ include $(KERNEL_LOCATION)/Rules.make
+
+diff -ur lirc-0.6.5.orig/drivers/lirc_sir/Makefile.am lirc-0.6.5/drivers/lirc_sir/Makefile.am
+--- lirc-0.6.5.orig/drivers/lirc_sir/Makefile.am Tue Nov 27 19:34:59 2001
++++ lirc-0.6.5/drivers/lirc_sir/Makefile.am Sun Jun 2 14:08:26 2002
+@@ -30,13 +30,13 @@
+ uninstall-local: rmdev
+
+ mkdev:
+- test -c $(DESTDIR)$(devdir)/lirc || ($(mkinstalldirs) $(DESTDIR)$(devdir) && @mknod@ $(DESTDIR)$(devdir)/lirc c @lirc_major@ 0)
++ echo "have devfs - no need to mknod"
+
+ rmdev:
+ -test -c $(DESTDIR)$(devdir)/lirc && $(RM) $(DESTDIR)$(devdir)/lirc
+
+ install-data-local:
+- -@depmod@ -a
++ echo "will do depmod -a later"
+
+ CLEANFILES = $(module_DATA) .$(module_DATA).flags *~
+
+diff -ur lirc-0.6.5.orig/drivers/lirc_sir/Makefile.in lirc-0.6.5/drivers/lirc_sir/Makefile.in
+--- lirc-0.6.5.orig/drivers/lirc_sir/Makefile.in Sat Jan 26 17:54:47 2002
++++ lirc-0.6.5/drivers/lirc_sir/Makefile.in Sun Jun 2 14:08:26 2002
+@@ -342,13 +342,13 @@
+ uninstall-local: rmdev
+
+ mkdev:
+- test -c $(DESTDIR)$(devdir)/lirc || ($(mkinstalldirs) $(DESTDIR)$(devdir) && @mknod@ $(DESTDIR)$(devdir)/lirc c @lirc_major@ 0)
++ echo "have devfs - no need to mknod"
+
+ rmdev:
+ -test -c $(DESTDIR)$(devdir)/lirc && $(RM) $(DESTDIR)$(devdir)/lirc
+
+ install-data-local:
+- -@depmod@ -a
++ echo "will do depmod -a later"
+
+ include $(KERNEL_LOCATION)/Rules.make
+
diff --git a/app-misc/lirc/files/lircd b/app-misc/lirc/files/lircd
new file mode 100644
index 000000000000..60bd33b72a0e
--- /dev/null
+++ b/app-misc/lirc/files/lircd
@@ -0,0 +1,22 @@
+#!/sbin/runscript
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+
+depend()
+{
+ need net
+}
+
+start()
+{
+ ebegin "Starting lircd"
+ start-stop-daemon --start --quiet --exec /usr/sbin/lircd
+ eend $?
+}
+
+stop()
+{
+ ebegin "Stopping lircd"
+ start-stop-daemon --stop --quiet --exec /usr/sbin/lircd
+ eend $?
+}
diff --git a/app-misc/lirc/lirc-0.6.5.ebuild b/app-misc/lirc/lirc-0.6.5.ebuild
new file mode 100644
index 000000000000..209a30328d4d
--- /dev/null
+++ b/app-misc/lirc/lirc-0.6.5.ebuild
@@ -0,0 +1,123 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/lirc/lirc-0.6.5.ebuild,v 1.1 2002/07/14 14:34:10 lostlogic Exp $
+
+
+DESCRIPTION="LIRC is a package that allows you to decode and send infra-red \
+ signals of many (but not all) commonly used remote controls."
+
+HOMEPAGE="http://www.lirc.org"
+
+[ "x${LIRC_OPTS}" = x ] && LIRC_OPTS="--with-driver=any \
+ --with-port=0x3f8 --with-irq=4"
+
+# This are the defaults. With this support for all supported remotes
+# will be build.
+# If you want other options then set the Environment variable to your needs.
+
+# Note: If you don't specify the driver configure becomes interactiv.
+
+# You have to know, which driver you want;
+# --with-driver=X
+
+# where X is one of:
+# none, any, animax, avermedia, avermedia98,
+# bestbuy, bestbuy2, caraca, chronos, comX,
+# cph03x, cph06x, creative, fly98, flyvideo,
+# hauppauge,hauppauge_dvb, ipaq, irdeo,
+# irdeo_remote, irman, irreal, it87, knc_one,
+# logitech, lptX, mediafocusI, packard_bell,
+# parallel, pctv, pixelview_bt878,
+# pixelview_pak, pixelview_pro, provideo,
+# realmagic, remotemaster, serial, silitek,
+# sir, slinke, tekram, winfast_tv2000
+
+# This could be usefull too
+
+# --with-port=port # port number for the lirc device.
+# --with-irq=irq # irq line for the lirc device.
+# --with-timer=value # timer value for the parallel driver
+# --with-tty=file # tty to use (Irman, RemoteMaster, etc.)
+# --without-soft-carrier # if your serial hw generates carrier
+# --with-transmitter # if you use a transmitter diode
+
+LICENSE="GPL-2"
+KEYWORDS="x86"
+SLOT="0"
+
+DEPEND="virtual/linux-sources
+ virtual/glibc"
+RDEPEND=${DEPEND}
+
+SRC_URI="http://unc.dl.sourceforge.net/sourceforge/lirc/${P}.tar.bz2"
+
+S=${WORKDIR}/${P}
+
+src_unpack() {
+ unpack ${P}.tar.bz2
+ patch -p0 < ${FILESDIR}/${P}-gentoo.diff
+
+ # You need my little patch, because with it:
+ # - lirc compiles with gentoo 2.4.19pre-ac and vanilla kernels
+}
+
+
+src_compile() {
+
+ #Let portage tell us where to put our modules
+ check_KV
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --with-kerneldir="/usr/src/linux" \
+ --with-moduledir="/lib/modules/${KV}/misc" \
+ --disable-manage-devices \
+ ${LIRC_OPTS} || die "./configure failed"
+
+ emake || die
+
+ case ${LIRC_OPTS}
+ in
+ *"any"*)
+ emake -C drivers "SUBDIRS=lirc_dev lirc_serial \
+ lirc_parallel lirc_sir lirc_it87 lirc_i2c lirc_gpio" || die
+ ;;
+ esac
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+
+ case ${LIRC_OPTS}
+ in
+ *"any"*)
+ insinto /lib/modules/${KV}/misc
+ for i in lirc_dev lirc_serial \
+ lirc_parallel lirc_sir lirc_it87 lirc_i2c lirc_gpio
+ do
+ doins drivers/${i}/${i}.o
+ done
+ ;;
+ esac
+
+ exeinto /etc/init.d
+ doexe ${FILESDIR}/lircd
+}
+
+pkg_postinst () {
+ /usr/sbin/update-modules
+
+ einfo
+ einfo "The lirc Linux Infrared Remote Control Package has been"
+ einfo "merged, please read the documentation, and if necessary"
+ einfo "add what is needed to /etc/modules.autoload or"
+ einfo "/etc/modules.d. If you need special compile options"
+ einfo "then read the comments at the begin of this"
+ einfo "ebuild (source) and set the LIRC_OPTS environment"
+ einfo "variable to your needs."
+ einfo
+}
+