summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-08-28 13:16:24 +0000
committerIan Delaney <idella4@gentoo.org>2013-08-28 13:16:24 +0000
commit391c021e621d8c017df56b6a625080e651a1aa9d (patch)
tree2512f729790f9fe97d721218fc937ed64da14670 /app-misc/note
parentFix wxwidgets dependency and DEPEND (diff)
downloadgentoo-2-391c021e621d8c017df56b6a625080e651a1aa9d.tar.gz
gentoo-2-391c021e621d8c017df56b6a625080e651a1aa9d.tar.bz2
gentoo-2-391c021e621d8c017df56b6a625080e651a1aa9d.zip
revbump -> EAPI 5
(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'app-misc/note')
-rw-r--r--app-misc/note/ChangeLog10
-rw-r--r--app-misc/note/note-1.3.3-r1.ebuild56
2 files changed, 63 insertions, 3 deletions
diff --git a/app-misc/note/ChangeLog b/app-misc/note/ChangeLog
index 8bdd359ba749..a65606d0da8c 100644
--- a/app-misc/note/ChangeLog
+++ b/app-misc/note/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/note
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/note/ChangeLog,v 1.24 2008/07/31 16:45:08 ulm Exp $
+# Copyright 2000-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/note/ChangeLog,v 1.25 2013/08/28 13:16:24 idella4 Exp $
+
+*note-1.3.3-r1 (28 Aug 2013)
+
+ 28 Aug 2013; Ian Delaney <idella4@gentoo.org> +note-1.3.3-r1.ebuild:
+ revbump -> EAPI 5
31 Jul 2008; Ulrich Mueller <ulm@gentoo.org> metadata.xml:
Add USE flag description to metadata wrt GLEP 56.
@@ -80,4 +85,3 @@
21 Jan 2004; <rphillips@gentoo.org> note-1.2.5.ebuild:
New package.
-
diff --git a/app-misc/note/note-1.3.3-r1.ebuild b/app-misc/note/note-1.3.3-r1.ebuild
new file mode 100644
index 000000000000..19cccf946a04
--- /dev/null
+++ b/app-misc/note/note-1.3.3-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/note/note-1.3.3-r1.ebuild,v 1.1 2013/08/28 13:16:24 idella4 Exp $
+
+EAPI=5
+
+inherit perl-module
+
+DESCRIPTION="A note taking perl program"
+HOMEPAGE="http://www.daemon.de/NOTE"
+SRC_URI="http://www.daemon.de/files/mirror/ftp.daemon.de/scip/Apps/note/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="crypt dbm general mysql text"
+
+DEPEND="dev-perl/TermReadKey
+ dev-perl/Term-ReadLine-Perl
+ virtual/perl-Storable
+ dev-perl/config-general
+ crypt? ( dev-perl/crypt-cbc
+ dev-perl/Crypt-Blowfish
+ dev-perl/Crypt-DES )
+ mysql? ( virtual/mysql
+ dev-perl/DBD-mysql )"
+RDEPEND=""
+
+src_install() {
+ perl-module_src_install
+
+ # Adding some basic utitily for testing note
+ dodir /usr/share/${PN}
+ cp "${S}/bin/stresstest.sh" "${D}/usr/share/${PN}"
+
+ # Adding some help for mysql backend driver
+ if use mysql; then
+ dodir /usr/share/${PN}/mysql
+ cp -r "${S}/mysql" "${D}/usr/share/${PN}"
+ fi
+
+ # Adding a sample configuration file
+ dodir /etc
+ cp "${S}/config/noterc" "${D}/etc"
+
+ # Supressing file not needed
+ for v in mysql text dbm general; do
+ if ! use ${v}; then
+ for u in `find "${D}" -type f -name *${v}.*pm`; do
+ rm "${u}"
+ done
+ fi
+ done
+
+ dodoc UPGRADE VERSION
+}