summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Lutgens <blutgens@gentoo.org>2001-04-22 01:19:37 +0000
committerBen Lutgens <blutgens@gentoo.org>2001-04-22 01:19:37 +0000
commit7eaa39a9f9563cd8f709651048c49f81e9667f18 (patch)
treec74036d6a7869f4e8c0f40310669fd8d8bedca85 /app-misc/screen
parentAdded the new gnupg package to ChangeLog, also not that I've created a new (diff)
downloadgentoo-2-7eaa39a9f9563cd8f709651048c49f81e9667f18.tar.gz
gentoo-2-7eaa39a9f9563cd8f709651048c49f81e9667f18.tar.bz2
gentoo-2-7eaa39a9f9563cd8f709651048c49f81e9667f18.zip
Added screen to app-misc/
Diffstat (limited to 'app-misc/screen')
-rw-r--r--app-misc/screen/screen-3.9.8.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-misc/screen/screen-3.9.8.ebuild b/app-misc/screen/screen-3.9.8.ebuild
new file mode 100644
index 000000000000..db0ce88a8590
--- /dev/null
+++ b/app-misc/screen/screen-3.9.8.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Ben Lutgens
+# $Header: /home/blutgens/gentoo-x86/app-misc/screen.ebuild,v 1.2 2001/04/21
+# 19:25 CST blutgens Exp $
+
+#P=
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION=" Screen is a full-screen window manager that multiplexes a
+physical terminal between several processes"
+SRC_URI="ftp://ftp.uni-erlangen.de/pub/utilities/screen/${A}"
+HOMEPAGE="http://www.gnu.org/software/screen/"
+
+DEPEND=">=sys-libs/glibc-2.1.3
+ >=sys-libs/gpm-1.19.3
+ >=sys-libs/ncurses-5.2"
+
+src_compile() {
+
+ try ./configure --prefix=/usr --host=${CHOST}\
+ --mandir=/usr/share --libexecdir=/usr/lib/misc\
+ --host=${CHOST}
+ try make
+
+}
+
+src_install () {
+
+ try make DESTDIR=${D} install
+ insinto /etc
+ doins etc/screenrc
+ dodoc README ChangeLog INSTALL COPYING TODO
+ docinto doc
+ cd doc
+ dodoc FAQ README.DOTSCREEN fdpat.ps window_to_display.ps
+}
+