summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGordon Malm <gengor@gentoo.org>2009-07-23 21:48:24 +0000
committerGordon Malm <gengor@gentoo.org>2009-07-23 21:48:24 +0000
commit0b141054aa70e69bdf327c7c965c1983d7cea59d (patch)
tree0d0667c5aa4bd0f36e3861ca542bc6820b68ff67 /app-misc/sphinx
parentVersion bump. Translation updates. (diff)
downloadgentoo-2-0b141054aa70e69bdf327c7c965c1983d7cea59d.tar.gz
gentoo-2-0b141054aa70e69bdf327c7c965c1983d7cea59d.tar.bz2
gentoo-2-0b141054aa70e69bdf327c7c965c1983d7cea59d.zip
Version bump 0.9.9_rc2, add id64 USE flag #268122, redigest libstemmer_c.tgz #276252, cleanup /etc #269514.
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'app-misc/sphinx')
-rw-r--r--app-misc/sphinx/ChangeLog12
-rw-r--r--app-misc/sphinx/metadata.xml1
-rw-r--r--app-misc/sphinx/sphinx-0.9.8.1.ebuild17
-rw-r--r--app-misc/sphinx/sphinx-0.9.8.ebuild19
-rw-r--r--app-misc/sphinx/sphinx-0.9.9_rc1.ebuild19
-rw-r--r--app-misc/sphinx/sphinx-0.9.9_rc2.ebuild56
6 files changed, 93 insertions, 31 deletions
diff --git a/app-misc/sphinx/ChangeLog b/app-misc/sphinx/ChangeLog
index bacc0e4ab01b..b02de41af705 100644
--- a/app-misc/sphinx/ChangeLog
+++ b/app-misc/sphinx/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-misc/sphinx
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/sphinx/ChangeLog,v 1.17 2008/12/22 20:34:48 maekke Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/sphinx/ChangeLog,v 1.18 2009/07/23 21:48:24 gengor Exp $
+
+*sphinx-0.9.9_rc2 (23 Jul 2009)
+
+ 23 Jul 2009; Gordon Malm <gengor@gentoo.org> sphinx-0.9.8.ebuild,
+ sphinx-0.9.8.1.ebuild, sphinx-0.9.9_rc1.ebuild, +sphinx-0.9.9_rc2.ebuild,
+ metadata.xml:
+ Version bump 0.9.9_rc2, add id64 USE flag #268122, redigest
+ libstemmer_c.tgz #276252, cleanup /etc #269514.
22 Dec 2008; Markus Meier <maekke@gentoo.org> sphinx-0.9.8.1.ebuild:
amd64/x86 stable, bug #251894
diff --git a/app-misc/sphinx/metadata.xml b/app-misc/sphinx/metadata.xml
index 880bd13b51d7..e44be86b46e9 100644
--- a/app-misc/sphinx/metadata.xml
+++ b/app-misc/sphinx/metadata.xml
@@ -7,6 +7,7 @@
<name>Caleb Tennis</name>
</maintainer>
<use>
+ <flag name='id64'>use 64-bit document and word IDs</flag>
<flag name='stemmer'>Enable language stemming support</flag>
</use>
</pkgmetadata>
diff --git a/app-misc/sphinx/sphinx-0.9.8.1.ebuild b/app-misc/sphinx/sphinx-0.9.8.1.ebuild
index b3ce7928ef19..ba5871d66876 100644
--- a/app-misc/sphinx/sphinx-0.9.8.1.ebuild
+++ b/app-misc/sphinx/sphinx-0.9.8.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/sphinx/sphinx-0.9.8.1.ebuild,v 1.2 2008/12/22 20:34:48 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/sphinx/sphinx-0.9.8.1.ebuild,v 1.3 2009/07/23 21:48:24 gengor Exp $
inherit eutils autotools
@@ -15,7 +15,7 @@ RESTRICT="mirror"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE="debug mysql postgres stemmer test"
+IUSE="debug id64 mysql postgres stemmer test"
DEPEND="mysql? ( virtual/mysql )
postgres? ( virtual/postgresql-base )"
@@ -36,20 +36,19 @@ src_unpack() {
src_compile() {
econf \
+ --sysconfdir="/etc/${PN}" \
+ $(use_enable id64) \
+ $(use_with debug) \
$(use_with mysql) \
$(use_with postgres pgsql) \
- $(use_with stemmer libstemmer) \
- $(use_with debug) || die "econf failed"
+ $(use_with stemmer libstemmer)
emake || die "emake failed"
}
src_install() {
emake DESTDIR="${D}" install || die "install failed"
- dodoc doc/* example.sql
- dodir /etc/sphinx
- insinto /etc/sphinx
- doins sphinx.conf.dist
+ dodoc doc/*
dodir /var/lib/sphinx
dodir /var/log/sphinx
diff --git a/app-misc/sphinx/sphinx-0.9.8.ebuild b/app-misc/sphinx/sphinx-0.9.8.ebuild
index c38704bb1743..5574f32e68e2 100644
--- a/app-misc/sphinx/sphinx-0.9.8.ebuild
+++ b/app-misc/sphinx/sphinx-0.9.8.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/sphinx/sphinx-0.9.8.ebuild,v 1.3 2008/10/25 20:27:26 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/sphinx/sphinx-0.9.8.ebuild,v 1.4 2009/07/23 21:48:24 gengor Exp $
inherit eutils autotools
@@ -14,8 +14,8 @@ RESTRICT="mirror"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 amd64"
-IUSE="debug mysql postgres stemmer test"
+KEYWORDS="amd64 ~x86"
+IUSE="debug id64 mysql postgres stemmer test"
DEPEND="mysql? ( virtual/mysql )
postgres? ( virtual/postgresql-base )"
@@ -36,20 +36,19 @@ src_unpack() {
src_compile() {
econf \
+ --sysconfdir="/etc/${PN}" \
+ $(use_enable id64) \
+ $(use_with debug) \
$(use_with mysql) \
$(use_with postgres pgsql) \
- $(use_with stemmer libstemmer) \
- $(use_with debug) || die "econf failed"
+ $(use_with stemmer libstemmer)
emake || die "emake failed"
}
src_install() {
emake DESTDIR="${D}" install || die "install failed"
- dodoc doc/* example.sql
- dodir /etc/sphinx
- insinto /etc/sphinx
- doins sphinx.conf.dist
+ dodoc doc/*
dodir /var/lib/sphinx
dodir /var/log/sphinx
diff --git a/app-misc/sphinx/sphinx-0.9.9_rc1.ebuild b/app-misc/sphinx/sphinx-0.9.9_rc1.ebuild
index 19af056a93f3..d815edae0037 100644
--- a/app-misc/sphinx/sphinx-0.9.9_rc1.ebuild
+++ b/app-misc/sphinx/sphinx-0.9.9_rc1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/sphinx/sphinx-0.9.9_rc1.ebuild,v 1.1 2008/12/21 17:46:59 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/sphinx/sphinx-0.9.9_rc1.ebuild,v 1.2 2009/07/23 21:48:24 gengor Exp $
inherit eutils autotools
@@ -14,8 +14,8 @@ RESTRICT="mirror"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~amd64"
-IUSE="debug mysql postgres stemmer test"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug id64 mysql postgres stemmer test"
DEPEND="mysql? ( virtual/mysql )
postgres? ( virtual/postgresql-base )"
@@ -36,20 +36,19 @@ src_unpack() {
src_compile() {
econf \
+ --sysconfdir="/etc/${PN}" \
+ $(use_enable id64) \
+ $(use_with debug) \
$(use_with mysql) \
$(use_with postgres pgsql) \
- $(use_with stemmer libstemmer) \
- $(use_with debug) || die "econf failed"
+ $(use_with stemmer libstemmer)
emake || die "emake failed"
}
src_install() {
emake DESTDIR="${D}" install || die "install failed"
- dodoc doc/* example.sql
- dodir /etc/sphinx
- insinto /etc/sphinx
- doins sphinx.conf.dist
+ dodoc doc/*
dodir /var/lib/sphinx
dodir /var/log/sphinx
diff --git a/app-misc/sphinx/sphinx-0.9.9_rc2.ebuild b/app-misc/sphinx/sphinx-0.9.9_rc2.ebuild
new file mode 100644
index 000000000000..96617f57ee4f
--- /dev/null
+++ b/app-misc/sphinx/sphinx-0.9.9_rc2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/sphinx/sphinx-0.9.9_rc2.ebuild,v 1.1 2009/07/23 21:48:24 gengor Exp $
+
+inherit eutils autotools
+
+MY_P=${P/_/-}
+
+DESCRIPTION="Full-text search engine with support for MySQL and PostgreSQL"
+HOMEPAGE="http://www.sphinxsearch.com/"
+SRC_URI="http://sphinxsearch.com/downloads/${MY_P}.tar.gz
+ stemmer? ( http://snowball.tartarus.org/dist/libstemmer_c.tgz )"
+RESTRICT="mirror"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug id64 mysql postgres stemmer test"
+
+DEPEND="mysql? ( virtual/mysql )
+ postgres? ( virtual/postgresql-base )"
+RDEPEND="${DEPEND}
+ test? ( dev-lang/php )"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${MY_P}.tar.gz
+ if use stemmer; then
+ cd "${S}"
+ unpack libstemmer_c.tgz
+ fi
+ cd "${S}"
+ eautoreconf
+}
+
+src_compile() {
+ econf \
+ --sysconfdir="/etc/${PN}" \
+ $(use_enable id64) \
+ $(use_with debug) \
+ $(use_with mysql) \
+ $(use_with postgres pgsql) \
+ $(use_with stemmer libstemmer)
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ dodoc doc/*
+
+ dodir /var/lib/sphinx
+ dodir /var/log/sphinx
+ dodir /var/run/sphinx
+}