summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Mrozowski <reavertm@gentoo.org>2010-07-29 01:09:37 +0000
committerMaciej Mrozowski <reavertm@gentoo.org>2010-07-29 01:09:37 +0000
commitf498484fa1eb7c62a4fcba4588d581930a732c68 (patch)
treee11c7efa9cb3b0339eaac1a458dcdd780341b008 /app-misc/strigi
parentVersion bump for dev channel release. Removed old ebuild. (diff)
downloadgentoo-2-f498484fa1eb7c62a4fcba4588d581930a732c68.tar.gz
gentoo-2-f498484fa1eb7c62a4fcba4588d581930a732c68.tar.bz2
gentoo-2-f498484fa1eb7c62a4fcba4588d581930a732c68.zip
Add back 0.7.1. It seems 0.7.2 is way too unstable (at least with KDE SC 4.5)
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'app-misc/strigi')
-rw-r--r--app-misc/strigi/ChangeLog6
-rw-r--r--app-misc/strigi/strigi-0.7.1.ebuild104
2 files changed, 109 insertions, 1 deletions
diff --git a/app-misc/strigi/ChangeLog b/app-misc/strigi/ChangeLog
index 58957de485f5..d5c2f21faa24 100644
--- a/app-misc/strigi/ChangeLog
+++ b/app-misc/strigi/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-misc/strigi
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/strigi/ChangeLog,v 1.58 2010/06/27 08:39:30 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/strigi/ChangeLog,v 1.59 2010/07/29 01:09:37 reavertm Exp $
+
+ 29 Jul 2010; Maciej Mrozowski <reavertm@gentoo.org> +strigi-0.7.1.ebuild:
+ Add back 0.7.1. It seems 0.7.2 is way too unstable (at least with KDE SC
+ 4.5)
27 Jun 2010; Christian Faulhammer <fauli@gentoo.org> strigi-0.7.2.ebuild:
x86 stable, bug 322791
diff --git a/app-misc/strigi/strigi-0.7.1.ebuild b/app-misc/strigi/strigi-0.7.1.ebuild
new file mode 100644
index 000000000000..a8a80560df77
--- /dev/null
+++ b/app-misc/strigi/strigi-0.7.1.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/strigi/strigi-0.7.1.ebuild,v 1.4 2010/07/29 01:09:37 reavertm Exp $
+
+EAPI="2"
+
+inherit base cmake-utils
+
+DESCRIPTION="Fast crawling desktop search engine with Qt4 GUI"
+HOMEPAGE="http://strigi.sourceforge.net/"
+SRC_URI="http://www.vandenoever.info/software/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="+clucene +dbus debug exif fam hyperestraier inotify log +qt4 test"
+
+COMMONDEPEND="
+ dev-libs/libxml2
+ virtual/libiconv
+ clucene? ( >=dev-cpp/clucene-0.9.21[-debug] )
+ dbus? (
+ sys-apps/dbus
+ qt4? ( x11-libs/qt-dbus:4 )
+ )
+ exif? ( >=media-gfx/exiv2-0.17 )
+ fam? ( virtual/fam )
+ hyperestraier? ( app-text/hyperestraier )
+ log? ( >=dev-libs/log4cxx-0.10.0 )
+ qt4? (
+ x11-libs/qt-core:4
+ x11-libs/qt-gui:4
+ )
+ !clucene? (
+ !hyperestraier? (
+ >=dev-cpp/clucene-0.9.21[-debug]
+ )
+ )
+"
+DEPEND="${COMMONDEPEND}
+ test? ( dev-util/cppunit )"
+RDEPEND="${COMMONDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.6.4-gcc44.patch"
+ "${FILESDIR}/${PN}-0.6.5-gcc4.4-missing-headers.patch"
+ "${FILESDIR}/${PN}-disable_java.patch"
+)
+
+src_prepare() {
+ base_src_prepare
+ rm cmake/FindQt4.cmake || die "unable to remove obsolete FindQt4 macro."
+}
+
+src_configure() {
+ # Strigi needs either expat or libxml2.
+ # However libxml2 seems to be required in both cases, linking to 2 xml parsers
+ # is just silly, so we forcefully disable linking to expat.
+ # Enabled: POLLING (only reliable way to check for files changed.)
+
+ mycmakeargs=(
+ -DENABLE_EXPAT=OFF -DENABLE_POLLING=ON
+ -DFORCE_DEPS=ON -DENABLE_CPPUNIT=OFF
+ -DENABLE_REGENERATEXSD=OFF
+ $(cmake-utils_use_enable clucene)
+ $(cmake-utils_use_enable dbus)
+ $(cmake-utils_use_enable exif EXIV2)
+ $(cmake-utils_use_enable fam)
+ $(cmake-utils_use_enable hyperestraier)
+ $(cmake-utils_use_enable inotify)
+ $(cmake-utils_use_enable log LOG4CXX)
+ $(cmake-utils_use_enable qt4)
+ )
+
+ if use qt4; then
+ mycmakeargs+=(-DENABLE_DBUS=ON)
+ fi
+
+ if ! use clucene && ! use hyperestraier; then
+ mycmakeargs+=(-DENABLE_CLUCENE=ON)
+ fi
+
+ cmake-utils_src_configure
+}
+
+src_test() {
+ mycmakeargs+=(-DENABLE_CPPUNIT=ON)
+ cmake-utils_src_configure
+ cmake-utils_src_compile
+
+ pushd "${CMAKE_BUILD_DIR}" > /dev/null
+ ctest --extra-verbose || die "Tests failed."
+ popd > /dev/null
+}
+
+pkg_postinst() {
+ if ! use clucene && ! use hyperestraier; then
+ elog "Because you didn't enable either of the supported backends:"
+ elog "clucene or hyperestraier"
+ elog "clucene support was silently installed."
+ elog "If you prefer another backend, be sure to reinstall strigi"
+ elog "and to enable that backend use flag"
+ fi
+}