summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-09-18 16:29:40 +0000
committerJustin Lecher <jlec@gentoo.org>2010-09-18 16:29:40 +0000
commit8f384e98f0712f482dc252a33c2e5464ac644989 (patch)
tree2fe807b72efe877dac0a85051ca7de1b1b2665b8 /app-misc/tdl
parentia64/s390/sh/sparc stable wrt #326339 (diff)
downloadgentoo-2-8f384e98f0712f482dc252a33c2e5464ac644989.tar.gz
gentoo-2-8f384e98f0712f482dc252a33c2e5464ac644989.tar.bz2
gentoo-2-8f384e98f0712f482dc252a33c2e5464ac644989.zip
Respecting LDFLAGS, 337612
(Portage version: 2.2_rc83/cvs/Linux x86_64)
Diffstat (limited to 'app-misc/tdl')
-rw-r--r--app-misc/tdl/ChangeLog10
-rw-r--r--app-misc/tdl/files/1.5.2-ldflags.patch13
-rw-r--r--app-misc/tdl/tdl-1.5.2-r1.ebuild69
3 files changed, 90 insertions, 2 deletions
diff --git a/app-misc/tdl/ChangeLog b/app-misc/tdl/ChangeLog
index 713a57f58343..791370525116 100644
--- a/app-misc/tdl/ChangeLog
+++ b/app-misc/tdl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/tdl
-# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/tdl/ChangeLog,v 1.22 2009/04/13 02:32:19 darkside Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/tdl/ChangeLog,v 1.23 2010/09/18 16:29:40 jlec Exp $
+
+*tdl-1.5.2-r1 (18 Sep 2010)
+
+ 18 Sep 2010; Justin Lecher <jlec@gentoo.org> +files/1.5.2-ldflags.patch,
+ +tdl-1.5.2-r1.ebuild:
+ Respecting LDFLAGS, 337612
13 Apr 2009; Jeremy Olexa <darkside@gentoo.org> -tdl-1.4.1.ebuild,
tdl-1.5.2.ebuild:
diff --git a/app-misc/tdl/files/1.5.2-ldflags.patch b/app-misc/tdl/files/1.5.2-ldflags.patch
new file mode 100644
index 000000000000..d807fdf02246
--- /dev/null
+++ b/app-misc/tdl/files/1.5.2-ldflags.patch
@@ -0,0 +1,13 @@
+diff --git a/Makefile.in b/Makefile.in
+index 46b05ca..eb9b656 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -52,7 +52,7 @@ OBJ = main.o io.o add.o done.o remove.o move.o list.o \
+ all : tdl
+
+ tdl : $(OBJ)
+- $(CC) $(CFLAGS) -o tdl $(OBJ) $(LIB_READLINE)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o tdl $(OBJ) $(LIB_READLINE)
+
+ %.o : %.c
+ $(CC) $(CFLAGS) -c $<
diff --git a/app-misc/tdl/tdl-1.5.2-r1.ebuild b/app-misc/tdl/tdl-1.5.2-r1.ebuild
new file mode 100644
index 000000000000..af599231b77d
--- /dev/null
+++ b/app-misc/tdl/tdl-1.5.2-r1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/tdl/tdl-1.5.2-r1.ebuild,v 1.1 2010/09/18 16:29:40 jlec Exp $
+
+EAPI="3"
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="Command line To Do List manager"
+HOMEPAGE="http://www.rc0.org.uk/tdl/"
+SRC_URI="http://www.rpcurnow.force9.co.uk/tdl/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE="doc readline"
+
+RDEPEND="
+ sys-libs/ncurses
+ sys-libs/readline"
+DEPEND="${RDEPEND}
+ sys-apps/texinfo
+ sys-apps/sed
+ doc? ( virtual/texi2dvi )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-ldflags.patch
+}
+
+src_configure() {
+ tc-export CC
+ local myconf="--prefix=${EPREFIX}/usr"
+
+ if ! use readline; then
+ myconf="${myconf} --without-readline"
+
+ sed -i 's#\($(LIB_READLINE)\)#\1 -lncurses##g' "${S}"/Makefile.in
+ fi
+ sed -i 's#-ltermcap#-lncurses#g' "${S}"/configure
+
+ # XXX: do not replace with econf.
+ "${S}"/configure ${myconf} || die "configure failed, sorry!"
+}
+
+src_compile() {
+ emake all tdl.info tdl.html tdl.txt || die
+ use doc && emake tdl.dvi tdl.ps tdl.pdf
+}
+
+src_install() {
+ local i
+
+ dodoc README NEWS tdl.txt "${FILESDIR}/screenshot.png" || die
+ doinfo tdl.info || die
+ dohtml tdl.html || die
+
+ dobin tdl || die
+ doman tdl.1 || die
+
+ for i in tdl{a,l,d,g}
+ do
+ dosym tdl /usr/bin/${i} || die
+ dosym tdl.1 /usr/share/man/man1/${i}.1 || die
+ done
+
+ if use doc; then
+ dodoc tdl.dvi tdl.ps tdl.pdf || die
+ fi
+}