summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2007-09-20 17:50:44 +0000
committerRaúl Porcel <armin76@gentoo.org>2007-09-20 17:50:44 +0000
commit4ebb3fa46d05291a6ce9ac7241b9689bd5373015 (patch)
tree53670b6198c7576d2443e350fc8c089cfff55c26 /app-misc/tkpasman/tkpasman-2.2b.ebuild
parentStable on ppc; bug #191280. (diff)
downloadgentoo-2-4ebb3fa46d05291a6ce9ac7241b9689bd5373015.tar.gz
gentoo-2-4ebb3fa46d05291a6ce9ac7241b9689bd5373015.tar.bz2
gentoo-2-4ebb3fa46d05291a6ce9ac7241b9689bd5373015.zip
Version bump wrt #190729, fix RDEPEND
(Portage version: 2.1.3.9)
Diffstat (limited to 'app-misc/tkpasman/tkpasman-2.2b.ebuild')
-rw-r--r--app-misc/tkpasman/tkpasman-2.2b.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-misc/tkpasman/tkpasman-2.2b.ebuild b/app-misc/tkpasman/tkpasman-2.2b.ebuild
new file mode 100644
index 000000000000..d1a15e85c031
--- /dev/null
+++ b/app-misc/tkpasman/tkpasman-2.2b.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/tkpasman/tkpasman-2.2b.ebuild,v 1.1 2007/09/20 17:50:43 armin76 Exp $
+
+inherit eutils
+
+MY_P="TkPasMan-${PV}"
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="A useful and reliable personal password manager, written in Tcl/Tk"
+HOMEPAGE="http://www.xs4all.nl/~wbsoft/linux/tkpasman.html"
+SRC_URI="http://www.xs4all.nl/~wbsoft/linux/projects/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="ssl"
+
+DEPEND=">=dev-lang/tcl-8.3
+ >=dev-lang/tk-8.3"
+
+RDEPEND="ssl? ( dev-libs/openssl )
+ ${DEPEND}"
+
+src_unpack() {
+ unpack ${A} && cd "${S}"
+
+ epatch ${FILESDIR}/${PN}-2.2a-gentoo.patch
+
+ use ssl || sed -i "s:^USE_OPENSSL=true:USE_OPENSSL=false:g" config
+}
+
+src_install() {
+ dobin tkpasman || die
+ dodoc README ChangeLog TODO WARNING INSTALL
+}