summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-07-25 19:18:35 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-07-25 19:18:35 +0000
commit6ac305a4a3efb9be218c55f45fb585aec0ffd061 (patch)
tree3ca505bd954944333b6d6cada5fb936e500cbf12 /app-misc/twin
parentAdded SLOT, KEYWORDS, LICENSE, and RDEPEND. (diff)
downloadgentoo-2-6ac305a4a3efb9be218c55f45fb585aec0ffd061.tar.gz
gentoo-2-6ac305a4a3efb9be218c55f45fb585aec0ffd061.tar.bz2
gentoo-2-6ac305a4a3efb9be218c55f45fb585aec0ffd061.zip
repoman'd
Diffstat (limited to 'app-misc/twin')
-rw-r--r--app-misc/twin/twin-0.2.8.ebuild84
-rw-r--r--app-misc/twin/twin-0.3.8-r1.ebuild11
2 files changed, 49 insertions, 46 deletions
diff --git a/app-misc/twin/twin-0.2.8.ebuild b/app-misc/twin/twin-0.2.8.ebuild
index 3cc1300e3475..4de2090a53ca 100644
--- a/app-misc/twin/twin-0.2.8.ebuild
+++ b/app-misc/twin/twin-0.2.8.ebuild
@@ -1,61 +1,61 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/app-misc/twin/twin-0.2.8.ebuild,v 1.5 2002/07/11 06:30:16 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/twin/twin-0.2.8.ebuild,v 1.6 2002/07/25 19:18:35 seemant Exp $
-
-A=${P}.tar.gz
S=${WORKDIR}/${P}
DESCRIPTION="A text-mode window environment"
-SRC_URI="http://ftp1.sourceforge.net/twin/${A}
- http://linuz.sns.it/~max/twin/${A}"
+SRC_URI="http://ftp1.sourceforge.net/twin/${P}.tar.gz
+ http://linuz.sns.it/~max/twin/${P}.tar.gz"
HOMEPAGE="http://linuz.sns.it/~max/twin/"
-DEPEND="virtual/glibc
- X? ( virtual/x11 )
- >=sys-libs/ncurses-5.2"
+
+SLOT="0"
+LICENSE="GPL-2 LGPL-2"
+KEYWORDS="x86"
+
+DEPEND="X? ( virtual/x11 )
+ >=sys-libs/ncurses-5.2"
src_unpack() {
- unpack ${A}
- cd ${S}
- try patch -p1 < ${FILESDIR}/${PF}-gentoo.diff
+ unpack ${A}
+ cd ${S}
+ patch -p1 < ${FILESDIR}/${PF}-gentoo.diff || die
}
src_compile() {
- local conf
-
- conf="\n\n\n\n\n\n\n\n"
- if [ "`use X`" ]
- then
- conf=${conf}"y\n"
- else
- conf=${conf}"n\n"
- fi
- conf=${conf}"\n\n\n\n\n"
- echo -e ${conf} > .temp
- cat .temp | make config
- rm .temp
- try make clean
- try make
+ local conf
+
+ conf="\n\n\n\n\n\n\n\n"
+ use X \
+ && conf=${conf}"y\n" \
+ || conf=${conf}"n\n"
+
+ conf=${conf}"\n\n\n\n\n"
+ echo -e ${conf} > .temp
+ cat .temp | make config
+ rm .temp
+ make clean || die
+ make || die
}
src_install() {
-
- dodir /usr/lib /usr/bin /usr/lib/ /usr/include
+
+ dodir /usr/lib /usr/bin /usr/lib/ /usr/include
- dobin server/twin_real server/twin_wrapper
- dobin clients/twsetroot clients/twevent clients/twmapscrn \
- clients/twedit clients/twterm clients/twattach clients/twsysmon
+ dobin server/twin_real server/twin_wrapper
+ dobin clients/twsetroot clients/twevent clients/twmapscrn \
+ clients/twedit clients/twterm clients/twattach clients/twsysmon
- dolib lib/libTw.so.1.0.0
+ dolib lib/libTw.so.1.0.0
- insinto /usr/include
- doins include/libTwkeys.h include/libTw.h include/libTwerrno.h
+ insinto /usr/include
+ doins include/libTwkeys.h include/libTw.h include/libTwerrno.h
- dosym /usr/bin/twin_wrapper /usr/bin/twin
- dosym /usr/bin/twattach /usr/bin/twdetach
- dosym /usr/lib/libTw.so.1.0.0 /usr/lib/libTw.so.1
- dosym /usr/lib/libTw.so.1 /usr/lib/libTw.so
+ dosym /usr/bin/twin_wrapper /usr/bin/twin
+ dosym /usr/bin/twattach /usr/bin/twdetach
+ dosym /usr/lib/libTw.so.1.0.0 /usr/lib/libTw.so.1
+ dosym /usr/lib/libTw.so.1 /usr/lib/libTw.so
- dodoc BUGS COPYING COPYING.LIB INSTALL README TODO Changelog.txt ${P}.lsm
- docinto clients
- dodoc clients/README.twsetroot clients/twsetroot.sample
+ dodoc BUGS COPYING COPYING.LIB INSTALL README TODO Changelog.txt ${P}.lsm
+ docinto clients
+ dodoc clients/README.twsetroot clients/twsetroot.sample
}
diff --git a/app-misc/twin/twin-0.3.8-r1.ebuild b/app-misc/twin/twin-0.3.8-r1.ebuild
index a0af8e5bde30..9b9794312b6e 100644
--- a/app-misc/twin/twin-0.3.8-r1.ebuild
+++ b/app-misc/twin/twin-0.3.8-r1.ebuild
@@ -1,15 +1,18 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/app-misc/twin/twin-0.3.8-r1.ebuild,v 1.7 2002/07/11 06:30:16 drobbins Exp $
-
+# $Header: /var/cvsroot/gentoo-x86/app-misc/twin/twin-0.3.8-r1.ebuild,v 1.8 2002/07/25 19:18:35 seemant Exp $
S=${WORKDIR}/${P}
DESCRIPTION="A text-mode window environment"
SRC_URI="http://ftp1.sourceforge.net/twin/${P}.tar.gz
http://linuz.sns.it/~max/twin/${P}.tar.gz"
HOMEPAGE="http://linuz.sns.it/~max/twin/"
-DEPEND="virtual/glibc
- X? ( virtual/x11 )
+
+SLOT="0"
+LICENSE="GPL-2 LGPL-2"
+KEYWORDS="x86"
+
+DEPEND="X? ( virtual/x11 )
ggi? ( >=media-libs/libggi-1.9 )
>=sys-libs/gpm-1.19.3
>=sys-libs/ncurses-5.2"