summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Schwarzott <zzam@gentoo.org>2009-10-23 08:13:49 +0000
committerMatthias Schwarzott <zzam@gentoo.org>2009-10-23 08:13:49 +0000
commit817ce4d8ae41dc4f9b136574bf11672aaf5b8ab6 (patch)
tree8d3b10e5f3cab9061aa6cdbdf7b702624ecbca8e /app-misc/usbirboy
parentVersion bump. (diff)
downloadgentoo-2-817ce4d8ae41dc4f9b136574bf11672aaf5b8ab6.tar.gz
gentoo-2-817ce4d8ae41dc4f9b136574bf11672aaf5b8ab6.tar.bz2
gentoo-2-817ce4d8ae41dc4f9b136574bf11672aaf5b8ab6.zip
Fix udev rule syntax.
(Portage version: 2.2_rc46/cvs/Linux i686)
Diffstat (limited to 'app-misc/usbirboy')
-rw-r--r--app-misc/usbirboy/ChangeLog10
-rw-r--r--app-misc/usbirboy/usbirboy-0.3.1-r1.ebuild57
2 files changed, 65 insertions, 2 deletions
diff --git a/app-misc/usbirboy/ChangeLog b/app-misc/usbirboy/ChangeLog
index 840bcb9000fb..e14404befb46 100644
--- a/app-misc/usbirboy/ChangeLog
+++ b/app-misc/usbirboy/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/usbirboy
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/usbirboy/ChangeLog,v 1.18 2008/05/16 20:49:40 zzam Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/usbirboy/ChangeLog,v 1.19 2009/10/23 08:13:49 zzam Exp $
+
+*usbirboy-0.3.1-r1 (23 Oct 2009)
+
+ 23 Oct 2009; Matthias Schwarzott <zzam@gentoo.org>
+ +usbirboy-0.3.1-r1.ebuild:
+ Fix udev rule syntax.
*usbirboy-0.3.1 (16 May 2008)
diff --git a/app-misc/usbirboy/usbirboy-0.3.1-r1.ebuild b/app-misc/usbirboy/usbirboy-0.3.1-r1.ebuild
new file mode 100644
index 000000000000..c2e2484e42b1
--- /dev/null
+++ b/app-misc/usbirboy/usbirboy-0.3.1-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/usbirboy/usbirboy-0.3.1-r1.ebuild,v 1.1 2009/10/23 08:13:49 zzam Exp $
+
+inherit linux-mod eutils
+
+DESCRIPTION="Use home made infrared receiver connected via USB"
+HOMEPAGE="http://usbirboy.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/${P}/usbirboykmod"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+
+ if ! kernel_is 2 6; then
+ die "This package works only with 2.6 kernel!"
+ fi
+
+ if ! linux_chkconfig_present USB; then
+ die "You need a kernel with enabled USB support!"
+ fi
+
+ MODULE_NAMES="usbirboy(misc:${S})"
+ BUILD_PARAMS="INCLUDE=${KV_DIR}"
+ BUILD_TARGETS="clean all"
+}
+
+src_install() {
+ linux-mod_src_install
+
+ dodoc README
+ newdoc ../usbirboymcu/README README.mcu
+
+ insinto /usr/share/${PN}
+ doins ../mcubin/usbirboy.s19
+
+ # Add configuration for udev
+ dodir /etc/udev/rules.d
+ echo 'KERNEL=="usbirboy", SYMLINK+="lirc"' \
+ > "${D}etc/udev/rules.d/30-${PN}.rules"
+}
+
+pkg_postinst() {
+ linux-mod_pkg_postinst
+ elog
+ elog "Firmware file has been installed to /usr/share/${PN}"
+ elog
+}