summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWolfram Schlich <wschlich@gentoo.org>2007-12-07 11:03:42 +0000
committerWolfram Schlich <wschlich@gentoo.org>2007-12-07 11:03:42 +0000
commit67000200fe335a395895082db2b41c650b8155bd (patch)
tree2792c9852baec4aec55fad5efb41e1f1d107c2b1 /app-misc
parentold (diff)
downloadgentoo-2-67000200fe335a395895082db2b41c650b8155bd.tar.gz
gentoo-2-67000200fe335a395895082db2b41c650b8155bd.tar.bz2
gentoo-2-67000200fe335a395895082db2b41c650b8155bd.zip
added myself as maintainer to metadata.xml, version bump
(Portage version: 2.1.4_rc7)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/digitemp/ChangeLog8
-rw-r--r--app-misc/digitemp/digitemp-3.5.0.ebuild68
-rw-r--r--app-misc/digitemp/files/digest-digitemp-3.5.03
-rw-r--r--app-misc/digitemp/metadata.xml20
4 files changed, 93 insertions, 6 deletions
diff --git a/app-misc/digitemp/ChangeLog b/app-misc/digitemp/ChangeLog
index 79ee4a575ab1..95a8d4ea4624 100644
--- a/app-misc/digitemp/ChangeLog
+++ b/app-misc/digitemp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/digitemp
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/digitemp/ChangeLog,v 1.13 2007/04/12 20:42:47 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/digitemp/ChangeLog,v 1.14 2007/12/07 11:03:41 wschlich Exp $
+
+*digitemp-3.5.0 (07 Dec 2007)
+
+ 07 Dec 2007; Wolfram Schlich <wschlich@gentoo.org> metadata.xml,
+ +digitemp-3.5.0.ebuild:
+ added myself as maintainer to metadata.xml, version bump
12 Apr 2007; Christian Faulhammer <opfer@gentoo.org>
digitemp-3.3.2.ebuild:
diff --git a/app-misc/digitemp/digitemp-3.5.0.ebuild b/app-misc/digitemp/digitemp-3.5.0.ebuild
new file mode 100644
index 000000000000..171b471716bb
--- /dev/null
+++ b/app-misc/digitemp/digitemp-3.5.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/digitemp/digitemp-3.5.0.ebuild,v 1.1 2007/12/07 11:03:41 wschlich Exp $
+
+DESCRIPTION="Temperature logging and reporting using Dallas Semiconductor's iButtons and 1-Wire protocol"
+HOMEPAGE="http://www.digitemp.com/ http://www.ibutton.com/"
+SRC_URI="http://www.digitemp.com/software/linux/${P}.tar.gz"
+
+IUSE="ds9097 ds9097u ds2490"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="ds2490? ( >=dev-libs/libusb-0.1.10a )"
+
+targets() {
+ # default is to compile to the ds9097u.
+ if ! ( use ds9097 || use ds9097u || use ds2490 ); then
+ echo ds9097u
+ fi
+ for target in ds9097 ds9097u ds2490; do
+ if use ${target}; then
+ echo ${target}
+ fi
+ done
+}
+
+src_compile() {
+ # default is to compile to the ds9097u.
+ if ! ( use ds9097 || use ds9097u || use ds2490 ); then
+ ewarn "If you don't choose a component to install, we default to ds9097u"
+ fi
+
+ local targets=$(targets)
+
+ for target in $targets; do
+ emake clean
+ emake LOCK="no" ${target} || die "emake ${target} failed"
+ done
+}
+
+src_install() {
+ for target in $(echo $(targets) | tr '[:lower:]' '[:upper:]'); do
+ dobin digitemp_${target} && \
+ dosym digitemp_${target} /usr/bin/digitemp
+ done
+
+ if [[ $($(targets)|wc -l) -ge 1 ]]; then
+ echo
+ ewarn "/usr/bin/digitemp has been symlinked to /usr/bin/digitemp_${target}"
+ ewarn "If you want to access the others, they are available at /usr/bin/digitemp_*"
+ echo
+ fi
+
+ dodoc README FAQ TODO
+
+ for example in perl python rrdb; do
+ insinto "/usr/share/doc/${PF}/${example}_examples"
+ doins ${example}/*
+ done
+}
+
+pkg_postinst() {
+ echo
+ elog "Examples of using digitemp with python, perl, and rrdtool are"
+ elog "located in /usr/share/doc/${PF}/"
+ echo
+}
diff --git a/app-misc/digitemp/files/digest-digitemp-3.5.0 b/app-misc/digitemp/files/digest-digitemp-3.5.0
new file mode 100644
index 000000000000..c048df24356d
--- /dev/null
+++ b/app-misc/digitemp/files/digest-digitemp-3.5.0
@@ -0,0 +1,3 @@
+MD5 72bda9c8a66b017aa969c19dedb3225b digitemp-3.5.0.tar.gz 267947
+RMD160 12270200a1820690160a8281f3e95e0e2683f9dc digitemp-3.5.0.tar.gz 267947
+SHA256 e185ef9b84501b28568160eb5a5cc3b98b72c0791aff9c128ff6d0cd23b711e8 digitemp-3.5.0.tar.gz 267947
diff --git a/app-misc/digitemp/metadata.xml b/app-misc/digitemp/metadata.xml
index b17012b02b48..1c40eb36c5eb 100644
--- a/app-misc/digitemp/metadata.xml
+++ b/app-misc/digitemp/metadata.xml
@@ -1,9 +1,19 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>no-herd</herd>
- <maintainer>
- <email>maintainer-needed@gentoo.org</email>
- <description>This package lacks a primary herd or maintainer.</description>
- </maintainer>
+<herd>no-herd</herd>
+<maintainer>
+ <email>wschlich@gentoo.org</email>
+ <name>Wolfram Schlich</name>
+ <description>Primary maintainer</description>
+</maintainer>
+<longdescription>
+DigiTemp is a simple to use program for reading values from 1-wire devices. Its
+main use is for reading temperature sensors, but it also reads counters, and
+understands the 1-wire hubs with devices on different branches of the network.
+DigiTemp now supports the following 1-wire temperature sensors: DS18S20 (and
+DS1820), DS18B20, DS1822, the DS2438 Smart Battery Monitor, DS2422 and DS2423
+Counters, DS2409 MicroLAN Coupler (used in 1-wire hubs), and the AAG TAI-8540
+humidity sensor.
+</longdescription>
</pkgmetadata>