summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-01-14 07:21:58 +0000
committerJustin Lecher <jlec@gentoo.org>2013-01-14 07:21:58 +0000
commitd0f1ec9408841297d3af8e4c0d0feb4e83798c92 (patch)
tree2111fb06d0a2121b3bf19ab918f1dc9a5acc087b /app-misc
parentSecurity bump. #451206 (diff)
downloadgentoo-2-d0f1ec9408841297d3af8e4c0d0feb4e83798c92.tar.gz
gentoo-2-d0f1ec9408841297d3af8e4c0d0feb4e83798c92.tar.bz2
gentoo-2-d0f1ec9408841297d3af8e4c0d0feb4e83798c92.zip
app-misc/boxes: Version Bump, moved to EAPI=5, #451866
(Portage version: 2.2.0_alpha150/cvs/Linux x86_64, signed Manifest commit with key 70EB7916)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/boxes/ChangeLog10
-rw-r--r--app-misc/boxes/boxes-1.1.1.ebuild32
-rw-r--r--app-misc/boxes/files/boxes-1.1.1-Makefile.patch62
-rw-r--r--app-misc/boxes/metadata.xml2
4 files changed, 103 insertions, 3 deletions
diff --git a/app-misc/boxes/ChangeLog b/app-misc/boxes/ChangeLog
index 330223d6dabf..e286cc941d14 100644
--- a/app-misc/boxes/ChangeLog
+++ b/app-misc/boxes/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/boxes
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/boxes/ChangeLog,v 1.29 2011/03/27 21:35:40 darkside Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/boxes/ChangeLog,v 1.30 2013/01/14 07:21:57 jlec Exp $
+
+*boxes-1.1.1 (14 Jan 2013)
+
+ 14 Jan 2013; Justin Lecher <jlec@gentoo.org> +boxes-1.1.1.ebuild,
+ +files/boxes-1.1.1-Makefile.patch, metadata.xml:
+ Version Bump, moved to EAPI=5, #451866
27 Mar 2011; Jeremy Olexa <darkside@gentoo.org> -boxes-1.1.ebuild:
remove old ebuilds
diff --git a/app-misc/boxes/boxes-1.1.1.ebuild b/app-misc/boxes/boxes-1.1.1.ebuild
new file mode 100644
index 000000000000..ed7c3806fd45
--- /dev/null
+++ b/app-misc/boxes/boxes-1.1.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/boxes/boxes-1.1.1.ebuild,v 1.1 2013/01/14 07:21:57 jlec Exp $
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Draw any kind of boxes around your text"
+HOMEPAGE="http://boxes.thomasjensen.com/"
+SRC_URI="http://boxes.thomasjensen.com/download/${P}.src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-Makefile.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin src/boxes
+ doman doc/boxes.1
+ dodoc README
+ insinto /usr/share/boxes
+ doins boxes-config
+}
diff --git a/app-misc/boxes/files/boxes-1.1.1-Makefile.patch b/app-misc/boxes/files/boxes-1.1.1-Makefile.patch
new file mode 100644
index 000000000000..1cdaffa35965
--- /dev/null
+++ b/app-misc/boxes/files/boxes-1.1.1-Makefile.patch
@@ -0,0 +1,62 @@
+ Makefile | 2 +-
+ src/Makefile | 8 +++-----
+ src/regexp/Makefile | 2 +-
+ 3 files changed, 5 insertions(+), 7 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 4bfd625..2c75625 100644
+--- a/Makefile
++++ b/Makefile
+@@ -80,7 +80,7 @@
+
+
+ # The following line (GLOBALCONF) is the only line you should need to edit!
+-GLOBALCONF = /usr/share/boxes
++GLOBALCONF = /usr/share/boxes/boxes-config
+ BVERSION = 1.1.1
+
+ SNAPFILE = boxes-SNAP-$(shell date +%Y%m%d)
+diff --git a/src/Makefile b/src/Makefile
+index 7cfab9f..9ed467b 100644
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -86,8 +86,7 @@
+ LEX = flex
+ YACC = bison
+ CC = gcc
+-CFLAGS = -ansi -I. -Iregexp -Wall -W $(CFLAGS_ADDTL)
+-LDFLAGS = -Lregexp
++CFLAGS += -ansi -I. -Iregexp $(CFLAGS_ADDTL)
+
+ GEN_HDR = parser.h
+ GEN_SRC = parser.c lex.yy.c
+@@ -106,14 +105,13 @@ ALL_OBJ = $(GEN_SRC:.c=.o) $(ORIG_NORM:.c=.o)
+
+
+ build:
+- $(MAKE) CFLAGS_ADDTL=-O boxes
+- strip boxes
++ $(MAKE) boxes
+ debug:
+ $(MAKE) CFLAGS_ADDTL=-g boxes
+
+ boxes: $(ALL_OBJ)
+ $(MAKE) -C regexp CC=$(CC) libregexp.a
+- $(CC) $(LDFLAGS) $(ALL_OBJ) -o boxes -lregexp
++ $(CC) $(LDFLAGS) $(ALL_OBJ) -o boxes -Lregexp -lregexp
+
+ boxes.h:
+ @echo File boxes.h not found or not current. Please run make in the parent directory.
+diff --git a/src/regexp/Makefile b/src/regexp/Makefile
+index 0bd0ace..53966c9 100644
+--- a/src/regexp/Makefile
++++ b/src/regexp/Makefile
+@@ -42,7 +42,7 @@
+ #============================================================================
+
+
+-CFLAGS = -O -I. $(CFLAGS_ADDTL)
++CFLAGS += -I. $(CFLAGS_ADDTL)
+
+ ALL_CL = regexp/regexp.c regexp/regsub.c
+ C_SRC = $(notdir $(ALL_CL))
diff --git a/app-misc/boxes/metadata.xml b/app-misc/boxes/metadata.xml
index 40149c995561..f23b9cae1593 100644
--- a/app-misc/boxes/metadata.xml
+++ b/app-misc/boxes/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>shell-tools</herd>
+ <herd>shell-tools</herd>
</pkgmetadata>