summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTod Neidt <tod@gentoo.org>2002-04-05 22:11:22 +0000
committerTod Neidt <tod@gentoo.org>2002-04-05 22:11:22 +0000
commitd645c6fa37e11d343165b7f6741a27baecfdac27 (patch)
tree732f1b541e18a53524403bc01917121694de72ec /app-misc
parentVersion bump (diff)
downloadgentoo-2-d645c6fa37e11d343165b7f6741a27baecfdac27.tar.gz
gentoo-2-d645c6fa37e11d343165b7f6741a27baecfdac27.tar.bz2
gentoo-2-d645c6fa37e11d343165b7f6741a27baecfdac27.zip
Initial commit. User request. Want some spice with that :)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/xcircuit/ChangeLog9
-rw-r--r--app-misc/xcircuit/files/digest-xcircuit-2.5.41
-rw-r--r--app-misc/xcircuit/xcircuit-2.5.4.ebuild36
3 files changed, 46 insertions, 0 deletions
diff --git a/app-misc/xcircuit/ChangeLog b/app-misc/xcircuit/ChangeLog
new file mode 100644
index 000000000000..0a7c4ef9beb6
--- /dev/null
+++ b/app-misc/xcircuit/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for <CATEGORY>/<PACKAGE_NAME>
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/app-misc/xcircuit/ChangeLog,v 1.1 2002/04/05 22:11:22 tod Exp $
+
+*xcircuit-2.5.4 (5 Apr 2003)
+
+ 5 Apr 2002; Tod Neidt <tod@gentoo.org> xcircuit-2.5.4.ebuild, Changelog :
+
+ Initial commit. User request.
diff --git a/app-misc/xcircuit/files/digest-xcircuit-2.5.4 b/app-misc/xcircuit/files/digest-xcircuit-2.5.4
new file mode 100644
index 000000000000..d9a7e983712a
--- /dev/null
+++ b/app-misc/xcircuit/files/digest-xcircuit-2.5.4
@@ -0,0 +1 @@
+MD5 86710040906ca4120c399efd93ee0346 xcircuit-2.5.4.tar.bz2 510752
diff --git a/app-misc/xcircuit/xcircuit-2.5.4.ebuild b/app-misc/xcircuit/xcircuit-2.5.4.ebuild
new file mode 100644
index 000000000000..5d1a6d8c7f23
--- /dev/null
+++ b/app-misc/xcircuit/xcircuit-2.5.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: First Last <your email>
+# $Header: /var/cvsroot/gentoo-x86/app-misc/xcircuit/xcircuit-2.5.4.ebuild,v 1.1 2002/04/05 22:11:22 tod Exp $
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="Circuit drawing and schematic capture program."
+
+SRC_URI="http://bach.ece.jhu.edu/~tim/programs/xcircuit/archive/${P}.tar.bz2"
+
+HOMEPAGE="http://bach.ece.jhu.edu/~tim/programs/xcircuit/xcircuit.html"
+
+DEPEND="virtual/x11
+ devel-lang/python
+ app-text/ghostscipt"
+
+src_compile() {
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man || die "./configure failed"
+
+ #Parallel make bombs on parameter.c looking for menudep.h
+ make || die
+
+}
+
+src_install () {
+
+ make DESTDIR=${D} install || die "Installation failed"
+
+ dodoc COPYRIGHT README*
+
+}