summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2008-02-13 15:03:55 +0000
committerAlin Năstac <mrness@gentoo.org>2008-02-13 15:03:55 +0000
commitf4be1aa9fd4957b21a379f4a22fd78054f2ee189 (patch)
tree6d0ebbd1d85a2ed0215c4f08011fd45b661d4b80 /app-mobilephone/gammu
parentFixed QA issues and added bindist for >=gsl-1.10 (see bug #199451). (diff)
downloadgentoo-2-f4be1aa9fd4957b21a379f4a22fd78054f2ee189.tar.gz
gentoo-2-f4be1aa9fd4957b21a379f4a22fd78054f2ee189.tar.bz2
gentoo-2-f4be1aa9fd4957b21a379f4a22fd78054f2ee189.zip
Version bump (#209441).
(Portage version: 2.1.3.19)
Diffstat (limited to 'app-mobilephone/gammu')
-rw-r--r--app-mobilephone/gammu/ChangeLog9
-rw-r--r--app-mobilephone/gammu/gammu-1.18.0.ebuild55
2 files changed, 62 insertions, 2 deletions
diff --git a/app-mobilephone/gammu/ChangeLog b/app-mobilephone/gammu/ChangeLog
index b77702cc52db..3e3c4834c5d3 100644
--- a/app-mobilephone/gammu/ChangeLog
+++ b/app-mobilephone/gammu/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-mobilephone/gammu
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/gammu/ChangeLog,v 1.48 2007/12/20 06:35:48 mrness Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/gammu/ChangeLog,v 1.49 2008/02/13 15:03:55 mrness Exp $
+
+*gammu-1.18.0 (13 Feb 2008)
+
+ 13 Feb 2008; Alin Năstac <mrness@gentoo.org> +gammu-1.18.0.ebuild:
+ Version bump (#209441).
*gammu-1.17.0 (20 Dec 2007)
diff --git a/app-mobilephone/gammu/gammu-1.18.0.ebuild b/app-mobilephone/gammu/gammu-1.18.0.ebuild
new file mode 100644
index 000000000000..7ef3f872ea63
--- /dev/null
+++ b/app-mobilephone/gammu/gammu-1.18.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/gammu/gammu-1.18.0.ebuild,v 1.1 2008/02/13 15:03:55 mrness Exp $
+
+inherit cmake-utils
+
+DESCRIPTION="a fork of the gnokii project, a tool to handle your cellular phone"
+HOMEPAGE="http://www.gammu.org"
+SRC_URI="ftp://dl.cihar.com/gammu/releases/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug bluetooth irda mysql postgres nls"
+
+RDEPEND="bluetooth? ( net-wireless/bluez-libs )
+ mysql? ( virtual/mysql )
+ postgres? ( dev-db/postgresql )
+ dev-util/dialog"
+DEPEND="${RDEPEND}
+ irda? ( virtual/os-headers )
+ nls? ( sys-devel/gettext )
+ dev-util/cmake"
+
+# Supported languages and translated documentation
+# Be sure all languages are prefixed with a single space!
+MY_AVAILABLE_LINGUAS=" cs de es it pl ru"
+IUSE="${IUSE} ${MY_AVAILABLE_LINGUAS// / linguas_}"
+
+src_unpack() {
+ unpack ${A}
+
+ # sys-devel/gettext is needed for creating .mo files
+ cd "${S}/locale"
+ local lang
+ for lang in ${MY_AVAILABLE_LINGUAS} ; do
+ if ! use linguas_${lang} ; then
+ sed -i -e "/^[[:space:]]*${lang}[[:space:]]*$/d" CMakeLists.txt
+ fi
+ done
+}
+
+src_compile() {
+ # debug flag is used inside cmake-utils.eclass
+ local mycmakeargs="$(cmake-utils_use_with bluetooth Bluez) \
+ $(cmake-utils_use_with irda IrDA) \
+ $(cmake-utils_use_with mysql MySQL) \
+ $(cmake-utils_use_with postgres Postgres) \
+ -DENABLE_SHARED=ON"
+ cmake-utils_src_compile
+}
+
+src_test() {
+ LD_LIBRARY_PATH="${WORKDIR}"/${PN}_build/common cmake-utils_src_test
+}