summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2011-02-21 18:49:56 +0000
committerPacho Ramos <pacho@gentoo.org>2011-02-21 18:49:56 +0000
commit016fa97b6caa35a36645d711a28306334d2fd6f4 (patch)
treeabae86356cdc3aaa3799bcc7ea4d360154847381 /app-mobilephone
parentStable on amd64 wrt bug #355449 (diff)
downloadgentoo-2-016fa97b6caa35a36645d711a28306334d2fd6f4.tar.gz
gentoo-2-016fa97b6caa35a36645d711a28306334d2fd6f4.tar.bz2
gentoo-2-016fa97b6caa35a36645d711a28306334d2fd6f4.zip
Version bump: Add a gnome-bluetooth plugin to configure new paired phones (behind 'gnome' USE flag), fix automatic phone reconnection, migrate from libglade to GtkBuilder, translation updates.
(Portage version: 2.1.9.40/cvs/Linux x86_64)
Diffstat (limited to 'app-mobilephone')
-rw-r--r--app-mobilephone/gnome-phone-manager/ChangeLog11
-rw-r--r--app-mobilephone/gnome-phone-manager/gnome-phone-manager-0.66.ebuild44
2 files changed, 53 insertions, 2 deletions
diff --git a/app-mobilephone/gnome-phone-manager/ChangeLog b/app-mobilephone/gnome-phone-manager/ChangeLog
index b701ec26c156..8850fcf819ea 100644
--- a/app-mobilephone/gnome-phone-manager/ChangeLog
+++ b/app-mobilephone/gnome-phone-manager/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-mobilephone/gnome-phone-manager
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/gnome-phone-manager/ChangeLog,v 1.36 2010/11/25 11:12:33 eva Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/gnome-phone-manager/ChangeLog,v 1.37 2011/02/21 18:49:56 pacho Exp $
+
+*gnome-phone-manager-0.66 (21 Feb 2011)
+
+ 21 Feb 2011; Pacho Ramos <pacho@gentoo.org> +gnome-phone-manager-0.66.ebuild:
+ Version bump: Add a gnome-bluetooth plugin to configure new paired phones
+ (behind 'gnome' USE flag), fix automatic phone reconnection, migrate from
+ libglade to GtkBuilder, translation updates.
25 Nov 2010; Gilles Dartiguelongue <eva@gentoo.org>
-gnome-phone-manager-0.60.ebuild:
diff --git a/app-mobilephone/gnome-phone-manager/gnome-phone-manager-0.66.ebuild b/app-mobilephone/gnome-phone-manager/gnome-phone-manager-0.66.ebuild
new file mode 100644
index 000000000000..2ac3ddf9e1e0
--- /dev/null
+++ b/app-mobilephone/gnome-phone-manager/gnome-phone-manager-0.66.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/gnome-phone-manager/gnome-phone-manager-0.66.ebuild,v 1.1 2011/02/21 18:49:56 pacho Exp $
+
+EAPI="3"
+GCONF_DEBUG="yes"
+
+inherit gnome2
+
+DESCRIPTION="A program created to allow you to control aspects of your mobile phone from your GNOME 2 desktop"
+HOMEPAGE="http://live.gnome.org/PhoneManager"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="gnome"
+# telepathy support is considered experimental
+
+RDEPEND=">=dev-libs/glib-2.25.0:2
+ >=x11-libs/gtk+-2.18:2
+ >=gnome-base/orbit-2
+ >=gnome-base/gconf-2
+ >=gnome-extra/evolution-data-server-1.2.3
+ media-libs/libcanberra[gtk]
+ >=app-mobilephone/gnokii-0.6.28[bluetooth]
+ net-wireless/bluez
+ dev-libs/dbus-glib
+ dev-libs/openobex
+ media-libs/libcanberra[gtk]
+ >=x11-themes/gnome-icon-theme-2.19.1
+ >=app-text/gtkspell-2
+ gnome? ( >=net-wireless/gnome-bluetooth-2.27.6:2 )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.35.5
+ dev-util/pkgconfig"
+# gnome-common needed for eautoreconf
+
+pkg_setup() {
+ DOCS="README NEWS AUTHORS ChangeLog"
+ G2CONF="${G2CONF}
+ $(use_enable gnome bluetooth-plugin)
+ --disable-telepathy"
+}