summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2008-11-02 12:53:27 +0000
committerAlin Năstac <mrness@gentoo.org>2008-11-02 12:53:27 +0000
commitc06a4d964bb9ec5db2ab1bd0f1d8c26d19f8288e (patch)
treeb00ba0c8c7f1834743644392395767eba15ddfad /app-mobilephone
parentVersion bump. (diff)
downloadgentoo-2-c06a4d964bb9ec5db2ab1bd0f1d8c26d19f8288e.tar.gz
gentoo-2-c06a4d964bb9ec5db2ab1bd0f1d8c26d19f8288e.tar.bz2
gentoo-2-c06a4d964bb9ec5db2ab1bd0f1d8c26d19f8288e.zip
Version bump.
(Portage version: 2.1.4.4)
Diffstat (limited to 'app-mobilephone')
-rw-r--r--app-mobilephone/wammu/ChangeLog7
-rw-r--r--app-mobilephone/wammu/wammu-0.29.ebuild62
2 files changed, 68 insertions, 1 deletions
diff --git a/app-mobilephone/wammu/ChangeLog b/app-mobilephone/wammu/ChangeLog
index bc75e4dd372e..76e2919b506f 100644
--- a/app-mobilephone/wammu/ChangeLog
+++ b/app-mobilephone/wammu/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-mobilephone/wammu
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/wammu/ChangeLog,v 1.32 2008/08/19 19:24:47 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/wammu/ChangeLog,v 1.33 2008/11/02 12:53:27 mrness Exp $
+
+*wammu-0.29 (02 Nov 2008)
+
+ 02 Nov 2008; Alin Năstac <mrness@gentoo.org> +wammu-0.29.ebuild:
+ Version bump.
*wammu-0.28 (19 Aug 2008)
diff --git a/app-mobilephone/wammu/wammu-0.29.ebuild b/app-mobilephone/wammu/wammu-0.29.ebuild
new file mode 100644
index 000000000000..d3272dd01569
--- /dev/null
+++ b/app-mobilephone/wammu/wammu-0.29.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/wammu/wammu-0.29.ebuild,v 1.1 2008/11/02 12:53:27 mrness Exp $
+
+inherit distutils
+
+DESCRIPTION="front-end for gammu (Nokia and other mobiles)"
+HOMEPAGE="http://www.cihar.com/gammu/wammu/"
+SRC_URI="http://dl.cihar.com/wammu/v0/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="bluetooth"
+
+RDEPEND=">=dev-python/wxpython-2.8
+ >=dev-python/python-gammu-0.24
+ bluetooth? (
+ || (
+ dev-python/pybluez
+ net-wireless/gnome-bluetooth
+ )
+ )"
+DEPEND="${RDEPEND}"
+
+# Supported languages and translated documentation
+# Be sure all languages are prefixed with a single space!
+MY_AVAILABLE_LINGUAS=" af ca cs de es et fi fr gl he hu it ko nl pl pt_BR ru sk sv zh_CN zh_TW"
+IUSE="${IUSE} ${MY_AVAILABLE_LINGUAS// / linguas_}"
+
+src_unpack() {
+ unpack ${A}
+
+ pushd "${S}"/locale || die "locale directory not found"
+ local lang support_linguas=no
+ for lang in ${MY_AVAILABLE_LINGUAS} ; do
+ if use linguas_${lang} ; then
+ support_linguas=yes
+ break
+ fi
+ done
+ # install all languages when all selected LINGUAS aren't supported
+ if [ "${support_linguas}" = "yes" ]; then
+ for lang in ${MY_AVAILABLE_LINGUAS} ; do
+ if ! use linguas_${lang} ; then
+ rm -r ${lang}
+ fi
+ done
+ fi
+ popd
+}
+
+src_compile() {
+ # SKIPWXCHECK: else 'import wx' results in
+ # Xlib: connection to ":0.0" refused by server
+ SKIPWXCHECK=yes distutils_src_compile
+}
+
+src_install() {
+ DOCS="AUTHORS FAQ NEWS"
+ SKIPWXCHECK=yes distutils_src_install
+}