summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorD.M.D. Ljungmark <spider@gentoo.org>2002-04-12 21:29:27 +0000
committerD.M.D. Ljungmark <spider@gentoo.org>2002-04-12 21:29:27 +0000
commiteca512798925991a3e60d836686e465091ebf34f (patch)
tree7cbb6a5460553f992e2bbbdc9ce326ab7f831d95 /app-office/abiword
parentAdd the libpng change (diff)
downloadgentoo-2-eca512798925991a3e60d836686e465091ebf34f.tar.gz
gentoo-2-eca512798925991a3e60d836686e465091ebf34f.tar.bz2
gentoo-2-eca512798925991a3e60d836686e465091ebf34f.zip
forcing rebuild with libpng update
Diffstat (limited to 'app-office/abiword')
-rw-r--r--app-office/abiword/ChangeLog6
-rw-r--r--app-office/abiword/abiword-0.99.3-r1.ebuild159
-rw-r--r--app-office/abiword/files/digest-abiword-0.99.3-r11
3 files changed, 165 insertions, 1 deletions
diff --git a/app-office/abiword/ChangeLog b/app-office/abiword/ChangeLog
index 644880656b1a..f5ed0d2a22b5 100644
--- a/app-office/abiword/ChangeLog
+++ b/app-office/abiword/ChangeLog
@@ -1,7 +1,11 @@
# ChangeLog for app-office/abiword
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/ChangeLog,v 1.4 2002/04/04 16:14:08 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/ChangeLog,v 1.5 2002/04/12 21:29:27 spider Exp $
+*abiword-0.99.3-r1 (12 Apr 2002)
+ 12 Apr 2002; Spider <spider@gentoo.org>
+ force recompile with new -r due to libpng changes
+
3 Apr 2002; M.Schlemmer <azarah@gentoo.org> abiword-0.99.3.ebuild :
Fix DEPEND for 'spell' USE var.
diff --git a/app-office/abiword/abiword-0.99.3-r1.ebuild b/app-office/abiword/abiword-0.99.3-r1.ebuild
new file mode 100644
index 000000000000..babac9c8f357
--- /dev/null
+++ b/app-office/abiword/abiword-0.99.3-r1.ebuild
@@ -0,0 +1,159 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Karl Trygve Kalleberg <karltk@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/abiword-0.99.3-r1.ebuild,v 1.1 2002/04/12 21:29:27 spider Exp $
+
+S=${WORKDIR}/${P}/abi
+DESCRIPTION="Text processor"
+SRC_URI="http://download.sourceforge.net/abiword/abiword-${PV}.tar.gz"
+HOMEPAGE="http://www.abisource.com"
+SLOT="0"
+DEPEND="virtual/glibc
+ >=sys-devel/gcc-2.95.2
+ =media-libs/freetype-1.3.1-r3
+ >=media-libs/libpng-1.2.1
+ >=media-libs/jpeg-6b-r2
+ >=x11-libs/gtk+-1.2.10-r4
+ gnome? ( >=gnome-base/gnome-libs-1.4.1.2-r1
+ >=dev-libs/libunicode-0.4-r1
+ >=gnome-base/bonobo-1.0.9-r1
+ >=gnome-extra/gal-0.13-r1 )
+ >=sys-devel/automake-1.5d-r1
+ perl? ( >=sys-devel/perl-5.6 )
+ spell? ( >=app-text/pspell-ispell-0.12-r1 )
+ xml2? ( >=dev-libs/libxml2-2.4.10 )
+ virtual/x11"
+
+
+fix_perl_env() {
+ # new configure scripts is a bit broken
+ export PERL_ARCHLIB="`(perl -V:installarchlib | sed -e "s/\(.*=\|'\|;\)//g\")`"
+ export PERL_LIB="`(perl -V:installprivlib | sed -e "s/\(.*=\|'\|;\)//g\")`"
+ export POD2MAN_EXE="`which pod2man`"
+ export SITE_LIB="`(perl -V:sitelib | sed -e "s/\(.*=\|'\|;\)//g\")`"
+ export SITE_ARCHLIB="`(perl -V:sitearch | sed -e "s/\(.*=\|'\|;\)//g\")`"
+}
+
+src_unpack() {
+
+ unpack ${A}
+
+ if [ "`use perl`" ] ; then
+ fix_perl_env
+
+ # Fix perl stuff install outside sandbox, as well as a bug in
+ # Abiword's build system (Abiword.3pm did not install, and
+ # the '.packlist' was not generated properly) -- Azarah (25/02/2002).
+ cd ${S}/src/bindings/perl
+ cp GNUmakefile.am GNUmakefile.am.orig
+ sed -e "s:PERL_ARCHLIB = @PERL_ARCHLIB@:PERL_ARCHLIB = ${PERL_ARCHLIB}:" \
+ -e "s:PERL_LIB = @PERL_LIB@:PERL_LIB = ${PERL_LIB}:" \
+ -e "s:POD2MAN_EXE = @POD2MAN_EXE@:POD2MAN_EXE = ${POD2MAN_EXE}:" \
+ -e "s:SITE_LIB = @SITE_LIB@:SITE_LIB = ${SITE_LIB}:" \
+ -e "s:SITE_ARCHLIB = @SITE_ARCHLIB@:SITE_ARCHLIB = ${SITE_ARCHLIB}:" \
+ -e 's:write $(SITE_ARCHLIB)/auto:write $(PERLDEST)/$(SITE_ARCHLIB)/auto:g' \
+ -e 's:blib/lib $(SITE_LIB):blib/lib $(PERLDEST)/$(SITE_LIB):g' \
+ -e 's:blib/arch $(SITE_ARCHLIB):blib/arch $(PERLDEST)/$(SITE_ARCHLIB):g' \
+ -e 's:blib/bin /usr/bin:blib/bin $(PERLDEST)/usr/bin:g' \
+ -e 's:blib/script /usr/bin:blib/script $(PERLDEST)/usr/bin:g' \
+ -e 's:blib/man1 /usr/share/man/man1:blib/man1 $(PERLDEST)/usr/share/man/man1:g' \
+ -e 's:blib/man3 /usr/share/man/man3:blib/man3 $(PERLDEST)/usr/share/man/man3:g' \
+ -e 's:mkpath $(PERL_ARCHLIB):mkpath $(PERLDEST)/$(PERL_ARCHLIB):g' \
+ -e 's:$(PERL_ARCHLIB)/perllocal.pod:$(PERLDEST)/$(PERL_ARCHLIB)/perllocal.pod.new:' \
+ GNUmakefile.am.orig >GNUmakefile.am || die
+ mkdir -p blib/{arch,bin,lib,man1,man3,script}
+ cd ${S}
+ fi
+
+ # clear invalid symlinks
+ rm -f ac-helpers/{install-sh,mkinstalldirs,missing}
+}
+
+src_compile() {
+
+ local myconf
+ if [ "`use gnome`" ] ; then
+ myconf="${myconf} --with-gnome --enable-gnome"
+ export ABI_OPT_BONOBO=1
+ fi
+
+ if [ "`use perl`" ] ; then
+ myconf="${myconf} --enable-scripting"
+ fi
+
+ if [ "`use spell`" ] ; then
+ myconf="${myconf} --with-pspell"
+ fi
+
+ if [ "`use xml2`" ] ; then
+ myconf="${myconf} --with-libxml2"
+ fi
+
+ ./autogen.sh
+
+ echo
+ echo "*************************************************"
+ echo "* Ignore above ERROR as it does not cause build *"
+ echo "* to fail. *"
+ echo "*************************************************"
+ echo
+
+ CFLAGS="$CFLAGS `gdk-pixbuf-config --cflags`"
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ --with-libjpeg \
+ --enable-extra-optimization \
+ ${myconf} || die
+
+ # Doesn't work with -j 4 (hallski)
+ make UNIX_CAN_BUILD_STATIC=0 \
+ OPTIMIZER="${CFLAGS}" || die
+}
+
+src_install() {
+
+ dodir /usr/{bin,lib}
+
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ sysconfdir=${D}/etc \
+ localstatedir=${D}/var/lib \
+ PERLDEST=${D} \
+ install || die
+
+ dosed "s:${D}::g" /usr/bin/AbiWord
+
+ rm -f ${D}/usr/bin/abiword
+ dosym /usr/bin/AbiWord /usr/bin/abiword
+
+ dodoc BUILD COPYING *.txt, *.TXT
+
+ # Install icon and .desktop for menu entry
+ if [ "`use gnome`" ] ; then
+ insinto /usr/share/pixmaps
+ newins ${WORKDIR}/${P}/abidistfiles/icons/abiword_48.png AbiWord.png
+ insinto /usr/share/gnome/apps/Applications
+ doins ${FILESDIR}/AbiWord.desktop
+ fi
+}
+
+pkg_postinst() {
+
+ # Appending installation info
+ local perlver="`perl -v | grep -e "This is perl" | cut -d ' ' -f 4`"
+ perlver=${perlver/v/}
+ local perlarch="`perl -V | grep -e " archname" | cut -d '=' -f 4`"
+ if [ -f /usr/lib/perl5/${perlver}/${perlarch}/perllocal.pod.new ] ; then
+ sed -e "s:5.6.0:${perlver}:g" \
+ /usr/lib/perl5/${perlver}/${perlarch}/perllocal.pod.new \
+ >> /usr/lib/perl5/${perlver}/${perlarch}/perllocal.pod
+ rm -rf /usr/lib/perl5/${perlver}/${perlarch}/perllocal.pod.new
+ fi
+}
+
diff --git a/app-office/abiword/files/digest-abiword-0.99.3-r1 b/app-office/abiword/files/digest-abiword-0.99.3-r1
new file mode 100644
index 000000000000..a95c13d33659
--- /dev/null
+++ b/app-office/abiword/files/digest-abiword-0.99.3-r1
@@ -0,0 +1 @@
+MD5 d1a5ddf262525f5c4db929201f1eb447 abiword-0.99.3.tar.gz 17988316