summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2011-05-08 20:54:59 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2011-05-08 20:54:59 +0000
commit36fe1ec4d7ce96a56d7fe83b886f0e2cf076d532 (patch)
treeff207a75624837cd809026d0c53577039a85c111 /app-office/akonadi-server
parentNarrow blocker (diff)
downloadgentoo-2-36fe1ec4d7ce96a56d7fe83b886f0e2cf076d532.tar.gz
gentoo-2-36fe1ec4d7ce96a56d7fe83b886f0e2cf076d532.tar.bz2
gentoo-2-36fe1ec4d7ce96a56d7fe83b886f0e2cf076d532.zip
Re-add because it is in the stabilization list
(Portage version: 2.1.9.46/cvs/Linux x86_64)
Diffstat (limited to 'app-office/akonadi-server')
-rw-r--r--app-office/akonadi-server/ChangeLog6
-rw-r--r--app-office/akonadi-server/akonadi-server-1.5.2.ebuild96
2 files changed, 101 insertions, 1 deletions
diff --git a/app-office/akonadi-server/ChangeLog b/app-office/akonadi-server/ChangeLog
index acb40334bf2b..eb33c26f5365 100644
--- a/app-office/akonadi-server/ChangeLog
+++ b/app-office/akonadi-server/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-office/akonadi-server
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/akonadi-server/ChangeLog,v 1.52 2011/05/07 10:19:30 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/akonadi-server/ChangeLog,v 1.53 2011/05/08 20:54:59 dilfridge Exp $
+
+ 08 May 2011; Andreas K. Huettel <dilfridge@gentoo.org>
+ +akonadi-server-1.5.2.ebuild:
+ Re-add because it is in the stabilization list
*akonadi-server-1.5.3 (07 May 2011)
diff --git a/app-office/akonadi-server/akonadi-server-1.5.2.ebuild b/app-office/akonadi-server/akonadi-server-1.5.2.ebuild
new file mode 100644
index 000000000000..831a96a5744e
--- /dev/null
+++ b/app-office/akonadi-server/akonadi-server-1.5.2.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/akonadi-server/akonadi-server-1.5.2.ebuild,v 1.3 2011/05/08 20:54:59 dilfridge Exp $
+
+EAPI=4
+
+inherit cmake-utils
+
+DESCRIPTION="The server part of Akonadi"
+HOMEPAGE="http://pim.kde.org/akonadi"
+SRC_URI="http://download.akonadi-project.org/${P/-server/}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+IUSE="mysql postgres +sqlite test"
+
+CDEPEND="
+ dev-libs/boost
+ >=dev-libs/soprano-2.2
+ >=x11-libs/qt-gui-4.5.0:4[dbus]
+ >=x11-libs/qt-sql-4.5.0:4[mysql?,postgres?]
+ >=x11-libs/qt-test-4.5.0:4
+ x11-misc/shared-mime-info
+"
+DEPEND="${CDEPEND}
+ dev-libs/libxslt
+ >=dev-util/automoc-0.9.88
+"
+RDEPEND="${CDEPEND}
+ postgres? ( dev-db/postgresql-server )
+"
+
+REQUIRED_USE="|| ( sqlite mysql postgres )"
+
+S=${WORKDIR}/${P/-server/}
+
+pkg_setup() {
+ # Set default storage backend in order: SQLite, MySQL, PostgreSQL
+ if use sqlite; then
+ DRIVER="QSQLITE3"
+ AVAILABLE+=" ${driver}"
+ elif use mysql; then
+ DRIVER="QMYSQL"
+ AVAILABLE+=" ${driver}"
+ elif use postgres; then
+ DRIVER="QPSQL"
+ AVAILABLE+=" ${driver}"
+ fi
+
+ # Notify about driver name change
+ if use sqlite && has_version "<=${CATEGORY}/${PN}-1.4.0[sqlite]"; then
+ ewarn
+ ewarn "SQLite driver name changed from QSQLITE to QSQLITE3."
+ ewarn "Please edit your ~/.config/akonadi/akonadiserverrc."
+ fi
+
+ # Notify about MySQL not being default anymore
+ if ! use mysql && has_version "<=${CATEGORY}/${PN}-1.4.0[mysql]"; then
+ ewarn
+ ewarn "MySQL driver is not enabled by default in Gentoo anymore."
+ ewarn "If you intend to use it, please enable mysql USE flag and reinstall"
+ ewarn "${CATEGORY}/${PN}."
+ ewarn "Otherwise select different driver in your ~/.config/akonadi/akonadiserverrc."
+ ewarn "Available drivers are:${AVAILABLE}"
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ "-DAKONADI_USE_STRIGI_SEARCH=OFF"
+ $(cmake-utils_use test AKONADI_BUILD_TESTS)
+ $(cmake-utils_use sqlite INSTALL_QSQLITE_IN_QT_PREFIX)
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ # Who knows, maybe it accidentally fixes our permission issues
+ cat <<-EOF > "${T}"/akonadiserverrc
+[%General]
+Driver=${DRIVER}
+EOF
+ insinto /usr/share/config/akonadi
+ doins "${T}"/akonadiserverrc || die "doins failed"
+
+ cmake-utils_src_install
+}
+
+pkg_postinst() {
+ echo
+ elog "${DRIVER} has been set as your default akonadi storage backend."
+ elog "You can override it in your ~/.config/akonadi/akonadiserverrc."
+ elog "Available drivers are: ${AVAILABLE}"
+}