summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn N. Laliberte <allanonjl@gentoo.org>2006-05-30 16:05:48 +0000
committerJohn N. Laliberte <allanonjl@gentoo.org>2006-05-30 16:05:48 +0000
commit6c725abbdcffb64f9f4a3fbdcc1261fea12a66d0 (patch)
treed8e92d370b9ff95a22023bf2b9bc4627951f248e /app-office/dia/dia-0.95.1.ebuild
parentStable on amd64 wrt bug #132887. (diff)
downloadgentoo-2-6c725abbdcffb64f9f4a3fbdcc1261fea12a66d0.tar.gz
gentoo-2-6c725abbdcffb64f9f4a3fbdcc1261fea12a66d0.tar.bz2
gentoo-2-6c725abbdcffb64f9f4a3fbdcc1261fea12a66d0.zip
new version. fixes #133699 and #130742. cleanup of ebuild.
(Portage version: 2.1_rc3-r2)
Diffstat (limited to 'app-office/dia/dia-0.95.1.ebuild')
-rw-r--r--app-office/dia/dia-0.95.1.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/app-office/dia/dia-0.95.1.ebuild b/app-office/dia/dia-0.95.1.ebuild
new file mode 100644
index 000000000000..f28b24081f27
--- /dev/null
+++ b/app-office/dia/dia-0.95.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/dia/dia-0.95.1.ebuild,v 1.1 2006/05/30 16:05:48 allanonjl Exp $
+
+inherit eutils gnome2 libtool autotools versionator
+
+DESCRIPTION="Diagram/flowchart creation program"
+HOMEPAGE="http://www.gnome.org/projects/dia/"
+LICENSE="GPL-2"
+
+# dia used -1 instead of .1 for the new version.
+MY_PV=$(replace_version_separator 2 '-' )
+MY_PV_MM=$(get_version_component_range 1-2 )
+MY_P="${PN}-${MY_PV}"
+SRC_URI="mirror://gnome/sources/${PN}/${MY_PV_MM}/${PN}-${MY_PV}.tar.bz2"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="gnome png python zlib"
+
+RDEPEND=">=x11-libs/gtk+-2.6.0
+ >=dev-libs/glib-2.6.0
+ >=x11-libs/pango-1.1.5
+ >=dev-libs/libxml2-2.3.9
+ >=dev-libs/libxslt-1
+ >=media-libs/freetype-2.0.95
+ dev-libs/popt
+ zlib? ( sys-libs/zlib )
+ png? ( media-libs/libpng
+ >=media-libs/libart_lgpl-2 )
+ gnome? ( >=gnome-base/libgnome-2.0
+ >=gnome-base/libgnomeui-2.0 )
+ python? ( >=dev-lang/python-1.5.2
+ >=dev-python/pygtk-1.99 )
+ ~app-text/docbook-xml-dtd-4.2
+ app-text/docbook-xsl-stylesheets"
+
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.21
+ dev-util/pkgconfig"
+
+G2CONF="${G2CONF} $(use_enable gnome) $(use_with python)"
+
+DOCS="AUTHORS ChangeLog COPYING KNOWN_BUGS MAINTAINERS NEWS README RELEASE-PROCESS THANKS TODO"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # Disable python -c 'import gtk' during compile to prevent using
+ # X being involved (#31589)
+ # changed the patch to a sed to make it a bit more portable - AllanonJL
+ sed -i -e '/AM_CHECK_PYMOD/d' configure.in
+
+ eautoreconf
+}