summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2004-08-19 22:31:59 +0000
committerMarinus Schraal <foser@gentoo.org>2004-08-19 22:31:59 +0000
commit0f9510c25c221b55b2f96ed4d4da88d69e33a3a0 (patch)
tree8f40743985c8c997e64f4f4a0413a7ce28d5dbf6 /app-office/dia/files
parentstable on amd64 (Manifest recommit) (diff)
downloadgentoo-2-0f9510c25c221b55b2f96ed4d4da88d69e33a3a0.tar.gz
gentoo-2-0f9510c25c221b55b2f96ed4d4da88d69e33a3a0.tar.bz2
gentoo-2-0f9510c25c221b55b2f96ed4d4da88d69e33a3a0.zip
add FT includes fix
Diffstat (limited to 'app-office/dia/files')
-rw-r--r--app-office/dia/files/dia-0.92.2-freetype_include.patch39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-office/dia/files/dia-0.92.2-freetype_include.patch b/app-office/dia/files/dia-0.92.2-freetype_include.patch
new file mode 100644
index 000000000000..fdadb9ab615d
--- /dev/null
+++ b/app-office/dia/files/dia-0.92.2-freetype_include.patch
@@ -0,0 +1,39 @@
+diff -Naur dia-0.92.2.origin/app/diapsft2renderer.c dia-0.92.2/app/diapsft2renderer.c
+--- dia-0.92.2.origin/app/diapsft2renderer.c 2003-08-25 17:15:03.000000000 +0200
++++ dia-0.92.2/app/diapsft2renderer.c 2004-03-08 19:51:29.706413024 +0100
+@@ -27,7 +27,8 @@
+ #include <pango/pango.h>
+ #include <pango/pangoft2.h>
+ /* I'd really rather avoid this */
+-#include <freetype/ftglyph.h>
++#include <ft2build.h>
++#include FT_GLYPH_H
+
+ #define DPI 300
+
+diff -Naur dia-0.92.2.origin/configure dia-0.92.2/configure
+--- dia-0.92.2.origin/configure 2003-11-01 12:26:01.000000000 +0100
++++ dia-0.92.2/configure 2004-03-08 23:00:20.733835024 +0100
+@@ -20119,7 +20119,8 @@
+ cat confdefs.h >>conftest.$ac_ext
+ cat >>conftest.$ac_ext <<_ACEOF
+ /* end confdefs.h. */
+-#include <freetype/freetype.h>
++#include <ft2build.h>
++#include FT_FREETYPE_H
+ #if (FREETYPE_MAJOR*1000+FREETYPE_MINOR)*1000+FREETYPE_PATCH < 2000009
+ #error Freetype version too low.
+ #endif
+diff -Naur dia-0.92.2.origin/configure.in dia-0.92.2/configure.in
+--- dia-0.92.2.origin/configure.in 2003-11-01 12:23:46.000000000 +0100
++++ dia-0.92.2/configure.in 2004-03-08 23:01:52.331910000 +0100
+@@ -69,7 +69,8 @@
+ AC_MSG_CHECKING([if FreeType version is 2.0.9 or higher])
+ old_CPPFLAGS="$CPPFLAGS"
+ CPPFLAGS="$CPPFLAGS `freetype-config --cflags`"
+- AC_TRY_CPP([#include <freetype/freetype.h>
++ AC_TRY_CPP([#include <ft2build.h>
++#include FT_FREETYPE_H
+ #if (FREETYPE_MAJOR*1000+FREETYPE_MINOR)*1000+FREETYPE_PATCH < 2000009
+ #error Freetype version too low.
+ #endif