summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2014-07-24 17:54:55 +0000
committerHanno Böck <hanno@gentoo.org>2014-07-24 17:54:55 +0000
commit3653bee719e07582d4160b0e3a0f155dbd2b75f0 (patch)
tree3da9e8e55e92b44d4c8599b528ceeba9aec150f3 /app-office/geierlein/geierlein-0.6.2.ebuild
parentMark stable for arm64/m68k/s390/sh. (diff)
downloadgentoo-2-3653bee719e07582d4160b0e3a0f155dbd2b75f0.tar.gz
gentoo-2-3653bee719e07582d4160b0e3a0f155dbd2b75f0.tar.bz2
gentoo-2-3653bee719e07582d4160b0e3a0f155dbd2b75f0.zip
geierlein bump, remove old
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xA5880072BBB51E42)
Diffstat (limited to 'app-office/geierlein/geierlein-0.6.2.ebuild')
-rw-r--r--app-office/geierlein/geierlein-0.6.2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-office/geierlein/geierlein-0.6.2.ebuild b/app-office/geierlein/geierlein-0.6.2.ebuild
new file mode 100644
index 000000000000..ca142425bc48
--- /dev/null
+++ b/app-office/geierlein/geierlein-0.6.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/geierlein/geierlein-0.6.2.ebuild,v 1.1 2014/07/24 17:54:55 hanno Exp $
+
+EAPI=5
+
+DESCRIPTION="Submit tax forms (Umsatzsteuervoranmeldung) to the german digital tax project ELSTER."
+HOMEPAGE="http://stesie.github.com/geierlein/"
+SRC_URI="https://github.com/stesie/geierlein/archive/V${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+RDEPEND="|| ( www-client/firefox www-client/firefox-bin )"
+DEPEND=""
+
+# needs nodejs and a couple of modules we don't have packaged
+RESTRICT="test"
+
+src_compile() {
+ emake prefix=/usr
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ prefix=/usr \
+ install || die
+ dodoc README.md
+}