summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2009-07-04 05:38:46 +0000
committerTorsten Veller <tove@gentoo.org>2009-07-04 05:38:46 +0000
commitf90b6d2c71f1ecece2bb049cc03e0f6b8fc995d2 (patch)
treebdb5ef8b6e2f324db29c21dbe44faa95a482b0cd /app-office/gnucash
parentRemove old development versions (diff)
downloadgentoo-2-f90b6d2c71f1ecece2bb049cc03e0f6b8fc995d2.tar.gz
gentoo-2-f90b6d2c71f1ecece2bb049cc03e0f6b8fc995d2.tar.bz2
gentoo-2-f90b6d2c71f1ecece2bb049cc03e0f6b8fc995d2.zip
Fix for aqbanking-4.0.0. Thanks to Patrick Beckmann (#275413)
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'app-office/gnucash')
-rw-r--r--app-office/gnucash/ChangeLog6
-rw-r--r--app-office/gnucash/files/r18166-to-r18167.diff16
-rw-r--r--app-office/gnucash/gnucash-2.2.9-r1.ebuild7
3 files changed, 27 insertions, 2 deletions
diff --git a/app-office/gnucash/ChangeLog b/app-office/gnucash/ChangeLog
index 4d3cf74dc211..ad3c04008c1c 100644
--- a/app-office/gnucash/ChangeLog
+++ b/app-office/gnucash/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-office/gnucash
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/gnucash/ChangeLog,v 1.192 2009/06/27 10:47:23 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnucash/ChangeLog,v 1.193 2009/07/04 05:38:46 tove Exp $
+
+ 04 Jul 2009; Torsten Veller <tove@gentoo.org>
+ +files/r18166-to-r18167.diff, gnucash-2.2.9-r1.ebuild:
+ Fix for aqbanking-4.0.0. Thanks to Patrick Beckmann (#275413)
27 Jun 2009; Torsten Veller <tove@gentoo.org> gnucash-2.3.1.ebuild:
Add ~alpha again after #271285 was resolved
diff --git a/app-office/gnucash/files/r18166-to-r18167.diff b/app-office/gnucash/files/r18166-to-r18167.diff
new file mode 100644
index 000000000000..4dcb47ba242d
--- /dev/null
+++ b/app-office/gnucash/files/r18166-to-r18167.diff
@@ -0,0 +1,16 @@
+bug 275413
+http://svn.gnucash.org/trac/changeset?format=diff&new=18167&old=18166
+--- src/import-export/aqbanking/gnc-ab-transfer.c
++++ src/import-export/aqbanking/gnc-ab-transfer.c
+@@ -237,4 +237,11 @@
+ context = AB_ImExporterContext_new();
+
++ gui = gnc_GWEN_Gui_get(parent);
++ if (!gui) {
++ g_warning("gnc_ab_maketrans: Couldn't initialize Gwenhywfar GUI");
++ aborted = TRUE;
++ goto repeat;
++ }
++
+ /* Finally, execute the job */
+ AB_Banking_ExecuteJobs(api, job_list, context, 0);
diff --git a/app-office/gnucash/gnucash-2.2.9-r1.ebuild b/app-office/gnucash/gnucash-2.2.9-r1.ebuild
index 0924554f7fcb..ba0bb83d2a8a 100644
--- a/app-office/gnucash/gnucash-2.2.9-r1.ebuild
+++ b/app-office/gnucash/gnucash-2.2.9-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/gnucash/gnucash-2.2.9-r1.ebuild,v 1.3 2009/06/11 21:35:57 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnucash/gnucash-2.2.9-r1.ebuild,v 1.4 2009/07/04 05:38:46 tove Exp $
EAPI=2
@@ -67,6 +67,11 @@ pkg_setup() {
--disable-error-on-warning"
}
+src_prepare() {
+ epatch "${FILESDIR}"/r18166-to-r18167.diff
+ gnome2_src_prepare
+}
+
src_test() {
GUILE_WARN_DEPRECATED=no \
GNC_DOT_DIR="${T}"/.gnucash \